[PATCH 12/13] gnu: Add go-github-com-json-iterator-go

  • Done
  • quality assurance status badge
Details
3 participants
  • Fries
  • Maxim Cournoyer
  • (
Owner
unassigned
Submitted by
Fries
Severity
normal
Merged with
F
F
Fries wrote on 5 Aug 2023 09:01
(address . guix-patches@gnu.org)(name . Fries)(address . fries1234@protonmail.com)
70ee9566b6562ea36a20f1ae2d6b79e3349f6e34.1691218710.git.fries1234@protonmail.com
* gnu/packages/golang.scm (go-github-com-json-iterator-go): Add variable.
---
gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9b38ed4daf..b08e7060fc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4386,6 +4386,39 @@ (define-public go-github-com-goccy-go-json
"Fast JSON encoder/decoder compatible with encoding/json for Go.")
(license license:expat)))
+(define-public go-github-com-json-iterator-go
+ (package
+ (name "go-github-com-json-iterator-go")
+ (version "1.1.12")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/json-iterator/go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c8f0hxm18wivx31bs615x3vxs2j3ba0v6vxchsjhldc8kl311bz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/json-iterator/go"))
+ (propagated-inputs
+ `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+ ("go-github-com-modern-go-reflect2" ,go-github-com-modern-go-reflect2)
+ ("go-github-com-modern-go-concurrent" ,go-github-com-modern-go-concurrent)
+ ("go-github-com-google-gofuzz" ,go-github-com-google-gofuzz)
+ ("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)))
+ (home-page "https://github.com/json-iterator/go")
+ (synopsis "High-performance, 100% compatible drop-in replacement of encoding/json")
+ (description
+ "Package jsoniter implements encoding and decoding of JSON as defined in
+@uref{https://rfc-editor.org/rfc/rfc4627.html,RFC 4627} and provides interfaces
+with identical syntax of standard lib encoding/json. Converting from
+encoding/json to jsoniter is no more than replacing the package with jsoniter
+and variable type declarations (if any). jsoniter interfaces gives 100%
+compatibility with code using standard lib.")
+ (license license:expat)))
+
(define-public go-github-com-getsentry-raven-go
(let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
(revision "0"))
--
2.41.0
(
(name . Fries)(address . fries1234@protonmail.com)
87jzu9q1r0.fsf@disroot.org
Fries via Guix-patches via <guix-patches@gnu.org> writes:
Toggle quote (3 lines)
> + (arguments
> + '(#:import-path "github.com/json-iterator/go"))

LIST.

Toggle quote (7 lines)
> + (propagated-inputs
> + `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
> + ("go-github-com-modern-go-reflect2" ,go-github-com-modern-go-reflect2)
> + ("go-github-com-modern-go-concurrent" ,go-github-com-modern-go-concurrent)
> + ("go-github-com-google-gofuzz" ,go-github-com-google-gofuzz)
> + ("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)))

LIST.

Toggle quote (3 lines)
> + (synopsis "High-performance, 100% compatible drop-in replacement of encoding/json")

s/of/for/

Toggle quote (3 lines)
> + (description
> + "Package jsoniter implements encoding and decoding of JSON as defined in

s/Package jsoniter/This package/

-- (
F
F
Fries wrote on 5 Aug 2023 11:30
Merge bugs
(address . control@debbugs.gnu.org)
6131230.DvuYhMxLoT@pc
merge 65075 65072 65076 65073 65078 65077 65079 65082 65080 65081 65084 65085 65083 65074
# accidently sent my patch series to the mailing list instead the cover letters bug
quit
F
F
Fries wrote on 6 Aug 2023 01:13
More cleanly merge bugs
(address . control@debbugs.gnu.org)
5713201.DvuYhMxLoT@pc
unmerge 65072
unmerge 65073
unmerge 65075
unmerge 65076
unmerge 65077
unmerge 65078
unmerge 65079
unmerge 65080
unmerge 65081
unmerge 65082
unmerge 65083
unmerge 65084
unmerge 65085
unmerge 65074
merge 65075 65074
merge 65072 65074
merge 65076 65074
merge 65073 65074
merge 65078 65074
merge 65077 65074
merge 65079 65074
merge 65082 65074
merge 65080 65074
merge 65081 65074
merge 65084 65074
merge 65085 65074
merge 65083 65074
# try to merge all the bugs with just 65074 instead of merging with all of themselves
stop
M
M
Maxim Cournoyer wrote on 1 Sep 2023 14:08
Re: bug#65085: [PATCH 12/13] gnu: Add go-github-com-json-iterator-go
(name . Fries)(address . fries1234@protonmail.com)
87wmxa3xl5.fsf_-_@gmail.com
tags 65072 + moreinfo
quit

Hi Fries,

Thank you for your contribution.

Fries <fries1234@protonmail.com> writes:

Toggle quote (34 lines)
> * gnu/packages/golang.scm (go-github-com-chyzer-test): New variable.
> ---
> gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index d99f76dc7d..ef82f0aa1b 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -2113,6 +2113,32 @@ (define-public go-github-com-dhowett-go-plist
> types.")
> (license license:giftware))))
>
> +(define-public go-github-com-chzyer-test
> + (package
> + (name "go-github-com-chzyer-test")
> + (version "1.0.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/chzyer/test")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/chzyer/test"
> + #:phases
> + ;; Tests relating to a in-memory disk fail due to a Segfault.
> + (modify-phases %standard-phases
> + (delete 'check))))

This should be minimally investigated, and ideally an issue created on
upstream issue tracker and an URL added next to the comment to track its
resolution, e.g:

;; Tests relating to a in-memory disk fail due to a segfault (see:
;; $URL).

Also taking the comments from parens into account, could you please send
a v2 to this same issue (65072@debbugs.gnu.org) ?

--
Thanks,
Maxim
?