[PATCH 13/13] gnu: Add scc

  • Done
  • quality assurance status badge
Details
3 participants
  • Fries
  • Maxim Cournoyer
  • (
Owner
unassigned
Submitted by
Fries
Severity
normal
Merged with
F
F
Fries wrote on 5 Aug 2023 09:01
(address . guix-patches@gnu.org)(name . Fries)(address . fries1234@protonmail.com)
31eb7dc018e2c47bd0c880291284e32cc2177ced.1691218710.git.fries1234@protonmail.com
* gnu/packages/code.scm (scc): New variable.
---
gnu/packages/code.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 9cdda2b751..6a74d1a9ca 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -44,6 +44,7 @@ (define-module (gnu packages code)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system go)
#:use-module (gnu packages)
#:use-module (gnu packages autogen)
#:use-module (gnu packages autotools)
@@ -373,6 +374,41 @@ (define-public cloc
cloc can handle a greater variety of programming languages.")
(license license:gpl2+)))
+(define-public scc
+ (package
+ (name "scc")
+ (version "3.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/boyter/scc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rkkfg6jimlc2rkajk6ypd5v0m3zai25ga5idz2pmkmzakv82n21"))))
+ (build-system go-build-system)
+ (native-inputs (list go-github-com-dbaggerman-cuba
+ go-github-com-json-iterator-go
+ go-github-com-mattn-go-runewidth
+ go-github-com-minio-blake2b-simd
+ go-github-com-spf13-cobra
+ go-golang-org-x-text
+ go-gopkg-in-yaml-v2))
+ (arguments
+ `(#:import-path "github.com/boyter/scc"))
+ (home-page "https://github.com/boyter/scc")
+ (synopsis "Very fast accurate code counter written in pure Go")
+ (description
+ "A tool similar to cloc, sloccount and tokei.
+For counting the lines of code, blank lines, comment lines, and
+physical lines of source code in many programming languages.
+
+Goal is to be the fastest code counter possible, but also
+perform COCOMO calculation like sloccount and to estimate
+code complexity similar to cyclomatic complexity calculators.")
+ (license license:expat)))
+
(define-public the-silver-searcher
(package
(name "the-silver-searcher")
--
2.41.0
(
(name . Fries)(address . fries1234@protonmail.com)
87a5v5q047.fsf@disroot.org
Fries via Guix-patches via <guix-patches@gnu.org> writes:
Toggle quote (8 lines)
> + (native-inputs (list go-github-com-dbaggerman-cuba
> + go-github-com-json-iterator-go
> + go-github-com-mattn-go-runewidth
> + go-github-com-minio-blake2b-simd
> + go-github-com-spf13-cobra
> + go-golang-org-x-text
> + go-gopkg-in-yaml-v2))

s/native-inputs/inputs/, except for the packages used in tests, if any.

Toggle quote (3 lines)
> + (arguments
> + `(#:import-path "github.com/boyter/scc"))

LIST.

Toggle quote (3 lines)
> + (synopsis "Very fast accurate code counter written in pure Go")

Maybe:

(synopsis "Fast code counter written in Go")

Toggle quote (9 lines)
> + (description
> + "A tool similar to cloc, sloccount and tokei.
> +For counting the lines of code, blank lines, comment lines, and
> +physical lines of source code in many programming languages.
> +
> +Goal is to be the fastest code counter possible, but also
> +perform COCOMO calculation like sloccount and to estimate
> +code complexity similar to cyclomatic complexity calculators.")

(description
"@command{scc} provides a lines-of-code counter similar to tools like
@command{cloc} and @command{sloccount}. It aims to be as fast as
possible while supporting @acronym{COCOMO,Constructive Cost Model}
calculation and estimation of code complexity.")
(
(name . ()(address . paren@disroot.org)
875y5tq01j.fsf@disroot.org
"(" <paren@disroot.org> writes:
Toggle quote (5 lines)
> (description
> "@command{scc} provides a lines-of-code counter similar to tools like
> @command{cloc} and @command{sloccount}. It aims to be as fast as
> possible while

Agh. Should be:

(description
"@command{scc} provides a lines-of-code counter similar to tools like
@command{cloc} and @command{sloccount}. It aims to be as fast as
possible while supporting @acronym{COCOMO,Constructive Cost Model}
calculation and code complexity estimation.")

-- (
F
F
Fries wrote on 5 Aug 2023 11:30
Merge bugs
(address . control@debbugs.gnu.org)
6131230.DvuYhMxLoT@pc
merge 65075 65072 65076 65073 65078 65077 65079 65082 65080 65081 65084 65085 65083 65074
# accidently sent my patch series to the mailing list instead the cover letters bug
quit
F
F
Fries wrote on 6 Aug 2023 01:13
More cleanly merge bugs
(address . control@debbugs.gnu.org)
5713201.DvuYhMxLoT@pc
unmerge 65072
unmerge 65073
unmerge 65075
unmerge 65076
unmerge 65077
unmerge 65078
unmerge 65079
unmerge 65080
unmerge 65081
unmerge 65082
unmerge 65083
unmerge 65084
unmerge 65085
unmerge 65074
merge 65075 65074
merge 65072 65074
merge 65076 65074
merge 65073 65074
merge 65078 65074
merge 65077 65074
merge 65079 65074
merge 65082 65074
merge 65080 65074
merge 65081 65074
merge 65084 65074
merge 65085 65074
merge 65083 65074
# try to merge all the bugs with just 65074 instead of merging with all of themselves
stop
M
M
Maxim Cournoyer wrote on 1 Sep 2023 14:08
Re: bug#65085: [PATCH 12/13] gnu: Add go-github-com-json-iterator-go
(name . Fries)(address . fries1234@protonmail.com)
87wmxa3xl5.fsf_-_@gmail.com
tags 65072 + moreinfo
quit

Hi Fries,

Thank you for your contribution.

Fries <fries1234@protonmail.com> writes:

Toggle quote (34 lines)
> * gnu/packages/golang.scm (go-github-com-chyzer-test): New variable.
> ---
> gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index d99f76dc7d..ef82f0aa1b 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -2113,6 +2113,32 @@ (define-public go-github-com-dhowett-go-plist
> types.")
> (license license:giftware))))
>
> +(define-public go-github-com-chzyer-test
> + (package
> + (name "go-github-com-chzyer-test")
> + (version "1.0.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/chzyer/test")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/chzyer/test"
> + #:phases
> + ;; Tests relating to a in-memory disk fail due to a Segfault.
> + (modify-phases %standard-phases
> + (delete 'check))))

This should be minimally investigated, and ideally an issue created on
upstream issue tracker and an URL added next to the comment to track its
resolution, e.g:

;; Tests relating to a in-memory disk fail due to a segfault (see:
;; $URL).

Also taking the comments from parens into account, could you please send
a v2 to this same issue (65072@debbugs.gnu.org) ?

--
Thanks,
Maxim
?