[PATCH 04/13] gnu: Add go-github-com-ianlancetaylor-demangle

  • Done
  • quality assurance status badge
Details
4 participants
  • Fries
  • Maxim Cournoyer
  • (
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Fries
Severity
normal
Merged with
F
F
Fries wrote on 5 Aug 2023 09:00
(address . guix-patches@gnu.org)(name . Fries)(address . fries1234@protonmail.com)
462388f546dbb543bbf044d2c12f5020e9d114c2.1691218710.git.fries1234@protonmail.com
* gnu/packages/golang.scm (go-github-com-ianlancetaylor-demangle): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1a6d64de23..5df38a02e5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,31 @@ (define-public go-github-com-dhowett-go-plist
types.")
(license license:giftware))))
+(define-public go-github-com-ianlancetaylor-demangle
+ (package
+ (name "go-github-com-ianlancetaylor-demangle")
+ (version "0.0.0-20230524184225-eabc099b10ab")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ianlancetaylor/demangle")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pvlg1adp50hnw8dz7il473xb197ixirg26cy5hj3ngb4qlajwvc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/ianlancetaylor/demangle"))
+ (home-page "https://github.com/ianlancetaylor/demangle")
+ (synopsis "Symbol name demangler written in Go")
+ (description
+ "Package demangle defines functions that demangle GCC/LLVM C++ and Rust symbol
+names. This package recognizes names that were mangled according to the C++ ABI
+defined at https://codesourcery.com/cxx-abi/ and the Rust ABI defined at
+https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html.")
+ (license license:bsd-3)))
+
(define-public go-github-com-chzyer-readline
(package
(name "go-github-com-chzyer-readline")
--
2.41.0
(
(name . Fries)(address . fries1234@protonmail.com)
87leeprgpt.fsf@disroot.org
Fries via Guix-patches via <guix-patches@gnu.org> writes:
Toggle quote (4 lines)
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/ianlancetaylor/demangle"))

LIST

Toggle quote (5 lines)
> + (synopsis "Symbol name demangler written in Go")
> + (description
> + "Package demangle defines functions that demangle GCC/LLVM C++ and Rust symbol

s/Package demangle/This package/

Go developers no know much of grammars.

-- (
F
F
Fries wrote on 5 Aug 2023 11:30
Merge bugs
(address . control@debbugs.gnu.org)
6131230.DvuYhMxLoT@pc
merge 65075 65072 65076 65073 65078 65077 65079 65082 65080 65081 65084 65085 65083 65074
# accidently sent my patch series to the mailing list instead the cover letters bug
quit
F
F
Fries wrote on 6 Aug 2023 01:13
More cleanly merge bugs
(address . control@debbugs.gnu.org)
5713201.DvuYhMxLoT@pc
unmerge 65072
unmerge 65073
unmerge 65075
unmerge 65076
unmerge 65077
unmerge 65078
unmerge 65079
unmerge 65080
unmerge 65081
unmerge 65082
unmerge 65083
unmerge 65084
unmerge 65085
unmerge 65074
merge 65075 65074
merge 65072 65074
merge 65076 65074
merge 65073 65074
merge 65078 65074
merge 65077 65074
merge 65079 65074
merge 65082 65074
merge 65080 65074
merge 65081 65074
merge 65084 65074
merge 65085 65074
merge 65083 65074
# try to merge all the bugs with just 65074 instead of merging with all of themselves
stop
M
M
Maxim Cournoyer wrote on 1 Sep 2023 14:08
Re: bug#65085: [PATCH 12/13] gnu: Add go-github-com-json-iterator-go
(name . Fries)(address . fries1234@protonmail.com)
87wmxa3xl5.fsf_-_@gmail.com
tags 65072 + moreinfo
quit

Hi Fries,

Thank you for your contribution.

Fries <fries1234@protonmail.com> writes:

Toggle quote (34 lines)
> * gnu/packages/golang.scm (go-github-com-chyzer-test): New variable.
> ---
> gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index d99f76dc7d..ef82f0aa1b 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -2113,6 +2113,32 @@ (define-public go-github-com-dhowett-go-plist
> types.")
> (license license:giftware))))
>
> +(define-public go-github-com-chzyer-test
> + (package
> + (name "go-github-com-chzyer-test")
> + (version "1.0.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/chzyer/test")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/chzyer/test"
> + #:phases
> + ;; Tests relating to a in-memory disk fail due to a Segfault.
> + (modify-phases %standard-phases
> + (delete 'check))))

This should be minimally investigated, and ideally an issue created on
upstream issue tracker and an URL added next to the comment to track its
resolution, e.g:

;; Tests relating to a in-memory disk fail due to a segfault (see:
;; $URL).

Also taking the comments from parens into account, could you please send
a v2 to this same issue (65072@debbugs.gnu.org) ?

--
Thanks,
Maxim
S
S
Sharlatan Hellseher wrote on 6 Apr 17:53 +0200
[PATCH 04/13] gnu: Add go-github-com-ianlancetaylor-demangle
(address . 65073-done@debbugs.gnu.org)
87o7ammqr2.fsf@gmail.com
Pushed as c28b319640..cf4f87986a to master by closing

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYRcBEACgkQdtcnv/Ys
0rUXRBAAv5GwKtViutT8fURSkiIb86a1d6oF+UjKvlD/v0g0QQ1Ti3GP+9B+OKZ1
fLzioCTDlRClgEi82kdUvIoVoVyUgP0eYGk+taB7gBki+plwSTLkvwfLcEUy4u2o
UwZFz88Rjb7WtGk4cwuEqKcu3e2CIiFFz7MMjDD4IKx13g8CuFTuQ8x4O/NRDnrF
VY+myGxi0eclP5aGvBUbjWAGbpSaZVsy+XqEXS53HhMhXqeYxQfP8ST3ux8sHW7v
v0Z56d9uH8yXpoqbZG7qGyPFfO7fCFDE36Wis92z+rHyh6f+GcsoDkvNTRFCz7d7
hN+wf7Jw0IHrWR+mehGeB7pcERXHo7s+slpwQNUK7xB2fu+T9ErhfifhoYE29h+j
7yhFeLAkjBTQrMx3LksDaaR9g+6KvBh6n0UVIRHAzaRACgTNOA5k/M1BOZhGrB+0
lJjILntRyhOxWrKYuQjoxyvpLL5kKBetpj/Vi4hhCMJoGVI63UvgiGIw7tZTm48F
SBRFyWoiPCuhqml3pywYXj1U1PKAUj2MwGJb0ckLvGbNVo8xPBUjmXeDEe3WYHd8
e3ntqvyv9HyEsHX4TF3ZEPgfana1eLfMZmhSOJ1TsRXsNmUwiKixa6M6htch7Ne2
wD5xZx4c71TRjd3fH+Yoq6J26+Zdk4yMmvp39+BWwBr1clNnFK8=
=cwE4
-----END PGP SIGNATURE-----

Closed
?