[PATCH 2/5] gnu: Add python-pymarshal.

  • Open
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 18 Aug 2023 17:35
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
edad4fb8bdf65ecc65734f2510b2edeecf6d28a2.1692372645.git.sughosha@disroot.org
* gnu/packages/python-xyz.scm (python-pymarshal): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f8c976753..67721666ec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30686,6 +30686,28 @@ (define-public python-peachpy
supports x86_64 instructions up to AVX-512 and SHA.")
(license license:bsd-2))))
+(define-public python-pymarshal
+ (package
+ (name "python-pymarshal")
+ (version "2.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pymarshal" version))
+ (sha256
+ (base32
+ "1lhb7yim60pvclbd440zd4n50xs1d2rvmnrhhvib3hyv0dxil5j3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ;fails due to unrecognized arguments
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs (list python-bson python-pyyaml))
+ (home-page "https://gitlab.com/d3v-t00lz/pymarshal")
+ (synopsis "Pythonic implementation of Golang struct (un)marshalling")
+ (description "PyMarshal replicates the feature of (un)marshalling structs
+in Golang.")
+ (license license:bsd-2)))
+
(define-public python-sgmllib3k
(let ((commit "799964676f35349ca2dd04503e34c2b3ad522c0d")
(revision "1"))
--
2.41.0
C
C
Christopher Baines wrote on 13 Oct 2023 11:48
(no subject)
(address . control@debbugs.gnu.org)
87bkd297l3.fsf@cbaines.net
merge 65367 65368 65369
thanks
?