[PATCH 1/5] gnu: Add python-wavefile.

  • Open
  • quality assurance status badge
Details
3 participants
  • Christopher Baines
  • Sharlatan Hellseher
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 18 Aug 2023 17:35
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
3364f152e8f31e4ec06d8e9bb0c126a1f59e1d70.1692372644.git.sughosha@disroot.org
* gnu/packages/python-xyz.scm (python-wavefile): New variable.
---
gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c5e170b628..7f8c976753 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -163,6 +163,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages algebra)
#:use-module (gnu packages astronomy)
#:use-module (gnu packages attr)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -230,6 +231,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages protobuf)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -1711,6 +1713,37 @@ (define-public python-pymediainfo
access the technical and tag data for video and audio files.")
(license license:expat)))
+(define-public python-wavefile
+ (package
+ (name "python-wavefile")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "wavefile" version))
+ (sha256
+ (base32
+ "02qcms8xx24r1d14idwyx04sw9ydp6rivff5s64hgp668mnfdar3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-libsndfile-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "wavefile/libsndfile.py"
+ (("libsndfile\\.so")
+ (search-input-file inputs "/lib/libsndfile.so")))))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "LD_LIBRARY_PATH" (getenv "LIBRARY_PATH")))))))
+ (inputs
+ (list libsndfile))
+ (propagated-inputs (list python-numpy python-pyaudio))
+ (home-page "https://github.com/vokimon/python-wavefile")
+ (synopsis "Pythonic wave file reader and writer")
+ (description "This package provides pythonic wave file reader and writer.")
+ (license license:gpl3+)))
+
(define-public python-psutil
(package
(name "python-psutil")
--
2.41.0
S
S
Sharlatan Hellseher wrote on 9 Oct 2023 01:50
(address . 65368@debbugs.gnu.org)
CAO+9K5rb4N5gg4k6tG1VyvdFqDbMGzSEG4+UspehQ4TvaDyyvg@mail.gmail.com
Hi,
It's mentioned 1/5 in the subject of the this issue. Are you planned
to send rest of the patches?
Patch looks ok from the first glance but description may be longer
take a look at project's README
be include some core features and description of what is Wevefile is.
Input missing portaudio19, check README.
Native inputs is missing which requires pytest according to GitHub Actions.
Thanks,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
C
C
Christopher Baines wrote on 13 Oct 2023 11:48
(address . control@debbugs.gnu.org)
87bkd297l3.fsf@cbaines.net
merge 65367 65368 65369
thanks
?