[PATCH] gnu: Add iwgtk.

  • Done
  • quality assurance status badge
Details
2 participants
  • James Smith
  • Z572
Owner
unassigned
Submitted by
James Smith
Severity
normal
J
J
James Smith wrote on 24 Apr 18:09 +0200
(address . guix-patches@gnu.org)(name . James Smith)(address . jsubuntuxp@disroot.org)
f8e832c998d1422863037f88fea360cb8d8b2ec3.1713974969.git.jsubuntuxp@disroot.org
* gnu/packages/networking.scm (iwgtk): New variable.

Change-Id: I8dc5446fda114f033c1e594028668af41cd5ec85
---
gnu/packages/networking.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9d657bc69d..dbc6280416 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,6 +100,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autogen)
@@ -144,6 +146,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages man)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages nettle)
@@ -4152,6 +4155,30 @@ (define-public iwd
maximum extent possible.")
(license license:lgpl2.1+)))
+(define-public iwgtk
+ (package
+ (name "iwgtk")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/J-Lentz/iwgtk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fvxq4ydhzisfn93pcqbspqqi8fwj45v8q104bkm4qfzhf5nvp7w"))))
+ (build-system meson-build-system)
+ (inputs (list gtk qrencode))
+ (native-inputs (list gettext-minimal pkg-config scdoc))
+ (home-page "https://github.com/J-Lentz/iwgtk")
+ (synopsis "Lightweight front-end for iwd")
+ (description "Wireless networking GUI front-end for iwd, with supported
+functionality similar to that of iwctl. Features include viewing and connecting
+to available networks, managing known networks, provisioning new networks via
+WPS or Wi-Fi Easy Connect, and an indicator icon displaying connection status
+and signal strength.")
+ (license license:gpl3+)))
+
(define-public libyang
(package
(name "libyang")

base-commit: 91d9e145e15241c20729a4f1fa43f3d662f6b806
--
2.41.0
Z
Z
Z572 wrote 4 days ago
(name . James Smith via Guix-patches via)(address . guix-patches@gnu.org)
875xvyvqt9.fsf@iscas.ac.cn
James Smith via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (69 lines)
> * gnu/packages/networking.scm (iwgtk): New variable.
>
> Change-Id: I8dc5446fda114f033c1e594028668af41cd5ec85
> ---
> gnu/packages/networking.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index 9d657bc69d..dbc6280416 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -64,6 +64,7 @@
> ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
> ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
> ;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
> +;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -99,6 +100,7 @@ (define-module (gnu packages networking)
> #:use-module (gnu packages)
> #:use-module (gnu packages admin)
> #:use-module (gnu packages adns)
> + #:use-module (gnu packages aidc)
> #:use-module (gnu packages algebra)
> #:use-module (gnu packages audio)
> #:use-module (gnu packages autogen)
> @@ -144,6 +146,7 @@ (define-module (gnu packages networking)
> #:use-module (gnu packages linux)
> #:use-module (gnu packages lua)
> #:use-module (gnu packages kerberos)
> + #:use-module (gnu packages man)
> #:use-module (gnu packages mpi)
> #:use-module (gnu packages ncurses)
> #:use-module (gnu packages nettle)
> @@ -4152,6 +4155,30 @@ (define-public iwd
> maximum extent possible.")
> (license license:lgpl2.1+)))
>
> +(define-public iwgtk
> + (package
> + (name "iwgtk")
> + (version "0.9")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference (url "https://github.com/J-Lentz/iwgtk")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1fvxq4ydhzisfn93pcqbspqqi8fwj45v8q104bkm4qfzhf5nvp7w"))))
> + (build-system meson-build-system)
> + (inputs (list gtk qrencode))
> + (native-inputs (list gettext-minimal pkg-config scdoc))
> + (home-page "https://github.com/J-Lentz/iwgtk")
> + (synopsis "Lightweight front-end for iwd")
> + (description "Wireless networking GUI front-end for iwd, with supported
> +functionality similar to that of iwctl. Features include viewing and connecting
> +to available networks, managing known networks, provisioning new networks via
> +WPS or Wi-Fi Easy Connect, and an indicator icon displaying connection status
> +and signal strength.")
> + (license license:gpl3+)))
> +
> (define-public libyang
> (package
> (name "libyang")
>
> base-commit: 91d9e145e15241c20729a4f1fa43f3d662f6b806

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmYxB4IACgkQO1qpk+Gi
3/B4nQ//emrfFwloSG/M9znbSyXXC0nqZirz2PjMEMIjY6jY5dxHrOPd2cYA8y3f
Z5AcoON2/av4KtPZk4eng9fnJtp5JWQ7uOUOcdxOXk1ysmB99EECAk75oFm3Zsc1
8Nk1eLTEyKPuPJoOXGiXASibumlyoiSzLKmvIQuw6csxJ3arLvyF2mMA+mVtf72p
97BEzSj/cM5ceRFsiWaESh2uGv0r4gpXManaMVV9wjkInOxHDCXN0r+bmZbzv0/7
RO+XTU2lGn10zdxSevGbgWY6lq3Ce9fTndOwh0l2+70odVv7z8ukxlDNRCCdHHET
LLSQ36H4y/HD6z2K5Qo4Qk5qjJeoguIyD5tEk4i007QswcBRUaVT0w80Mh1FpAmX
J+rJRJkShjADsgomy31+1156JbxpnxNWI1TQgA/U6QYLsNFXhQPSxAoO1vOPnv23
vTFtP8Zd9XdRl4jtlCIjt2uy2xhztWnOEGfArVUa+UYyyEIkvNQFhs+R1DANWDn/
hBs/oWUiTIP6oKg78DkcQKNPQ1TjSAVQ3tjLWNMw3+LQ7KRWMSRGwAEQP2eUN9f6
sSc/qx2dJAzh0MptcHgPNHx5uJ2WHnbODlmmIG9c8lzfrraQLylVm8EuOc3C7Odk
5O7w2mRvDkUWwefAnOCh3l3WSyhZP6ptI1OxZXqbCq19TiuCmNw=
=yfa2
-----END PGP SIGNATURE-----

?