[PATCH] gnu: cairo: Fix cross-compilation.

  • Open
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 24 Apr 05:17 +0200
(address . guix-patches@gnu.org)
c496085ed765e3e8cc037c0f9fa86d79b9871bf4.1713928638.git.zhengjunjie@iscas.ac.cn
* gnu/packages/gtk.scm (cairo)[arguments]: When
cross-compilation, Add fix-cross-compile phase.

Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
---
gnu/packages/gtk.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..8fcd3ed1f3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
@@ -182,7 +182,19 @@ (define cairo
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:glib-or-gtk? #t
#:configure-flags
- (list "-Dtests=disabled")))
+ (list "-Dtests=disabled")
+ ,@(if (%current-target-system)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compile
+ (lambda _
+ ;; XXX: Let meson-build-system can customize the property
+ (substitute* "meson.build"
+ (("'ipc_rmid_deferred_release', 'auto'")
+ ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
+ ;; XXX: check it on hurd.
+ "'ipc_rmid_deferred_release', 'true'"))))))
+ '())))
(native-inputs
`(,@(if (target-hurd?)
'()

base-commit: d115af1bcc48f07a40dafd94d1d00926d446d068
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Apr 06:18 +0200
ecc1fb038795ddab619748497f3120a59bc882f5.camel@gmail.com
Am Mittwoch, dem 24.04.2024 um 11:17 +0800 schrieb Zheng Junjie:
Toggle quote (5 lines)
> * gnu/packages/gtk.scm (cairo)[arguments]: When
> cross-compilation, Add fix-cross-compile phase.
>
> Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
> ---
Haven't checked that it works yet, but at least lexically it LGTM.
For the commit message – particularly the ChangeLog portion – I'd say
"Add ‘fix-cross-compilation’ phase when cross-compiling." and adjust
the phase name accordingly.

Cheers
Z
Z
Zheng Junjie wrote on 24 Apr 06:34 +0200
[PATCH v2] gnu: cairo: Fix cross-compilation.
(address . 70546@debbugs.gnu.org)
e7e54c3b1fa933c57ceddcb2c2524cdcd5154fad.1713933265.git.zhengjunjie@iscas.ac.cn
* gnu/packages/gtk.scm (cairo)[arguments]: Add ‘fix-cross-compilation’ phase
when cross-compiling.

Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
---
gnu/packages/gtk.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..678bc89378 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
@@ -182,7 +182,19 @@ (define cairo
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:glib-or-gtk? #t
#:configure-flags
- (list "-Dtests=disabled")))
+ (list "-Dtests=disabled")
+ ,@(if (%current-target-system)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compilation
+ (lambda _
+ ;; XXX: Let meson-build-system can customize the property
+ (substitute* "meson.build"
+ (("'ipc_rmid_deferred_release', 'auto'")
+ ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
+ ;; XXX: check it on hurd.
+ "'ipc_rmid_deferred_release', 'true'"))))))
+ '())))
(native-inputs
`(,@(if (target-hurd?)
'()

base-commit: d115af1bcc48f07a40dafd94d1d00926d446d068
--
2.41.0
?