[Patch] gnu: Add r-lpsolveapi, r-roi, r-roi-plugin-lpsolve, r-detectseparation and r-metadeconfoundr.

  • Open
  • quality assurance status badge
Details
2 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 23 Apr 13:20 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
3c33811b4b1e44449256d3ffc64f33d8@mdc-berlin.de
* gnu/packages/cran.scm (r-lpsolveapi, r-roi, r-roi-plugin-lpsolve, r-detectseparation and r-metadeconfoundr): New variables.
Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 23 Apr 13:25 +0200
[PATCH 1/5] gnu: Add r-lpsolveapi.
(address . 70535@debbugs.gnu.org)
169f518d77f20df0bfa5f59d5e4a6d4cd7d2282b.1713871546.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-lpsolveapi): New variable.

Change-Id: I6a93603a5814df0eb43a214b5c2a0f4865901bcd
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ee0aac7f7a..4b6ece1eb1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8191,6 +8191,26 @@ (define-public r-lpsolve
transportation problems.")
(license license:lgpl2.0)))
+(define-public r-lpsolveapi
+ (package
+ (name "r-lpsolveapi")
+ (version "5.5.2.0-17.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lpSolveAPI" version))
+ (sha256
+ (base32 "191zjgyap3kcsvh8fygqqyr9p0agbzm160fzynnpaxf19yp6r3dh"))))
+ (properties `((upstream-name . "lpSolveAPI")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=lpSolveAPI")
+ (synopsis "Interface to lp_solve")
+ (description
+ "The lpSolveAPI package provides an R interface to lp_solve, a @acronym{MILP,
+Mixed Integer Linear Programming}, solver with support for pure linear, (mixed)
+integer/binary, semi-continuous and @acronym{SOS, special ordered sets} models.")
+ (license license:lgpl2.0)))
+
(define-public r-limsolve
(package
(name "r-limsolve")

base-commit: 2d19e505f6f9f82aebc9ba8c74ba223818acd9bc
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 23 Apr 13:25 +0200
[PATCH 2/5] gnu: Add r-roi.
(address . 70535@debbugs.gnu.org)
d4a15b3e6caf7bd9da7cb6fd9327fdca66bb79ec.1713871546.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-roi): New variable.

Change-Id: I58cbb4be238a5cc9f861ee9dafea03a133f7c0f1
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4b6ece1eb1..53a964e60a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12211,6 +12211,26 @@ (define-public r-randomizr
experimental designs and random samples for common sampling designs.")
(license license:expat)))
+(define-public r-roi
+ (package
+ (name "r-roi")
+ (version "1.0-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ROI" version))
+ (sha256
+ (base32 "05hnj9fskfm2klz7zv97lb0r60akjq4a1cay8p62whpi0hri9zyl"))))
+ (properties `((upstream-name . "ROI")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate r-registry r-slam))
+ (home-page "https://roi.r-forge.r-project.org/")
+ (synopsis "R optimization infrastructure")
+ (description
+ "The @acronym{ROI, R Optimization Infrastructure} is a framework for handling
+optimization problems in R.")
+ (license license:gpl3)))
+
(define-public r-roptim
(package
(name "r-roptim")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 23 Apr 13:25 +0200
[PATCH 3/5] gnu: Add r-roi-plugin-lpsolve.
(address . 70535@debbugs.gnu.org)
6e334ad253559aa7d65529fca177c4aa7e01b53f.1713871546.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-roi-plugin-lpsolve): New variable.

Change-Id: Ia3f47ba0b414ecd9273c101977ec8d14916fa656
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 53a964e60a..1fdd5eb685 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1680,6 +1680,26 @@ (define-public r-rocit
metrics.")
(license license:gpl3)))
+(define-public r-roi-plugin-lpsolve
+ (package
+ (name "r-roi-plugin-lpsolve")
+ (version "1.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ROI.plugin.lpsolve" version))
+ (sha256
+ (base32 "0xgg1fzq5sba3yvvrci3iw97p31walpnhv4zwnd39gw8v5z6f9dj"))))
+ (properties `((upstream-name . "ROI.plugin.lpsolve")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-lpsolveapi r-roi))
+ (home-page "https://roigrp.gitlab.io")
+ (synopsis "Plugin of lp_solve for the R optimization infrastructure")
+ (description
+ "This package enhances the @acronym{ROI, R Optimization Infrastructure} with
+the lp_solve solver.")
+ (license license:gpl3)))
+
(define-public r-rorcid
(package
(name "r-rorcid")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 23 Apr 13:25 +0200
[PATCH 4/5] gnu: Add r-detectseparation.
(address . 70535@debbugs.gnu.org)
4fb130e4a11b7a2214afa52b45b0b49635d00a36.1713871546.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-detectseparation): New variable.

Change-Id: I6c795719c22a6ff929785e799f749ce053e83fbe
---
gnu/packages/cran.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1fdd5eb685..57dabc8ec3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4253,6 +4253,38 @@ (define-public r-depmixs4
mixture models.")
(license license:gpl2+)))
+(define-public r-detectseparation
+ (package
+ (name "r-detectseparation")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "detectseparation" version))
+ (sha256
+ (base32 "05z3p1z5mhmdj5qdknz1b8f6fwbghzckl88pv79v59cfwpbvgmz8"))))
+ (properties `((upstream-name . "detectseparation")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-lpsolveapi r-pkgload r-roi r-roi-plugin-lpsolve))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ikosmidis/detectseparation")
+ (synopsis
+ "Detect and check for separation and infinite maximum likelihood estimates")
+ (description
+ "This package provides pre-fit and post-fit methods for detecting separation
+and infinite maximum likelihood estimates in generalized linear models with
+categorical responses. The pre-fit methods apply on binomial-response generalized
+liner models such as logit, probit and cloglog regression, and can be directly
+supplied as fitting methods to the @code{glm()} function. The post-fit methods
+apply to models with categorical responses, including binomial-response
+generalized linear models and multinomial-response models, such as baseline
+category logits and adjacent category logits models; for example, the models
+implemented in the brglm2 package. The post-fit methods successively refit the
+model with increasing number of iteratively reweighted least squares iterations,
+and monitor the ratio of the estimated standard error for each parameter to what
+it has been in the first iteration.")
+ (license license:gpl3)))
+
(define-public r-readxl
(package
(name "r-readxl")
--
2.41.0
M
M
M?d?lin Ionel Patra?cu wrote on 23 Apr 13:25 +0200
[PATCH 5/5] gnu: Add r-metadeconfoundr.
(address . 70535@debbugs.gnu.org)
bda80f881fb9f31f0c0a694237c7876c6d36dea9.1713871546.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-metadeconfoundr): New variable.

Change-Id: I733fb464d2a3c7fd1335826be9f23e2610e6fd60
---
gnu/packages/cran.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 57dabc8ec3..46749aa714 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -41612,6 +41612,47 @@ (define-public r-metadat
analyses.")
(license license:gpl2+)))
+(define-public r-metadeconfoundr
+ ;; There are some consistent updates after the release of version 0.3.0.
+ (let ((commit "90aec0226c5128bfcbbc08903452eff460d21424")
+ (revision "1"))
+ (package
+ (name "r-metadeconfoundr")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TillBirkner/metadeconfoundR")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zkqar27p5qwq46xbxsw5x1pl50xbkgqiizw5bydlyhwb0ga2f3h"))))
+ (properties `((upstream-name . "metadeconfoundR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bigmemory
+ r-detectseparation
+ r-doparallel
+ r-dosnow
+ r-foreach
+ r-futile-logger
+ r-ggplot2
+ r-lme4
+ r-lmtest
+ r-reshape2
+ r-snow))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/TillBirkner/metadeconfoundR")
+ (synopsis "Check multiple covariates for potenial confounding effects")
+ (description
+ "This package detects naive associations between omics features and
+metadata in cross-sectional data-sets using non-parametric tests. In a second
+step, confounding effects between metadata associated to the same omics feature
+are detected and labeled using nested post-hoc model comparison tests. The
+generated output can be graphically summarized using the built-in plotting
+function.")
+ (license license:gpl2))))
+
(define-public r-mathjaxr
(package
(name "r-mathjaxr")
--
2.41.0
?