[PATCH] services: sddm: Disable wayland display-service

  • Open
  • quality assurance status badge
Details
One participant
  • Feng Shu
Owner
unassigned
Submitted by
Feng Shu
Severity
normal
F
F
Feng Shu wrote on 23 Apr 09:08 +0200
(name . guix-patches)(address . guix-patches@gnu.org)
87le5436ah.fsf@163.com
From 97e36b18e3eefdf5d5fa86caf55383ad219b0340 Mon Sep 17 00:00:00 2001
From: Feng Shu <tumashu@163.com>
Date: Tue, 23 Apr 2024 14:37:13 +0800
Subject: [PATCH] services: sddm: Disable wayland display-service

* gnu/services/sddm.scm (<sddm-configuration>): wayland is not walid value of
display-server.

(sddm-configuration-file): do not use sddm-configuration-display-server at the
moment, for user config: (display-server "wayland"), will let user's addm show
blank screen when sddm update to 0.20.

* doc/guix.texi (X Window): update display-server doc of sddm-service-type.

Change-Id: I75354eb75f54263389e5839e152fb85d4351aece
---
doc/guix.texi | 4 ++--
gnu/services/sddm.scm | 12 +++++++++---
2 files changed, 11 insertions(+), 5 deletions(-)

Toggle diff (49 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 04e33da1a9..5abdd84d24 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -23160,8 +23160,8 @@ The available fields are:
The SDDM package to use.
@item @code{display-server} (default: "x11")
-Select display server to use for the greeter. Valid values are
-@samp{"x11"} or @samp{"wayland"}.
+Select display server to use for the greeter. Valid value is
+@samp{"x11"}, currently do not support @samp{"x11-user"} and @samp{"wayland"}.
@item @code{numlock} (default: "on")
Valid values are @samp{"on"}, @samp{"off"} or @samp{"none"}.
diff --git a/gnu/services/sddm.scm b/gnu/services/sddm.scm
index 48695e2806..a0859ccca5 100644
--- a/gnu/services/sddm.scm
+++ b/gnu/services/sddm.scm
@@ -45,8 +45,7 @@ (define-record-type* <sddm-configuration>
(default sddm))
;; [General]
- ;; valid values are x11 and wayland
- ;; currently doesn't do anything is enabled by wayland greeter PR
+ ;; valid values is x11, currently do not support x11-user and wayland.
(display-server sddm-configuration-display-server
(default "x11"))
;; valid values are on, off or none
@@ -117,7 +116,14 @@ (define-record-type* <sddm-configuration>
(define (sddm-configuration-file config)
(mixed-text-file "sddm.conf" "
[General]
-DisplayServer=" (sddm-configuration-display-server config) "
+DisplayServer=" (or "x11"
+ ;; sddm-0.20 begin support x11-user and wayland
+ ;; value, but sddm-service-type do not support them
+ ;; at the moment, setting to x11-user and wayland
+ ;; will let sddm show blank screen, update here
+ ;; when sddm-service-type really support x11-user
+ ;; and wayland.
+ (sddm-configuration-display-server config)) "
Numlock=" (sddm-configuration-numlock config) "
HaltCommand=" (sddm-configuration-halt-command config) "
RebootCommand=" (sddm-configuration-reboot-command config) "
--
2.39.2


--
?