[PATCH] gnu: retroarch: Fix OpenGL core and Vulkan drivers.

  • Open
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 22 Apr 15:45 +0200
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
aff3cb8e23c19f6c03d0cc7652ee455573ecd8e7.1713793535.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/emulators.scm (retroarch)[arguments]: Ignore check result for
HAVE_GLSLANG_HLSL in the configure phase.

Change-Id: I3ba110b834acca25ada0e680a6bcb879b4db96f4
---
gnu/packages/emulators.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a935808da5..08894bd685 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1462,6 +1462,10 @@ (define-public retroarch
(("/usr/local/share/wayland-protocols")
(string-append wayland-protocols "/share/wayland-protocols")))
+ ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
+ (substitute* "qb/config.libs.sh"
+ (("[$]HAVE_GLSLANG_HLSL") "notcare"))
+
;; The configure script does not yet accept the extra arguments
;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
(invoke

base-commit: 30de2751094fa7cceeb692c656296209970d61cb
--
2.41.0
?