[PATCH 2/2] gnu: Add cl-charje.loop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Charles
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Charles
Severity
normal
C
C
Charles wrote on 29 Mar 04:39 +0100
(address . guix-patches@gnu.org)(name . Charles)(address . charles@charje.net)
573fb7c1c21949db47fd72445dd47b3d03536474.1711683567.git.charles@charje.net
* gnu/packages/lisp-xyz.scm (sbcl-charje.loop, cl-charje.loop,
ecl-charje.loop): New variables.

Change-Id: I69cfc7a73a7632e4fa2204d729503b98e609070e
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1a7fb18d81..1c47b7a7c6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2552,6 +2552,40 @@ (define-public cl-iterate
(define-public ecl-iterate
(sbcl-package->ecl-package sbcl-iterate))
+(define-public sbcl-charje.loop
+ (package
+ (name "sbcl-charje.loop")
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~charje/loop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-charje.loop" version))
+ (sha256
+ (base32
+ "1x1hw5xmrx9xmfzga8y0yi6s27r7zc80rwl2z7l4d2h24ykscvd4"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria
+ sbcl-binding-arrows
+ sbcl-parse-declarations))
+ (home-page "https://git.sr.ht/~charje/loop")
+ (synopsis "Loop abstraction for Common Lisp that is consistent for
+different kinds of data")
+ (description "Loop is a joy to use and has a consistent interface unlike
+other looping abstractions and ANSI list operations. You can define your own
+iterators and aggregators that integrate tightly into other operations. All
+operations are non-consing when possible.")
+ (license license:agpl3+)))
+
+(define-public cl-charje.loop
+ (sbcl-package->cl-source-package sbcl-charje.loop))
+
+(define-public ecl-charje.loop
+ (sbcl-package->ecl-package sbcl-charje.loop))
+
(define-public sbcl-cl-uglify-js
;; There have been many bug fixes since the 2010 release.
(let ((commit "429c5e1d844e2f96b44db8fccc92d6e8e28afdd5")
--
2.41.0
G
G
Guillaume Le Vaillant wrote on 29 Mar 14:53 +0100
(name . Charles)(address . charles@charje.net)(address . 70060-done@debbugs.gnu.org)
87y1a1400p.fsf@kitej
Patch applied as d84fb791f6a3a010f7d3fbe2d8bab55db1e1bc1f.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZgbH5g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8OdwEAiX9yEstIEwbXqj45EbDldqO6eji8BzwBg1gf
Qsl042sA/A0ygr84gctK+P4LJpW9t7g8DgIpKDZFjPofpqG6jLTD
=QCyA
-----END PGP SIGNATURE-----

Closed
?