[PATCH] gnu: Add python-apprise.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal
F
F
Fabio Natali wrote on 28 Mar 17:15 +0100
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
1e2f0580212adc76b9fe6479c45414c094effc64.1711642451.git.me@fabionatali.com
* gnu/packages/python-xyz.scm (python-apprise): New variable.

Change-Id: I55b8c7b558ce34835cff31b9fac6ff3b81ff5fec
---
Hi! ?

This is to add Apprise, a push notification Python library.

It seems that Apprise is required if we want to upgrade borgmatic from 1.7.12 to 1.8.9.

I hope the patch looks alright but all feedback is welcome.

Thanks, cheers, Fabio.

gnu/packages/python-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a6ef23b58..2cdcc5e51c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -231,6 +231,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages messaging)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -293,6 +294,51 @@ (define-module (gnu packages python-xyz)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-apprise
+ (package
+ (name "python-apprise")
+ (version "1.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "apprise" version))
+ (sha256
+ (base32 "0wvs1k71fipn617y9wsdcvwcgg2pd0nvriarlwl4438la4086ppg"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-certifi
+ python-click
+ python-dataclasses
+ python-markdown
+ python-pyyaml
+ python-requests
+ python-requests-oauthlib))
+ (native-inputs (list python-babel
+ python-coverage
+ python-cryptography
+ python-flake8
+ python-paho-mqtt
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock
+ python-pytest-xdist
+ python-wheel))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (delete-file "test/test_plugin_macosx.py")
+ (invoke "pytest")))))))
+ (home-page "https://github.com/caronc/apprise")
+ (synopsis
+ "Push notification Python library that works with many platforms")
+ (description
+ "Apprise is a Python library that allows sending push notifications to a broad
+range of notification services, such as Telegram, Discord, Slack, Amazon SNS,
+Gotify, etc.")
+ (license license:bsd-2)))
+
(define-public python-xmldiff
(package
(name "python-xmldiff")

base-commit: fb9549164520ad993c2fbbaedc899844d57baabc
--
2.41.0
F
F
Fabio Natali wrote on 28 Mar 20:05 +0100
[PATCH] gnu: borgmatic: Update to 1.8.9.
(address . 70057@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
bb9eb4064136798fdead3fe9338990c974abb37b.1711649468.git.me@fabionatali.com
* gnu/packages/backup.scm (borgmatic): Update to 1.8.9.

Change-Id: I28330c4f864b7f15c50fc6c80c5d9c40af91b6b9
---
Hi,

This is to update borgmatic to 1.8.9.

I'm sending this as a follow up to another patch, re python-apprise. In fact,
Apprise is now a borgmatic dependency, at least for some of its new
functionality (notifications).

I'm sorry, I should have probably started this as a patch series, with a short
introductory email. I hope it's still clear and easily reviewable.

Thanks, cheers, Fabio.


gnu/packages/backup.scm | 22 +++++++++++++++-------
1 file changed, 15 insertions(+), 7 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 253ab74a19..300f2825c6 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1308,13 +1308,13 @@ (define-public disarchive
(define-public borgmatic
(package
(name "borgmatic")
- (version "1.7.12")
+ (version "1.8.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgmatic" version))
(sha256
- (base32 "0720wvs3h2w8h28d7mpvjfp0q37dnrwf1y2ik3y4yr9csih7fmgh"))))
+ (base32 "1xmqv0gg2ic7lp5kmygr9f6qkabsr86mma7pigan12vk2bcdbw31"))))
(build-system python-build-system)
(arguments
(list #:phases
@@ -1339,11 +1339,19 @@ (define-public borgmatic
(setenv "PATH" (string-append #$output "/bin"
":" (getenv "PATH")))
(invoke "pytest")))))))
- (inputs
- (list borg python-colorama python-jsonschema python-requests
- python-ruamel.yaml-0.16))
- (native-inputs
- (list python-flexmock python-pytest python-pytest-cov))
+ (inputs (list borg
+ python-apprise
+ python-colorama
+ python-jsonschema
+ python-requests))
+ (native-inputs (list python-flexmock
+ python-pytest
+ python-pytest-cov))
+ (propagated-inputs (list python-colorama
+ python-jsonschema
+ python-packaging
+ python-requests
+ python-ruamel.yaml))
(home-page "https://torsion.org/borgmatic/")
(synopsis "Simple, configuration-driven backup software")
(description

base-commit: fb9549164520ad993c2fbbaedc899844d57baabc
prerequisite-patch-id: d9e77adec47d85410e146267e3373f4d3a110832
--
2.41.0
J
Re: [bug#70057] [PATCH] gnu: Add python-apprise.
a45b4505bec8e0d892746d98ba8fe83ba3892946@dismail.de
Hi Fabio,

Thanks for the patch and your contribution to GNU Guix. I reviewed and applied python-apprise.

I'll take a look at your other patch for borgmatic soon.

all the best,

jgart
J
Re: [bug#70057] [PATCH]
dbf77387603d6cb18548e03814b59e1051d36fac@dismail.de
Hi Fabio,

I reviewed and applied borgmatic with some minor changes.

I consolidated the propagated-inputs to be part of the inputs as it was in the previous existing package.

Since borgmatic is an end user application we do not need to propagate the Python library dependencies.

I also applied guix style to the package which introduced some formatting changes and mentioned the changes in the commit message.

all the best,

jgart
Closed
J
fff4bb05ca5815b15e633f050b84e1e03bb44a8b@dismail.de
Hi Fabio,

I reviewed and applied borgmatic with some minor changes.

I consolidated the propagated-inputs to be part of the inputs as it was in the previous existing package.
h
Since borgmatic is an end user application we do not need to propagate the Python library dependencies.

I also applied guix style to the package which introduced some formatting changes and mentioned the changes in the commit message.

all the best,

jgart
Closed
J
01253ea0121dcc1f8aafd9ef09291cacd0e9623f@dismail.de
Hi Fabio,

I reviewed and applied borgmatic with some minor changes.

I consolidated the propagated-inputs to be part of the inputs as it was in the previous existing package.

Since borgmatic is an end user application we do not need to propagate the Python library dependencies.

I also applied guix style to the package which introduced some formatting changes and mentioned the changes in the commit message.

all the best,

jgart
Closed
F
F
Fabio Natali wrote on 1 Apr 12:24 +0200
(name . jgart)(address . jgart@dismail.de)
87msqd5qjf.fsf@fabionatali.com
On 2024-03-31, 23:23 +0000, "jgart" <jgart@dismail.de> wrote:
Toggle quote (2 lines)
> I reviewed and applied borgmatic with some minor changes.

This is brilliant, thanks for helping with this jgart!

Have a lovely day. Cheers, Fabio.
Closed
J
(name . Fabio Natali)(address . me@fabionatali.com)
f616be0ca8f0fa3e24632d967003a56f291b3038@dismail.de
Toggle quote (4 lines)
> This is brilliant, thanks for helping with this jgart!
>
> Have a lovely day. Cheers, Fabio.

Anytime! Excuse the duplicate emails. My email client was acting up.

all best,

jgart
Closed
?