[PATCH 2/2] gnu: Add r-trackviewer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 1 Sep 2023 22:45
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
ab4446c5f3df2c236cd43eeec34ce85c9ff50276.1693601111.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-trackviewer): New variable.
---
gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 88592c4f71..0070d7777c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9931,6 +9931,48 @@ (define-public r-tkwidgets
"This package implements widgets to provide user interfaces.")
(license license:artistic2.0)))
+(define-public r-trackviewer
+ (package
+ (name "r-trackviewer")
+ (version "1.36.2")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "trackViewer" version))
+ (sha256
+ (base32
+ "1ngfpd308y8i3vgv07cggk2azs64lsyyc9zfi3pz0gapr33ha6a1"))))
+ (properties `((upstream-name . "trackViewer")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-annotationdbi
+ r-biocgenerics
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicfeatures
+ r-genomicranges
+ r-graph
+ r-grimport
+ r-gviz
+ r-htmlwidgets
+ r-interactionset
+ r-iranges
+ r-plotrix
+ r-rgraphviz
+ r-rhdf5
+ r-rsamtools
+ r-rtracklayer
+ r-s4vectors
+ r-scales
+ r-strawr))
+ (native-inputs (list esbuild r-knitr))
+ (home-page "https://bioconductor.org/packages/trackViewer")
+ (synopsis "Web interface for interactive multi-omics data analysis")
+ (description
+ "TrackViewer offers multi-omics analysis with web based tracks and lollipops.
+Visualize mapped reads along with annotation as track layers for NGS dataset
+such as @code{ChIP-seq,} RNA-seq, @code{miRNA-seq,} DNA-seq, SNPs and
+methylation data.")
+ (license license:gpl2+)))
+
(define-public r-transcriptr
(package
(name "r-transcriptr")
--
2.34.1
R
R
Ricardo Wurmus wrote on 2 Sep 2023 11:55
(address . 65688-done@debbugs.gnu.org)
87h6ocdhj3.fsf@elephly.net
Thanks for the patch!

This one needed a little more work. The “esbuild” in the native inputs
was added by the importer because the package includes minified
JavaScript files.

Luckily it’s just one file and we can replace it easily. I’ve made the
necessary changes and pushed it with commit
8c0c94bf9f70a9252cd6f4261d2bce6bdba2bd0b to the “master” branch.

--
Ricardo
Closed
?