[PATCH] gnu: Add fonts-tlwg.

  • Done
  • quality assurance status badge
Details
3 participants
  • chris
  • Maxim Cournoyer
  • Bruno Victal
Owner
unassigned
Submitted by
chris
Severity
normal
C
(address . guix-patches@gnu.org)(name . chris)(address . chris@bumblehead.com)
20230831065214.629-1-chris@bumblehead.com
* gnu/packages/fonts.scm (fonts-tlwg): New variable.
---
gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e10227f020..78c0e0eb4c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3390,3 +3391,25 @@ (define-public font-recursive
primarily to meet the needs of programming environments and application
interfaces.")
(license license:silofl1.1)))
+
+(define-public fonts-tlwg
+ (package
+ (name "fonts-tlwg")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tlwg/" name
+ "/releases/download/v" version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
+ (native-inputs (list fontforge))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/tlwg/fonts-tlwg/")
+ (synopsis "Collection of scalable Thai fonts")
+ (description "Fonts-TLWG is a collection of Thai scalable fonts available under free
+licenses. Its goal is to provide fonts that conform to existing standards
+and recommendations, so that it can be a reference implementation.")
+ (license license:gpl2)))

base-commit: d6966b8a5b4f2ddda2bc685b9642e7a1c2cbe17c
--
2.41.0
B
B
Bruno Victal wrote on 31 Aug 2023 18:05
(name . chris)(address . chris@bumblehead.com)(address . 65658-close@debbugs.gnu.org)
081febfd-cfb4-4bb5-822a-c8037e7d402c@makinata.eu
Close, duplicate of #65657.



--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
M
M
Maxim Cournoyer wrote on 6 Sep 2023 02:53
Re: bug#65658: [PATCH] gnu: Add fonts-tlwg.
(name . chris)(address . chris@bumblehead.com)(address . 65658-done@debbugs.gnu.org)
877cp4f7g2.fsf@gmail.com
Hi!

chris <chris@bumblehead.com> writes:

Toggle quote (2 lines)
> * gnu/packages/fonts.scm (fonts-tlwg): New variable.

Thank you for your contribution!

Toggle quote (41 lines)
> gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index e10227f020..78c0e0eb4c 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -57,6 +57,7 @@
> ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
> ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
> ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> +;;; Copyright © 2023 chris <chris@bumblehead.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -3390,3 +3391,25 @@ (define-public font-recursive
> primarily to meet the needs of programming environments and application
> interfaces.")
> (license license:silofl1.1)))
> +
> +(define-public fonts-tlwg
> + (package
> + (name "fonts-tlwg")
> + (version "0.7.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/tlwg/" name
> + "/releases/download/v" version "/" name "-" version ".tar.xz"))
> + (sha256
> + (base32
> + "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
> + (native-inputs (list fontforge))
> + (build-system gnu-build-system)
> + (home-page "https://github.com/tlwg/fonts-tlwg/")
> + (synopsis "Collection of scalable Thai fonts")
> + (description "Fonts-TLWG is a collection of Thai scalable fonts available under free
> +licenses. Its goal is to provide fonts that conform to existing standards
> +and recommendations, so that it can be a reference implementation.")

We do not use 'free licenses' or 'open source' or similar terms to
describe packages in Guix, as that is implied by our FSDG promise.

Toggle quote (2 lines)
> + (license license:gpl2)))

This should be gpl2+, since the license text mentions (emphasis mine):

This font is free software; you can redistribute it and/or modify it
under the terms of the GNU General Public License as published by the
Free Software Foundation; either version 2 of the License, *or (at your
option) any later version*.

I've applied it with small changes for the above.

Thank you!

--
Thanks,
Maxim
Closed
?