[PATCH] gnu: Add fonts-tlwg.

  • Done
  • quality assurance status badge
Details
2 participants
  • chris
  • Maxim Cournoyer
Owner
unassigned
Submitted by
chris
Severity
normal
C
(address . guix-patches@gnu.org)(name . chris)(address . chris@bumblehead.com)
20230830220642.24329-1-chris@bumblehead.com
* gnu/packages/fonts.scm (fonts-tlwg): New variable.
---
gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e10227f020..19bd8540af 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3390,3 +3391,26 @@ (define-public font-recursive
primarily to meet the needs of programming environments and application
interfaces.")
(license license:silofl1.1)))
+
+(define-public fonts-tlwg
+ (package
+ (name "fonts-tlwg")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tlwg/" name
+ "/releases/download/v" version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
+ (native-inputs (list fontforge))
+ (build-system gnu-build-system)
+ ;; (build-system font-build-system)
+ (home-page "https://github.com/tlwg/fonts-tlwg/")
+ (synopsis "Collection of scalable Thai fonts")
+ (description "Fonts-TLWG is a collection of Thai scalable fonts available under free
+licenses. Its goal is to provide fonts that conform to existing standards
+and recommendations, so that it can be a reference implementation.")
+ (license license:gpl2)))
--
2.41.0
C
(address . 65657@debbugs.gnu.org)(name . chris)(address . chris@bumblehead.com)
20230831161511.1298-1-chris@bumblehead.com
* gnu/packages/fonts.scm (fonts-tlwg): New variable.
---
gnu/packages/fonts.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e10227f020..d5bb25f0ef 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3390,3 +3391,31 @@ (define-public font-recursive
primarily to meet the needs of programming environments and application
interfaces.")
(license license:silofl1.1)))
+
+(define-public fonts-tlwg
+ (package
+ (name "fonts-tlwg")
+ (version "0.7.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/tlwg/"
+ name
+ "/releases/download/v"
+ version
+ "/"
+ name
+ "-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "00mv8rmjpsk8jbbl978q3yrc2pxj8a86a3d092563dlc9n8gykkf"))))
+ (native-inputs (list fontforge))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/tlwg/fonts-tlwg/")
+ (synopsis "Collection of scalable Thai fonts")
+ (description
+ "Fonts-TLWG is a collection of Thai scalable fonts available under free
+licenses. Its goal is to provide fonts that conform to existing standards
+and recommendations, so that it can be a reference implementation.")
+ (license license:gpl2)))

base-commit: d6966b8a5b4f2ddda2bc685b9642e7a1c2cbe17c
--
2.41.0
C
first patch mistakes
(address . 65657@debbugs.gnu.org)
ZPC-c6Wwtap10zqL@guix-xps
I sent an email to close this issue 65657 in favor of 65658, but the email did not appear on the issue page for 65657 and in the meantime someone else closed 65658 in favor of 65657. I hope the follow-up lint-updated patch sent here makes it through 65657 any advice is welcome, thank you.
C
C
Christopher DePauw wrote on 31 Aug 2023 18:30
(address . 65657@debbugs.gnu.org)
908858c5e0102c621ffab08a1e777e05@bumblehead.com
I sent an email to close this issue 65657 in favor of 65658, but the
email did not appear on the issue page for 65657 and in the meantime
someone else closed 65658 in favor of 65657. I hope this lint-updated
patch makes it through 65657 any advice is welcome, thank you.
Attachment: file
C
C
Christopher DePauw wrote on 31 Aug 2023 17:57
closing as duplicate of 65658
(address . 65657-done@debbugs.gnu.org)
2b8c2c0a2388fa4037f0899fb078b0f7@bumblehead.com
closing as duplicate of 65658
Attachment: file
Closed
C
C
chris wrote on 1 Sep 2023 19:13
more info
(address . 65657@debbugs.gnu.org)(address . chris@bumblehead.com)
ZPIbrOq0z2ORVP_R@guix-xps
This patch makes dedicated thai fonts available through guix. Locally, I have used this package for several months. Before the patch was applied, thai characters would render as little box characters. After the patch was applied, thai characters are rendered nicely.

The tlwg fonts are the primary thai fonts packaged by other distributions.
M
M
Maxim Cournoyer wrote on 6 Sep 2023 05:45
Re: bug#65657: [PATCH] gnu: Add fonts-tlwg.
(name . Christopher DePauw)(address . chris@bumblehead.com)(address . 65657-done@debbugs.gnu.org)
87y1hk9d7o.fsf_-_@gmail.com
Hi,

Christopher DePauw <chris@bumblehead.com> writes:

Toggle quote (5 lines)
> I sent an email to close this issue 65657 in favor of 65658, but the
> email did not appear on the issue page for 65657 and in the meantime
> someone else closed 65658 in favor of 65657. I hope this lint-updated
> patch makes it through 65657 any advice is welcome, thank you.

I've applied 65658. Closing!

--
Thanks,
Maxim
Closed
?