[PATCH] gnu: liburcu: Update to 0.14.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • odion
Owner
unassigned
Submitted by
odion
Severity
normal
O
(address . guix-patches@gnu.org)(name . Olivier Dion)(address . odion@efficios.com)
4e237aa21ee92ded2a19ba07814771d96ed07937.1693408885.git.olivier.dion@polymtl.ca
From: Olivier Dion <odion@efficios.com>

* gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.
---
gnu/packages/datastructures.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index bd4f099d94..0689ef4259 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -213,14 +213,14 @@ (define-public libcuckoo
(define-public liburcu
(package
(name "liburcu")
- (version "0.13.1")
+ (version "0.14.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.lttng.org/files/urcu/"
"userspace-rcu-" version ".tar.bz2"))
(sha256
(base32
- "10rh6v9j13622cjlzx31cfpghjy0kqkvn6pb42whwwcg5cyz64rj"))))
+ "0kwx4fi3gn4p4sdxqkz2zh4z0fv06q449bnz43zjqfad3lkbyhya"))))
(build-system gnu-build-system)
(native-inputs
(list perl)) ; for tests

base-commit: ebaff644a6ae87ca289c827d902b46e7877e66ec
--
2.41.0
M
M
Maxim Cournoyer wrote on 6 Sep 2023 06:56
(address . odion@efficios.com)(address . 65624@debbugs.gnu.org)
87bkef99x7.fsf@gmail.com
Hi,

odion@efficios.com writes:

Toggle quote (4 lines)
> From: Olivier Dion <odion@efficios.com>
>
> * gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.

According to QA new errors were introduced with this upgrade:
https://qa.guix.gnu.org/issue/65624. It looks like it broke at least
multipath-tools.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 6 Sep 2023 06:56
control message for bug #65624
(address . control@debbugs.gnu.org)
87a5tz99x3.fsf@gmail.com
tags 65624 + moreinfo
quit
O
O
Olivier Dion wrote on 6 Sep 2023 16:32
Re: bug#65624: [PATCH] gnu: liburcu: Update to 0.14.0.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65624@debbugs.gnu.org)
87msxztlrf.fsf@laura
On Wed, 06 Sep 2023, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (12 lines)
> Hi,
>
> odion@efficios.com writes:
>
>> From: Olivier Dion <odion@efficios.com>
>>
>> * gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.
>
> According to QA new errors were introduced with this upgrade:
> https://qa.guix.gnu.org/issue/65624. It looks like it broke at least
> multipath-tools.

There are missing include statements in compilation units of multipath-
tools for <assert.h>. It probably worked before because Userspace RCU
was including it in its public header file and not anymore. Therefore,
it is a bug of mutlipath-tools which was fixed in version 0.9.6.

So I see two solutions to this. Either I back-port the patch to version
0.9.3 or we update multipath-tools to 0.9.6.

Thought?
--
Olivier Dion
EfficiOS Inc.
M
M
Maxim Cournoyer wrote on 6 Sep 2023 19:13
(name . Olivier Dion)(address . odion@efficios.com)(address . 65624@debbugs.gnu.org)
87a5tz5ioo.fsf@gmail.com
Hi,

Olivier Dion <odion@efficios.com> writes:

[...]

Toggle quote (8 lines)
> There are missing include statements in compilation units of multipath-
> tools for <assert.h>. It probably worked before because Userspace RCU
> was including it in its public header file and not anymore. Therefore,
> it is a bug of mutlipath-tools which was fixed in version 0.9.6.
>
> So I see two solutions to this. Either I back-port the patch to version
> 0.9.3 or we update multipath-tools to 0.9.6.

I'd favor updating multipath-tools; it only 2 dependents, and it's a
patch-level update, so my expectation is that it shouldn't break
anything.

--
Thanks,
Maxim
O
O
odion wrote on 7 Sep 2023 17:20
[PATCH v2 2/2] gnu: liburcu: Update to 0.14.0.
(address . 65624@debbugs.gnu.org)
20230907152053.12402-2-odion@efficios.com
From: Olivier Dion <odion@efficios.com>

* gnu/packages/datastructures.scm (liburcu): Update to 0.14.0.
---
gnu/packages/datastructures.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index bd4f099d94..0689ef4259 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -213,14 +213,14 @@ (define-public libcuckoo
(define-public liburcu
(package
(name "liburcu")
- (version "0.13.1")
+ (version "0.14.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.lttng.org/files/urcu/"
"userspace-rcu-" version ".tar.bz2"))
(sha256
(base32
- "10rh6v9j13622cjlzx31cfpghjy0kqkvn6pb42whwwcg5cyz64rj"))))
+ "0kwx4fi3gn4p4sdxqkz2zh4z0fv06q449bnz43zjqfad3lkbyhya"))))
(build-system gnu-build-system)
(native-inputs
(list perl)) ; for tests
--
2.41.0
O
O
odion wrote on 7 Sep 2023 17:20
[PATCH v2 1/2] gnu: multipath-tools: Update to 0.9.6.
20230907152053.12402-1-odion@efficios.com
From: Olivier Dion <olivier.dion@polymtl.ca>

* gnu/packages/linux.scm (multipath-tools): Update to 0.9.6.
[#:make-flags]: Set systemd_prefix to output and remove SYSTEMDPATH.
[#:phases]: Add phase 'no-fortfify-3 before 'build.
[inputs]: Add util-linux "lib" output for libmount.
---
gnu/packages/linux.scm | 20 ++++++++++++++++----
1 file changed, 16 insertions(+), 4 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 36354b4d82..3d310941a4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5547,7 +5547,7 @@ (define-public mdadm-static
(define-public multipath-tools
(package
(name "multipath-tools")
- (version "0.9.3")
+ (version "0.9.6")
(home-page "https://github.com/opensvc/multipath-tools")
(source (origin
(method git-fetch)
@@ -5555,7 +5555,7 @@ (define-public multipath-tools
(file-name (git-file-name name version))
(sha256
(base32
- "0zcnr1135znizbnfqhqv3by9i2qwn5vg6kgmj6ma3yy1x1krx0d4"))
+ "1933iqh9r54pdl95yck0n4bw7jiiblymc964vlc1787qd4q012sz"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -5573,7 +5573,7 @@ (define-public multipath-tools
(string-append "prefix=" #$output)
;; Install Udev rules below this directory, relative
;; to the prefix.
- "SYSTEMDPATH=lib")
+ (string-append "systemd_prefix=" #$output))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -5605,6 +5605,16 @@ (define-public multipath-tools
(("CFLAGS \\+= " match)
(string-append match "-Wno-error=unused-function ")))))
(delete 'configure) ;no configure script
+ (add-before 'build 'no-fortify-3
+ (lambda _
+ ;; NOTE: The check made seems to wrongly assume the
+ ;; FORTIFY_SOURCE=3 is valid. However, when compiling, warnings
+ ;; are emitted from glibc, resulting in failed build. Fix this
+ ;; by forcing the usage of FORTIFY_SOURCE=2.
+ (substitute* "create-config.mk"
+ (("FORTIFY_SOURCE=3")
+ "FORTIFY_SOURCE=2"))
+ ))
(add-before 'build 'set-LDFLAGS
(lambda _
;; Note: this cannot be passed as a make flag because that will
@@ -5622,7 +5632,9 @@ (define-public multipath-tools
liburcu
lvm2
readline
- eudev))
+ eudev
+ ;; For libmount.
+ `(,util-linux "lib")))
(synopsis "Access block devices through multiple paths")
(description
"This package provides the following binaries to drive the
--
2.41.0
M
M
Maxim Cournoyer wrote on 10 Sep 2023 16:48
(address . odion@efficios.com)
87v8ciulrj.fsf@gmail.com
Hi,

odion@efficios.com writes:

Toggle quote (7 lines)
> From: Olivier Dion <olivier.dion@polymtl.ca>
>
> * gnu/packages/linux.scm (multipath-tools): Update to 0.9.6.
> [#:make-flags]: Set systemd_prefix to output and remove SYSTEMDPATH.
> [#:phases]: Add phase 'no-fortfify-3 before 'build.
> [inputs]: Add util-linux "lib" output for libmount.

I've installed the series, thanks!

--
Thanks,
Maxim
Closed
?