[PATCH] gnu: vtk-7: Fix build.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 29 Aug 2023 16:06
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
6b06ed7d65400b6ad4cf248451e8f2952bd4188f.1693317959.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/patches/vtk-7-gcc-11-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/image-processing.scm (vtk-7)[source]: Add patch for gcc-11.
---
gnu/local.mk | 1 +
gnu/packages/image-processing.scm | 3 ++-
gnu/packages/patches/vtk-7-gcc-11-compat.patch | 11 +++++++++++
3 files changed, 14 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/vtk-7-gcc-11-compat.patch

Toggle diff (47 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 48187d7e64..9b493df8d5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2085,6 +2085,7 @@ dist_patch_DATA = \
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
%D%/packages/patches/vtk-7-gcc-10-compat.patch \
+ %D%/packages/patches/vtk-7-gcc-11-compat.patch \
%D%/packages/patches/vtk-7-hdf5-compat.patch \
%D%/packages/patches/vtk-7-python-compat.patch \
%D%/packages/patches/wacomtablet-add-missing-includes.patch \
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index afeda4bc20..771a2d52f4 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -472,7 +472,8 @@ (define-public vtk-7
"0nm7xwwj7rnsxjdv2ssviys8nhci4n9iiiqm2y14s520hl2dsp1d"))
(patches (search-patches "vtk-7-python-compat.patch"
"vtk-7-hdf5-compat.patch"
- "vtk-7-gcc-10-compat.patch"))))
+ "vtk-7-gcc-10-compat.patch"
+ "vtk-7-gcc-11-compat.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments vtk)
((#:configure-flags flags)
diff --git a/gnu/packages/patches/vtk-7-gcc-11-compat.patch b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
new file mode 100644
index 0000000000..c7ab3af36e
--- /dev/null
+++ b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
@@ -0,0 +1,11 @@
+Description: GCC 11 now enforces that comparison objects be invocable as const.
+--- a/Rendering/Label/vtkLabelHierarchy.cxx
++++ b/Rendering/Label/vtkLabelHierarchy.cxx
+@@ -525,1 +525,1 @@
+- const vtkHierarchyNode & b)
++ const vtkHierarchyNode & b) const
+--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
++++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
+@@ -66,1 +66,1 @@
+- bool operator () ( const vtkIdType& a, const vtkIdType& b )
++ bool operator () ( const vtkIdType& a, const vtkIdType& b ) const

base-commit: 715d203b414727be43e405d09e86aa823125a4b3
--
2.41.0
?
Closing
877cpb7cgs.fsf@envs.net
Pushed now, closing!
Closed
?