[PATCH 1/2] gnu: cssc: Fix tests.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 27 Aug 2023 11:41
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
c9704731f2dd78aab8b70023ca1cc06abfab34b3.1693129275.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/version-control.scm (cssc)[arguments]: Replace
egrep with grep -E in the precheck phase.
---
gnu/packages/version-control.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 699a091642..1ca3dc9a53 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2377,6 +2377,15 @@ (define-public cssc
(substitute* "tests/prt/all-512.sh"
(("/bin/sh") (which "sh")))
+ (for-each
+ (lambda (file)
+ (substitute* file (("egrep") "grep -E")))
+ '("tests/common/test-common"
+ "tests/admin/comment.sh"
+ "tests/cdc/2comment.sh"
+ "tests/cdc/4order.sh"
+ "tests/get/subst.sh"))
+
;; XXX: This test has no hope of passing until there is a "nogroup"
;; entry (or at least some group to which the guix builder does
;; not belong) in the /etc/group file of the build environment.

base-commit: 5856e185a3d4f47e27dfd064a231b3a1d44a6494
--
2.41.0
?
Closing
877cpb7cgs.fsf@envs.net
Pushed now, closing!
Closed
?