[PATCH] gnu: pencil2d: Fix tests.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 27 Aug 2023 04:54
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
499c3851ede4c6e239dbd2332006a3e761e29222.1693104877.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/animation.scm (pencil2d)[arguments]: Use gexps.
Add fix-tests phase.
---
gnu/packages/animation.scm | 31 ++++++++++++++++++-------------
1 file changed, 18 insertions(+), 13 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 9691dd0d80..d6bd3fd03d 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -442,19 +442,24 @@ (define-public pencil2d
(inputs
(list qtbase-5 qtxmlpatterns qtmultimedia-5 qtsvg-5))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (invoke "qmake" (string-append "PREFIX=" out)))))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (plugin-path (getenv "QT_PLUGIN_PATH")))
- (wrap-program (string-append out "/bin/pencil2d")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; Its bundled catch2-2.5.0 fails to build with glibc-2.35.
+ (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
+ "tests/src/catch.hpp")))
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "qmake" (string-append "PREFIX=" out)))))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (plugin-path (getenv "QT_PLUGIN_PATH")))
+ (wrap-program (string-append out "/bin/pencil2d")
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
(home-page "https://www.pencil2d.org")
(synopsis "Make 2D hand-drawn animations")
(description

base-commit: 28fdf6cc16aee56fdc17a31701b90ace6e512481
--
2.41.0
?
Closing
877cpb7cgs.fsf@envs.net
Pushed now, closing!
Closed
?