[PATCH] daemon: Fix build with GCC13

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • soeren
Owner
unassigned
Submitted by
soeren
Severity
normal
S
S
soeren wrote on 26 Aug 2023 09:00
(address . guix-patches@gnu.org)
20230826070036.7629-2-soeren@soeren-tempel.net
From: Sören Tempel <soeren@soeren-tempel.net>

The sqlite.hh file uses fixed-width integer types from stdint.h. As
such, it needs to include <cstdint>. Without this include, the file
doesn't compile successfully with GCC13.


* nix/libstore/sqlite.hh: include <cstdint>

Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
---
nix/libstore/sqlite.hh | 1 +
1 file changed, 1 insertion(+)

Toggle diff (11 lines)
diff --git a/nix/libstore/sqlite.hh b/nix/libstore/sqlite.hh
index 326e4a4855..6cadba6849 100644
--- a/nix/libstore/sqlite.hh
+++ b/nix/libstore/sqlite.hh
@@ -2,6 +2,7 @@
#include <functional>
#include <string>
+#include <cstdint>
#include "types.hh"
L
L
Ludovic Courtès wrote on 9 Sep 2023 22:31
(address . soeren@soeren-tempel.net)(address . 65547-done@debbugs.gnu.org)
87il8jw0kb.fsf@gnu.org
Hi,

soeren@soeren-tempel.net skribis:

Toggle quote (12 lines)
> From: Sören Tempel <soeren@soeren-tempel.net>
>
> The sqlite.hh file uses fixed-width integer types from stdint.h. As
> such, it needs to include <cstdint>. Without this include, the file
> doesn't compile successfully with GCC13.
>
> See: https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
>
> * nix/libstore/sqlite.hh: include <cstdint>
>
> Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>

Pushed as cd469932758bf2bec1ff9c82aeb373e18730d0c4, thanks!

Ludo’.
Closed
?