[PATCH] gnu: Add font-junicode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Philip McGrath
Owner
unassigned
Submitted by
Philip McGrath
Severity
normal
P
P
Philip McGrath wrote on 24 Aug 2023 06:50
(address . guix-patches@gnu.org)
5925990d0d10d11c11a9e85de54147750fff36a3.1692852531.git.philip@philipmcgrath.com
* gnu/packages/fonts.scm (font-junicode): New variable.
---
gnu/packages/fonts.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e881ab11cd..ee911559af 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021-2023 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022-2023 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Kitzman <kitzman@disroot.org>
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
@@ -1855,6 +1855,36 @@ (define-public font-iosevka-comfy
version of the original, designed for enhanced readability.")
(license license:silofl1.1)))
+(define-public font-junicode
+ (package
+ (name "font-junicode")
+ (version "2.001")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/psb1558/Junicode-font")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13sm9sqb56i81zmgd0n14xzksy1ww88fz1wfgm5q2wrq6wgv0wmr"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/psb1558/Junicode-font")
+ (synopsis "Unicode font for medievalists, linguists, and others")
+ (description "The Junicode font was developed for students and scholars of
+medieval Europe, but its large glyph repertoire also makes it useful as a
+general-purpose font. Its visual design is based on the typography used by
+Oxford University Press in the late 17th and early 18th centuries. The font
+implements the @acronym{MUFI, Medieval Unicode Font Initiative} recommendation
+for encoding ligatures, alternative letter forms, and other features of
+interest to medievalists using Unicode's Private Use Area.
+
+Junicode 2 is a major reworking of the font family. Its OpenType programming
+has been rebuilt to support the creation of searchable, accessible electronic
+documents using the @acronym{MUFI} characters. The family includes five
+weights and five widths in both Roman and Italic, plus variable fonts.")
+ (license license:silofl1.1)))
+
(define-public font-sarasa-gothic
(package
(name "font-sarasa-gothic")

base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
--
2.41.0
P
P
Philip McGrath wrote on 26 Aug 2023 21:45
[PATCH v2] gnu: Add font-junicode.
(address . 65484@debbugs.gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
21c0911a90e97f65d5ab9c0a86f7b0cb61e50e21.1693078978.git.philip@philipmcgrath.com
* gnu/packages/fonts.scm (font-junicode): New variable.
---
gnu/packages/fonts.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e881ab11cd..e1a23ac4f3 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021-2023 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022-2023 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Kitzman <kitzman@disroot.org>
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
@@ -1855,6 +1855,36 @@ (define-public font-iosevka-comfy
version of the original, designed for enhanced readability.")
(license license:silofl1.1)))
+(define-public font-junicode
+ (package
+ (name "font-junicode")
+ (version "2.002")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/psb1558/Junicode-font")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05wj2jjq6xhn6372rnamygazy41y3i1nfdiaivcpx0cdw39kdmvw"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/psb1558/Junicode-font")
+ (synopsis "Unicode font for medievalists, linguists, and others")
+ (description "The Junicode font was developed for students and scholars of
+medieval Europe, but its large glyph repertoire also makes it useful as a
+general-purpose font. Its visual design is based on the typography used by
+Oxford University Press in the late 17th and early 18th centuries. The font
+implements the @acronym{MUFI, Medieval Unicode Font Initiative} recommendation
+for encoding ligatures, alternative letter forms, and other features of
+interest to medievalists using Unicode's Private Use Area.
+
+Junicode 2 is a major reworking of the font family. Its OpenType programming
+has been rebuilt to support the creation of searchable, accessible electronic
+documents using the @acronym{MUFI} characters. The family includes five
+weights and five widths in both Roman and Italic, plus variable fonts.")
+ (license license:silofl1.1)))
+
(define-public font-sarasa-gothic
(package
(name "font-sarasa-gothic")

base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
--
2.41.0
P
P
Philip McGrath wrote on 31 Aug 2023 17:47
[PATCH v3] gnu: Add font-junicode.
(address . 65484@debbugs.gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
fe3e24b2b4674b57719d1557a23badbecdfb868d.1693496602.git.philip@philipmcgrath.com
* gnu/packages/fonts.scm (font-junicode): New variable.
---
gnu/packages/fonts.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e10227f020..f96ef655cf 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021-2023 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022-2023 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Kitzman <kitzman@disroot.org>
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
@@ -1910,6 +1910,36 @@ (define-public font-iosevka-comfy
version of the original, designed for enhanced readability.")
(license license:silofl1.1)))
+(define-public font-junicode
+ (package
+ (name "font-junicode")
+ (version "2.003")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/psb1558/Junicode-font")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qg1qwk294p2hgq2gbyhfwwdas1xbkfz3csxf5jz4xqiskn4skgl"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/psb1558/Junicode-font")
+ (synopsis "Unicode font for medievalists, linguists, and others")
+ (description "The Junicode font was developed for students and scholars of
+medieval Europe, but its large glyph repertoire also makes it useful as a
+general-purpose font. Its visual design is based on the typography used by
+Oxford University Press in the late 17th and early 18th centuries. The font
+implements the @acronym{MUFI, Medieval Unicode Font Initiative} recommendation
+for encoding ligatures, alternative letter forms, and other features of
+interest to medievalists using Unicode's Private Use Area.
+
+Junicode 2 is a major reworking of the font family. Its OpenType programming
+has been rebuilt to support the creation of searchable, accessible electronic
+documents using the @acronym{MUFI} characters. The family includes five
+weights and five widths in both Roman and Italic, plus variable fonts.")
+ (license license:silofl1.1)))
+
(define-public font-sarasa-gothic
(package
(name "font-sarasa-gothic")

base-commit: b51e45d3aaa8a85d39a8a4c3d18e8b57254aeaf2
--
2.41.0
M
M
Maxim Cournoyer wrote on 6 Sep 2023 02:51
Re: bug#65484: [PATCH] gnu: Add font-junicode.
(name . Philip McGrath)(address . philip@philipmcgrath.com)(address . 65484-done@debbugs.gnu.org)
87cyywf7j3.fsf_-_@gmail.com
Hi,

Philip McGrath <philip@philipmcgrath.com> writes:

Toggle quote (2 lines)
> * gnu/packages/fonts.scm (font-junicode): New variable.

Installed!

--
Thanks,
Maxim
Closed
?