[PATCH] Updating EternalTerminal

  • Done
  • quality assurance status badge
Details
2 participants
  • Aaron Covrig
  • Christopher Baines
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 24 Aug 2023 02:53
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
30759e57065acfe35b3bbeae71ab090c90610e5a.1692838398.git.aaron.covrig.us@ieee.org
Changes:
1. Updated EternalTerminal to the current latest release
(which fixes build issues)
2. Removed GoogleTest dependency from EternalTerminal as the
project has replaced it with Catch2
3. Added (gnu packages curl) to inclusions as EternalTerminal now
depends on curl
---
gnu/packages/terminals.scm | 23 +++++++----------------
1 file changed, 7 insertions(+), 16 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index c59b1a6588..624b845a58 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -74,6 +74,7 @@ (define-module (gnu packages terminals)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages dlang)
#:use-module (gnu packages docbook)
#:use-module (gnu packages fontutils)
@@ -1301,30 +1302,20 @@ (define-public kitty
(define-public eternalterminal
(package
(name "eternalterminal")
- (version "6.0.13")
- (source
+ (version "6.2.4")
+ (source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/MisterTea/EternalTerminal")
(commit (string-append "et-v" version))))
(file-name (git-file-name name version))
- (sha256
- (base32 "0sb1hypg2276y8c2a5vivrkcxp70swddvhnd9h273if3kv6j879r"))))
+ (sha256
+ (base32 "13vhr701j85ga37d53339bxgrf9fqa6z1zcp6s3ly5bb8p7lyvzm"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags '("-DBUILD_TEST=ON")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'insert-googletests
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tests (assoc-ref inputs "googletest")))
- (copy-recursively tests "external/googletest"))
- #t)))))
- (inputs
- (list gflags libsodium protobuf))
- (native-inputs
- `(("googletest" ,(package-source googletest))))
+ '(#:configure-flags '("-DBUILD_TEST=ON" "-DDISABLE_VCPKG=1")))
+ (inputs (list libsodium protobuf openssl zlib curl))
(home-page "https://mistertea.github.io/EternalTerminal/")
(synopsis "Remote shell that reconnects without interrupting the session")
(description "@dfn{Eternal Terminal} (ET) is a remote shell that

base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
--
2.41.0
C
C
Christopher Baines wrote on 20 Oct 2023 13:58
(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
878r7x4i8v.fsf@cbaines.net
Aaron Covrig via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (11 lines)
> Changes:
> 1. Updated EternalTerminal to the current latest release
> (which fixes build issues)
> 2. Removed GoogleTest dependency from EternalTerminal as the
> project has replaced it with Catch2
> 3. Added (gnu packages curl) to inclusions as EternalTerminal now
> depends on curl
> ---
> gnu/packages/terminals.scm | 23 +++++++----------------
> 1 file changed, 7 insertions(+), 16 deletions(-)

Hi Aaron,

Thanks for the patch, I've written a commit message in the Guix style:

gnu: eternalterminal: Update to 6.2.4.

* gnu/packages/terminals.scm (eternalterminal): Update to 6.2.4.
[arguments]: Add -DDISABLE_VCPKG=1 to #:configure-flags, remove #:phases.
[inputs]: Remove gflags, add openssl, zlib and curl.
[native-inputs]: Remove.

and pushed this to master now as
746298e54fddcd4f2f9b7a65355dd6b692f67a71.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUya6BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf3+xAAsGUrnMEbccnoS5cCJ1fxXzm12D3lOP7U
PJLNGRf5qUGIT4Sc1fUYJfu+gPuS0O3lOCSSbZ8Lch/zK60RYboPVqn5abFfOx7+
TyL1fDstuVRs9Ns0ZM8pxqA1u0eeT6V2xi+IbaXzfDEmJmWZKOobok0NaWbX4NI+
BuFuxKpl6mOFG6CaPyqzzD7Tb6JiW+YJSdTRsTq/Mh+YFqXJxCe3ZpHMGg2r7fMZ
M7wLqbEnjjSaiY0jhfKqv8qizDluVGJY2na0eP3aJDU4UhdVfIzWQWCRBATtyGqV
hWoVojV7GVwnGHIk0DQ+HPcVqttPuVp0W9R+IDRN4B4SKp/qRKZnXO0yDSet0kVW
nQBi85arckoBmkB5edAwJ6GLyRve1hP1RCQL5wPPOziHK4SdbtynqSZMHIG1AObQ
m/ucJnXGhxWFLI/mZZ12ha0m5xY2OGOTBAAGbvkdszhganSXrkQofnDIJkSJH+mS
soNriTxmySPUwElOVLGn7iNI52H3MqZww6vc0J6YSwjxFruo59H6BMmFD/i0HPbq
q4NztNX0bNIyryFjsUyttkEyKJCKH5xXzwnPr07tsyagCkzxy4v0pikzVWgk4Hbo
Nt6NFAC82FvjPh6CGonPgejtu5K3j5TJS7kFDrKrSXHmKPvLyTlYPx08QL1bhtCI
fah5kTA6tIA=
=TvZS
-----END PGP SIGNATURE-----

Closed
?