[PATCH 0/2] Add emacs-slite

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • ykonai
Owner
unassigned
Submitted by
ykonai
Severity
normal
Y
Y
ykonai wrote on 23 Aug 2023 19:44
(address . guix-patches@gnu.org)
cover.1692810936.git.mail@ykonai.net
Hello Guix,

This adds the slite test runner for emacs. It contains two packages, the
Common Lisp side and the Emacs side. Because the .el file does not explicitly
load in the system whenever it's run but requires the user to do so manually,
it's split into two packages.

ykonai (2):
gnu: Add cl-slite.
gnu: Add emacs-slite.

gnu/packages/emacs-xyz.scm | 15 +++++++++++++++
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
2 files changed, 48 insertions(+)


base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
--
2.41.0
Y
Y
ykonai wrote on 23 Aug 2023 19:48
[PATCH 1/2] gnu: Add cl-slite.
(address . 65477@debbugs.gnu.org)
b626ae8a170fb50cc0142bd63bb8801502e8e620.1692810936.git.mail@ykonai.net
* gnu/packages/lisp-xyz.scm (cl-slite, ecl-slite, sbcl-slite): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d62122f408..6f9a942a30 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -27328,6 +27328,39 @@ (define-public cl-slot-extra-options
(define-public ecl-slot-extra-options
(sbcl-package->ecl-package sbcl-slot-extra-options))
+(define-public sbcl-slite
+ (let ((commit "942a95330592d30be5ac02fb1b697fb14ccbf1af")
+ (revision "0"))
+ (package
+ (name "sbcl-slite")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdrhq/slite/")
+ (commit commit)))
+ (file-name (git-file-name "slite" version))
+ (sha256
+ (base32 "0b4c4vs1zlhcvr9flv8bx76v9hrwc9qmazmp60407q7cghn0k8zk"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-cl-str
+ sbcl-fiveam
+ sbcl-parachute
+ sbcl-lisp-unit2))
+ (home-page "https://github.com/tdrhq/slite")
+ (synopsis "Common Lisp system for Slite ")
+ (description
+ "This package provides the Common Lisp part of the emacs-slite test runner.")
+ (license license:asl2.0))))
+
+(define-public cl-slite
+ (sbcl-package->cl-source-package sbcl-slite))
+
+(define-public ecl-slite
+ (sbcl-package->ecl-package sbcl-slite))
+
(define-public sbcl-parseq
(package
(name "sbcl-parseq")
--
2.41.0
Y
Y
ykonai wrote on 23 Aug 2023 19:48
[PATCH 2/2] gnu: Add emacs-slite.
(address . 65477@debbugs.gnu.org)
9d1940eb5c8adfa295f690d451c04ec2beb3bb87.1692810936.git.mail@ykonai.net
* gnu/packages/emacs-xyz.scm (emacs-slite): New variable.
---
gnu/packages/emacs-xyz.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 977d553ea5..06682e2227 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9757,6 +9757,21 @@ (define-public emacs-slime
for compilation, debugging, documentation lookup, and so on.")
(license (list license:gpl2+ license:public-domain))))
+(define-public emacs-slite
+ (package
+ (inherit sbcl-slite)
+ (name "emacs-slite")
+ (build-system emacs-build-system)
+ (synopsis "SLIme-based TEst runner for FiveAM and Parachute Tests")
+ (description
+ "Slite interactively runs your Common Lisp tests (currently only FiveAM
+and Parachute are supported). It allows you to see the summary of test
+failures, jump to test definitions, rerun tests with debugger all from inside
+Emacs.
+
+In order to work, this also requires the slite Common Lisp system to be
+present. See the code@{*cl-slite packages}.")))
+
(define-public emacs-popup
(package
(name "emacs-popup")
--
2.41.0
L
L
Ludovic Courtès wrote on 17 Sep 2023 15:30
Re: bug#65477: [PATCH 0/2] Add emacs-slite
(name . ykonai)(address . mail@ykonai.net)(address . 65477@debbugs.gnu.org)
87wmwpvsep.fsf_-_@gnu.org
Hi,

ykonai <mail@ykonai.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-slite): New variable.

[...]

Toggle quote (4 lines)
> +(define-public emacs-slite
> + (package
> + (inherit sbcl-slite)

Since ‘sbcl-slite’ is defined in lisp-xyz.scm, you should either define
‘emacs-slite’ in that same file or the other way around.

Could you send an updated patch?

Thanks,
Ludo’.
Y
Y
ykonai wrote on 27 Sep 2023 22:33
[PATCH v2 1/2] gnu: Add cl-slite.
(address . 65477@debbugs.gnu.org)
31ccdfcb77fe881b5720b640f4851ac51d2c1218.1695846794.git.mail@ykonai.net
* gnu/packages/lisp-xyz.scm (cl-slite, ecl-slite, sbcl-slite): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d62122f408..6f9a942a30 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -27328,6 +27328,39 @@ (define-public cl-slot-extra-options
(define-public ecl-slot-extra-options
(sbcl-package->ecl-package sbcl-slot-extra-options))
+(define-public sbcl-slite
+ (let ((commit "942a95330592d30be5ac02fb1b697fb14ccbf1af")
+ (revision "0"))
+ (package
+ (name "sbcl-slite")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdrhq/slite/")
+ (commit commit)))
+ (file-name (git-file-name "slite" version))
+ (sha256
+ (base32 "0b4c4vs1zlhcvr9flv8bx76v9hrwc9qmazmp60407q7cghn0k8zk"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-cl-str
+ sbcl-fiveam
+ sbcl-parachute
+ sbcl-lisp-unit2))
+ (home-page "https://github.com/tdrhq/slite")
+ (synopsis "Common Lisp system for Slite ")
+ (description
+ "This package provides the Common Lisp part of the emacs-slite test runner.")
+ (license license:asl2.0))))
+
+(define-public cl-slite
+ (sbcl-package->cl-source-package sbcl-slite))
+
+(define-public ecl-slite
+ (sbcl-package->ecl-package sbcl-slite))
+
(define-public sbcl-parseq
(package
(name "sbcl-parseq")

base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
--
2.41.0
Y
Y
ykonai wrote on 27 Sep 2023 22:33
[PATCH v2 2/2] gnu: Add emacs-slite.
(address . 65477@debbugs.gnu.org)
a420186bcb0d5137bfa3cee1f2aae4a2e62eded8.1695846794.git.mail@ykonai.net
* gnu/packages/lisp-xyz.scm (emacs-slite): New variable.

The package is within lisp-xyz.scm due to inheriting from sbcl-slite (as it is
really one project, with an CL part and an Emacs part).
---
gnu/packages/lisp-xyz.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6f9a942a30..5cd9a61680 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -72,6 +72,7 @@ (define-module (gnu packages lisp-xyz)
#:use-module (guix build-system asdf)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system emacs)
#:use-module (gnu packages audio)
#:use-module (gnu packages base)
#:use-module (gnu packages c)
@@ -27361,6 +27362,21 @@ (define-public cl-slite
(define-public ecl-slite
(sbcl-package->ecl-package sbcl-slite))
+(define-public emacs-slite
+ (package
+ (inherit sbcl-slite)
+ (name "emacs-slite")
+ (build-system emacs-build-system)
+ (synopsis "SLIme-based TEst runner for FiveAM and Parachute Tests")
+ (description
+ "Slite interactively runs your Common Lisp tests (currently only FiveAM
+and Parachute are supported). It allows you to see the summary of test
+failures, jump to test definitions, rerun tests with debugger all from inside
+Emacs.
+
+In order to work, this also requires the slite Common Lisp system to be
+present. See the code@{*cl-slite packages}.")))
+
(define-public sbcl-parseq
(package
(name "sbcl-parseq")
--
2.41.0
Y
Y
ykonai wrote on 27 Sep 2023 22:36
Re: bug#65477: [PATCH 0/2] Add emacs-slite
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 65477@debbugs.gnu.org)
8534yzqrpq.fsf@ykonai.net
Hi,

I moved it into the lisp-xyz.scm file. This required adding the emacs
build-system to the list of required modules in lisp-xyz.scm. Apologies
for the delay.
L
L
Ludovic Courtès wrote on 19 Oct 2023 22:02
Re: [bug#65477] [PATCH v2 1/2] gnu: Add cl-slite.
(name . ykonai)(address . mail@ykonai.net)(address . 65477-done@debbugs.gnu.org)
87edhqz8hv.fsf@gnu.org
Hi,

ykonai <mail@ykonai.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/lisp-xyz.scm (cl-slite, ecl-slite, sbcl-slite): New variables.

[...]

Toggle quote (2 lines)
> * gnu/packages/lisp-xyz.scm (emacs-slite): New variable.

Applied, thanks!

Ludo’.
Closed
?