[PATCH] services: mcron: Add module for %user-log-dir.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 21 Aug 2023 06:33
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
a6fdad6d07523a320eb682aa0b025573c4d66ed8.1692591833.git.hako@ultrarare.space
* gnu/services/mcron.scm (mcron-shepherd-services)[modules]: Add
(shepherd support) for home service.
---

This patch fixes the following error:
Loading /gnu/store/...-shepherd.conf.
herd: error: exception caught while executing 'load' on service 'root':
Unbound variable: %user-log-dir

I wasn't fully sure to report the issue in #65119 since the error didn't occur
in a home container, sorry for my hesitation.

gnu/services/mcron.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index db8b539ff5..efb7465549 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -165,6 +165,9 @@ (define (mcron-shepherd-services config)
(ice-9 popen) ;for the 'schedule' action
(ice-9 rdelim)
(ice-9 match)
+ ,(if home-service?
+ '(shepherd support) ;for '%user-log-dir'
+ '())
,@%default-modules))
(start #~(make-forkexec-constructor
(list #$(file-append mcron "/bin/mcron")

base-commit: 7cad70566322262f6acdbbb965e867e34010eb55
--
2.41.0
H
H
Hilton Chain wrote on 22 Aug 2023 14:47
(address . 65413-done@debbugs.gnu.org)
878ra3w8eg.wl-hako@ultrarare.space
On Mon, 21 Aug 2023 12:33:22 +0800,
Hilton Chain wrote:
Toggle quote (5 lines)
>
> * gnu/services/mcron.scm (mcron-shepherd-services)[modules]: Add
> (shepherd support) for home service.
> ---

Pushed as 552d0703776c532f25498d5cb852c3c497cb9252.
Closed
H
H
Hilton Chain wrote on 22 Aug 2023 17:21
(address . 65413@debbugs.gnu.org)
874jkrw1ax.wl-hako@ultrarare.space
On Tue, 22 Aug 2023 20:47:51 +0800,
Hilton Chain wrote:
Toggle quote (10 lines)
>
> On Mon, 21 Aug 2023 12:33:22 +0800,
> Hilton Chain wrote:
> >
> > * gnu/services/mcron.scm (mcron-shepherd-services)[modules]: Add
> > (shepherd support) for home service.
> > ---
>
> Pushed as 552d0703776c532f25498d5cb852c3c497cb9252.

Fixup pushed as 0c4fb8f43f8aba2dcabe1bc97a8f6d8d41057704...

Toggle snippet (16 lines)
1 file changed, 1 insertion(+), 3 deletions(-)
gnu/services/mcron.scm | 4 +---

modified gnu/services/mcron.scm
@@ -165,9 +165,7 @@ (define (mcron-shepherd-services config)
(ice-9 popen) ;for the 'schedule' action
(ice-9 rdelim)
(ice-9 match)
- ,(if home-service?
- '((shepherd support) #:select (%user-log-dir))
- '())
+ ((shepherd support) #:select (%user-log-dir))
,@%default-modules))
(start #~(make-forkexec-constructor
(list #$(file-append mcron "/bin/mcron")
L
L
Ludovic Courtès wrote on 22 Aug 2023 18:11
Re: [bug#65413] [PATCH] services: mcron: Add module for %user-log-dir.
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 65413@debbugs.gnu.org)
871qfv5a6w.fsf@gnu.org
Hilton Chain <hako@ultrarare.space> skribis:

Toggle quote (12 lines)
> * gnu/services/mcron.scm (mcron-shepherd-services)[modules]: Add
> (shepherd support) for home service.
> ---
>
> This patch fixes the following error:
> Loading /gnu/store/...-shepherd.conf.
> herd: error: exception caught while executing 'load' on service 'root':
> Unbound variable: %user-log-dir
>
> I wasn't fully sure to report the issue in #65119 since the error didn't occur
> in a home container, sorry for my hesitation.

I tested the changes in ‘guix home container’ and didn’t notice the
error; I wonder what’s going on, would be worth investigating.

Anyway, thanks for the quick fix!

Ludo’.
?