[PATCH] gnu: scilab: Fix compilation error.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 17 Aug 2023 20:15
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
03a288df56dc60850e6a8c0fc2785949e209f33a.1692296107.git.ngraves@ngraves.fr
---
gnu/packages/maths.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (88 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8b765e886b..7a6a26d806 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8546,6 +8546,10 @@ (define-public scilab
"__threadSignal InterpReady;" "\n"
"__threadSignalLock InterpReadyLock;"
"\n")))
+ ;; Fix CPP compilation errors.
+ (substitute* "modules/output_stream/src/cpp/diary_manager.cpp"
+ (("if \\(array_size > 0\\)")
+ "if (*array_size > 0)"))
;; Set SCIHOME to /tmp before macros compilation.
(setenv "SCIHOME" "/tmp"))))))
(home-page "https://scilab.org")

base-commit: 9896b37ac53e9b0504de55dd5ba4bfa2c241a7ed
prerequisite-patch-id: cccdad83975cbf04d7bd618c2c1a4b4de6fa7fd2
prerequisite-patch-id: 6f28833d2efa054d55126980f87ba4d2fdd13c6d
prerequisite-patch-id: afc6cadece838372370f7093f863ce8eaae7bc55
prerequisite-patch-id: b9330c12700355319c104aa3b493eafe03cbb619
prerequisite-patch-id: 46fa9c5a48fcc5b13409049b14b6e7314a6d6956
prerequisite-patch-id: 846f8b50b8de749caaa459b874087d06e15e0a80
prerequisite-patch-id: 023101e5a315951ce9786fb8230955c97001dac9
prerequisite-patch-id: d4b0193f128d8236026e079e746ea0cf6c4c0af0
prerequisite-patch-id: d73442d6d7c88e7375e9de0a9cd655cacb7766f9
prerequisite-patch-id: d8a56dd7bc6c1c3ba3ac0f77b2402b9c6469cfb2
prerequisite-patch-id: 3bc2b2eecd799be8d8b0f96b850ef83a6306dab7
prerequisite-patch-id: 798d4a277eff03a59339af4ebe19406682f361ab
prerequisite-patch-id: 3f65e9cdab64edeacfeb5748cd4fb130839b2b30
prerequisite-patch-id: 6f8225b63a1dd1866b05bb91544e49d7c096601c
prerequisite-patch-id: ff71ec9bdf6337390a720db4535268af271e32df
prerequisite-patch-id: c6b40cc38f5bdfab229ac3d7ed4346c5d9f1b2f7
prerequisite-patch-id: 9ab6dade9e641d5e667ba6a61dbfbb3d32c943a6
prerequisite-patch-id: 4fcae29a8f6dd95716669680141da315acaf6e59
prerequisite-patch-id: 0a5a6da0061188dc9be59bc9829db53288307c58
prerequisite-patch-id: 83c4b7d9d831990e4d37ba89c584d773c872ba6b
prerequisite-patch-id: 1c8dddf99041cf399b8836e3ad6721d7bbcebb7c
prerequisite-patch-id: 773df13cc85606b205d1d914e59525b7a6820a1d
prerequisite-patch-id: 6f8974ce8c0a3a25721a41781f9b0dfd61e96cf4
prerequisite-patch-id: d219948d28923c5ccd34b63f988032df33f2f336
prerequisite-patch-id: 0bd75bb28df9ccf3405caf8217d708afc978047d
prerequisite-patch-id: 26476dd782cf8f5e427d4bd36ac85957538a0aa3
prerequisite-patch-id: b5f87c460fd984c41fbb52e7e0dc305c20c46f22
prerequisite-patch-id: 5502b9c6a64abaca6a9921f25cd324869d26aa1e
prerequisite-patch-id: a7e84bb368349566e9a6fdbe49a371fdb464bb1e
prerequisite-patch-id: a84a766ceef6bedd5da3f9512c87a2c2a11ff33f
prerequisite-patch-id: 0175b2b1cbbc15c1c775147821715bca9e3303a3
prerequisite-patch-id: 9c20b408ac8aa275ecba58383d83be5cef7647df
prerequisite-patch-id: 836749cd3bd3b86f64de637c3c2df48a3608f09f
prerequisite-patch-id: 28ea1ddbef32a1bc9e908f3f9c7466953c60f13d
prerequisite-patch-id: 52a78e387e36e6408d7147950195d552e4e41528
prerequisite-patch-id: 87fee01a70d4b8cbfca44cc0a9c9f54471a92d18
prerequisite-patch-id: 8c8cdb345e815fc3332805ca224103f185d4a568
prerequisite-patch-id: 3434c5caf1eba9e9a64c673681e5911d2c1d9232
prerequisite-patch-id: c45bf303726fb3dacee01a66c0ff75105a81164d
prerequisite-patch-id: d44a1adb0404f23522aac21fa8a7f26be7ddabdc
prerequisite-patch-id: e422fe29bbcef80260b190637faa1a4953c3f1cb
prerequisite-patch-id: 285479a1a1e46e6f0f8aba5429edfa400c81b32b
prerequisite-patch-id: 30fcff6f8c9328c71d3fca609cddde0b56973bb7
prerequisite-patch-id: 70bb47ccac3375de893e4e640ce7c59369a05a39
prerequisite-patch-id: cc3d79386ca4a93146dc195cd5732764f1ac447f
prerequisite-patch-id: 2686866ec4bf08c7faa05b17cb84d9e0c13ec12c
prerequisite-patch-id: 369b61e07e3c90151a5414b784513b9ae3d3e978
prerequisite-patch-id: 065651c3a8cee63b725d7f86c080c274b494627e
prerequisite-patch-id: 1ee71844f0c9a0112a456e5b76079239906a7fb8
prerequisite-patch-id: c7b3d9c5bff04c16576781eff50ce37f7c49131c
prerequisite-patch-id: c8b8fe8dc51fea0b8a2626cf7031f01b6000e023
prerequisite-patch-id: 182e25335d4c357001f4f8bed2b3f89b91d9cae5
prerequisite-patch-id: c0ea00d5f4c6a83642a92c9341f0288fbfe3095a
prerequisite-patch-id: 795d31cc33a24a6a57e67af31b65acd8faa8187c
prerequisite-patch-id: 358af8aa7fa71b5cb8fbe6dde29d141bb7c57f1e
prerequisite-patch-id: b9ab3ee98a9d4ca518a4d99042982d64fbce5d05
prerequisite-patch-id: 12b76e9c2751da73ed64c9489b15f74ff17568cf
prerequisite-patch-id: eb618ab7b10483d917c308a38792af98baa517e2
prerequisite-patch-id: aca7b0d7b302853e522f47700d0780a96b4a72e6
prerequisite-patch-id: c6bbe6026bfcd2c9ff6e06efc5b8424a6943d1bf
prerequisite-patch-id: 1dc9b52f102fa787539119b849a14224ef7b4fa5
prerequisite-patch-id: 5f664cb2fd995a53765c5ffc19a708ac795cc0c4
prerequisite-patch-id: 8e234d0f4d93d2aad499eec8842be3d28da98707
prerequisite-patch-id: 40b6c9f09f27833367a71ec25d77afae4d2a835e
prerequisite-patch-id: 45e65ea00ece53f3496251401acd464081f8ca7a
prerequisite-patch-id: c12968d02d99c253f858586a86b16fa32d41f1c1
prerequisite-patch-id: 5f3241174d47de322626fe034db348320830997d
prerequisite-patch-id: 86baa45ec2aad977c8c8135f7613aa391155de6d
prerequisite-patch-id: 05e12788823a88a516418532f9bf441ceebc53b6
--
2.41.0
A
A
Andreas Enge wrote on 17 Aug 2023 20:42
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
ZN5qBMyRq5vFizuz@jurong
Hello Nicolas,

Am Thu, Aug 17, 2023 at 08:15:07PM +0200 schrieb Nicolas Graves:
Toggle quote (4 lines)
> + (substitute* "modules/output_stream/src/cpp/diary_manager.cpp"
> + (("if \\(array_size > 0\\)")
> + "if (*array_size > 0)"))

the fix looks right to me. But our scilab version is 8 years old, while there
are newer versions around. Would it make sense to rather update the package
to a newer version? (I had a look at 5.2.2, 6.0.0 and 6.1.1, but all of them
would still require your suggested fix.)

Andreas
A
A
Andreas Enge wrote on 18 Aug 2023 20:23
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
ZN-3HT15NUDqFw-O@jurong
Am Thu, Aug 17, 2023 at 08:42:12PM +0200 schrieb Andreas Enge:
Toggle quote (5 lines)
> the fix looks right to me. But our scilab version is 8 years old, while there
> are newer versions around. Would it make sense to rather update the package
> to a newer version? (I had a look at 5.2.2, 6.0.0 and 6.1.1, but all of them
> would still require your suggested fix.)

I have pushed the fix and updated scilab to 5.2.2.

I have also tried 6.1.1, and attached is how far I got.
The lines for including strings.h instead of string.h are a failed attempt
to have strcasecmp defined; with and without it the error message is
In file included from ../../modules/ast/includes/types/arrayof.hxx:33,
from ../../modules/ast/includes/types/double.hxx:28,
from ../../modules/ast/includes/symbol/variables.hxx:24,
from ../../modules/ast/includes/symbol/context.hxx:25,
from ../../modules/ast/includes/ast/runvisitor.hxx:19,
from ../../modules/ast/includes/ast/execvisitor.hxx:19,
from src/cpp/funcmanager.cpp:31:
src/cpp/funcmanager.cpp: In member function ‘bool FuncManager::AppendModules()’:
../../modules/string/includes/os_string.h:107:25: error: ‘strcasecmp’ was not declared in this scope; did you mean ‘wcscasecmp’?
107 | #define stricmp strcasecmp
| ^~~~~~~~~~
src/cpp/funcmanager.cpp:134:9: note: in expansion of macro ‘stricmp’
134 | if (stricmp("utf-8", encoding) == 0)
| ^~~~~~~

The file looks unchanged in the latest git commit of scilab, and I have not
seen a corresponding patch in the Debian package, so I have given up.

Andreas
Toggle diff (63 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1666d6e420..837d055c8e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8457,7 +8457,7 @@ (define-public optizelle
(define-public scilab
(package
(name "scilab")
- (version "5.5.2")
+ (version "6.1.1")
(source
(origin
(method url-fetch)
@@ -8465,9 +8465,9 @@ (define-public scilab
(string-append "https://www.scilab.org/download/"
version "/scilab-" version "-src.tar.gz"))
(sha256
- (base32 "0phg9pn24yw98hbh475ik84dnikf1225b2knh7qbhdbdx6fm2d57"))))
+ (base32 "01s28d162znwl7na0qlclzmfg6h7kwgmly1hr5vc51fkidilf4z5"))))
(build-system gnu-build-system)
- (native-inputs (list pkg-config gfortran))
+ (native-inputs (list pkg-config gfortran eigen))
(inputs (list libxml2
`(,pcre "bin")
`(,pcre "out")
@@ -8495,7 +8495,9 @@ (define-public scilab
"--without-javasci"
"--disable-build-help"
"--with-external-scirenderer"
- ;; Tcl and Tk library locations.
+ ;; Disable the Scicos modelica compiler, which requires ocamlc.
+ "--without-modelica"
+ ;; Header and library locations.
(string-append "--with-tcl-include="
(string-drop-right
(search-input-file %build-inputs "include/tcl.h")
@@ -8512,6 +8514,10 @@ (define-public scilab
(string-drop-right
(search-input-directory %build-inputs "lib/tk8.6")
(string-length "/tk8.6")))
+ (string-append "--with-eigen-include="
+ (string-drop-right
+ (search-input-file %build-inputs "include/eigen3/Eigen/Sparse")
+ (string-length "/Eigen/Sparse")))
;; There are some 2018-fortran errors that are ignored
;; with this fortran compiler flag.
"FFLAGS=-fallow-argument-mismatch")
@@ -8538,6 +8544,9 @@ (define-public scilab
(("(H5Rdereference\\(_iDatasetId, H5R_OBJECT, )&(.*)\\);$"
all common ref)
(string-append common ref)))
+ (substitute* "modules/string/includes/os_string.h"
+ (("#include <string.h>")
+ "#include <strings.h>"))
;; fix multiple definitions
(substitute* "modules/tclsci/src/c/TCL_Command.h"
(("^__thread")
@@ -8562,4 +8571,4 @@ (define-public scilab
statistical analysis, image enhancement, fluid dynamics simulations, numerical
optimization, and modeling, simulation of explicit and implicit dynamical
systems and symbolic manipulations.")
- (license license:cecill))) ;CeCILL v2.1
+ (license license:gpl2+)))
L
L
Ludovic Courtès wrote on 21 Aug 2023 18:47
control message for bug #65357
(address . control@debbugs.gnu.org)
87edjw8hqa.fsf@gnu.org
close 65357
quit
A
A
Andreas Enge wrote on 30 Aug 2023 11:47
Re: [bug#65357] [PATCH] gnu: scilab: Fix compilation error.
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
ZO8QNlTYUPJ-Dgdv@jurong
Hello,

Am Fri, Aug 18, 2023 at 08:23:25PM +0200 schrieb Andreas Enge:
Toggle quote (9 lines)
> ../../modules/string/includes/os_string.h:107:25: error: ‘strcasecmp’ was not declared in this scope; did you mean ‘wcscasecmp’?
> 107 | #define stricmp strcasecmp
> | ^~~~~~~~~~
> src/cpp/funcmanager.cpp:134:9: note: in expansion of macro ‘stricmp’
> 134 | if (stricmp("utf-8", encoding) == 0)
> | ^~~~~~~
> The file looks unchanged in the latest git commit of scilab, and I have not
> seen a corresponding patch in the Debian package, so I have given up.

"man strcasecmp" has this to say:
NOTES
The strcasecmp() and strncasecmp() functions first appeared in 4.4BSD, where they were declared in
<string.h>. Thus, for reasons of historical compatibility, the glibc <string.h> header file also de?
clares these functions, if the _DEFAULT_SOURCE (or, in glibc 2.19 and earlier, _BSD_SOURCE) feature
test macro is defined.

So it might be enough to just add "#define _DEFAULT_SOURCE" somewhere.

Andreas
A
A
Andreas Enge wrote on 31 Aug 2023 14:17
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
ZPCE9zqADSazsGwn@jurong
Am Wed, Aug 30, 2023 at 11:47:34AM +0200 schrieb Andreas Enge:
Toggle quote (2 lines)
> So it might be enough to just add "#define _DEFAULT_SOURCE" somewhere.

This was not the problem.

As the topic of this issue is solved and none of us is going to continue
the investigations for updating scilab, I am closing the issue.

Andreas
Closed
?