[PATCH] Fixing tilix compile issue by upgrading version

  • Done
  • quality assurance status badge
Details
2 participants
  • Aaron Covrig
  • John Kehayias
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 16 Aug 2023 03:34
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
a12f7c006dc85e9f3a5b2821c8eaf1106847aa05.1692149699.git.aaron.covrig.us@ieee.org
Changes:
1. Changed tilix from v1.9.5 to untagged v1.9.6
---
gnu/packages/terminals.scm | 92 +++++++++++++++++++-------------------
1 file changed, 47 insertions(+), 45 deletions(-)

Toggle diff (121 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 081ef19af1..57f72881a8 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1339,50 +1340,51 @@ (define-public wterm
(deprecated-package "wterm" foot))
(define-public tilix
- (package
- (name "tilix")
- (version "1.9.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gnunn1/tilix")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ij3ix6yhi8hicxvglrxjyyv8bch9birrgsr8ml6jfh3hvk4pxdh"))))
- (build-system meson-build-system)
- (arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'set-env-variables
- (lambda _
- (setenv "CC" ,(cc-for-target))))
- (add-after 'unpack 'skip-gtk-update-icon-cache
- (lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true"))
- (("update-desktop-database") (which "true"))))))))
- (inputs
- (list dbus
- dconf
- gsettings-desktop-schemas
- gtk+
- gtkd
- ldc
- libsecret
- libunwind
- vte))
- (native-inputs
- (list appstream
- gettext-minimal
- (list glib "bin")
- ldc
- pkg-config))
- (home-page "https://gnunn1.github.io/tilix-web/")
- (synopsis "Tiling terminal emulator")
- (description "Tilix is a tiling terminal emulator following the
+ (let ((commit "e2c75f417a84ad784735524f1b8bf01c516f705d")
+ (revision "1")) ;Guix package revision
+ (package
+ (name "tilix")
+ ;; unreleased version 1.9.6 (RELEASE.md reports 1.9.6, but no Git tag created)
+ (version (git-version "1.9.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnunn1/tilix")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k5r99c9ab1l0v37hs1zy08rspgv8n7y3bd13ljqg607cyalbgbf"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-env-variables
+ (lambda _
+ (setenv "CC"
+ ,(cc-for-target))))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache")
+ (which "true"))
+ (("update-desktop-database")
+ (which "true"))))))))
+ (inputs (list dbus
+ dconf
+ gsettings-desktop-schemas
+ gtk+
+ gtkd
+ ldc
+ libsecret
+ libunwind
+ vte))
+ (native-inputs (list appstream gettext-minimal
+ (list glib "bin") ldc pkg-config))
+ (home-page "https://gnunn1.github.io/tilix-web/")
+ (synopsis "Tiling terminal emulator")
+ (description
+ "Tilix is a tiling terminal emulator following the
Gnome Human Interface Guidelines. Its features include:
@enumerate
@item Layout terminals in any fashion by splitting them horizontally or
@@ -1394,7 +1396,7 @@ (define-public tilix
terminal are replicated to the others.
@item Supports notifications when processes are completed out of view.
@end enumerate")
- (license license:mpl2.0)))
+ (license license:mpl2.0))))
(define-public tio
(package

base-commit: be6f5edd445850720dfcec2642db643b84fc0645
--
2.41.0
A
A
Aaron Covrig wrote on 21 Aug 2023 06:26
[PATCH v1] Fixing tilix compile issues by including updates
(address . 65330@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
17bcec724e8a16665c3f17079ced6ac46bff7e98.1692591975.git.aaron.covrig.us@ieee.org
1. Changed tilix from v1.9.5 to v1.9.5 + commits
---
This revision changes the version to reflect that this is built
upon v1.9.5 with added commits, rather than being v1.9.6;
additionally, it corrects line spacing so that only the
changed parts are seen as modified by git
gnu/packages/terminals.scm | 26 +++++++++++++++-----------
1 file changed, 15 insertions(+), 11 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 5fc72d7937..fd55233a5b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1339,18 +1340,21 @@ (define-public wterm
(deprecated-package "wterm" foot))
(define-public tilix
+(let ((commit "e2c75f417a84ad784735524f1b8bf01c516f705d")
+ (revision "0"))
(package
(name "tilix")
- (version "1.9.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gnunn1/tilix")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ij3ix6yhi8hicxvglrxjyyv8bch9birrgsr8ml6jfh3hvk4pxdh"))))
+ ;; includes commits that fix glibc related build issues
+ (version (git-version "1.9.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnunn1/tilix")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k5r99c9ab1l0v37hs1zy08rspgv8n7y3bd13ljqg607cyalbgbf"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -1394,7 +1398,7 @@ (define-public tilix
terminal are replicated to the others.
@item Supports notifications when processes are completed out of view.
@end enumerate")
- (license license:mpl2.0)))
+ (license license:mpl2.0))))
(define-public tio
(package

base-commit: 7cad70566322262f6acdbbb965e867e34010eb55
--
2.41.0
J
J
John Kehayias wrote on 22 Aug 2023 21:08
Re: bug#65330: [PATCH] Fixing tilix compile issue by upgrading version
(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)(address . 65330-done@debbugs.gnu.org)
87y1i2j3oa.fsf_-_@protonmail.com
Hello,

On Mon, Aug 21, 2023 at 12:26 AM, Aaron Covrig wrote:

Toggle quote (7 lines)
> 1. Changed tilix from v1.9.5 to v1.9.5 + commits
> ---
> This revision changes the version to reflect that this is built
> upon v1.9.5 with added commits, rather than being v1.9.6;
> additionally, it corrects line spacing so that only the
> changed parts are seen as modified by git

We were discussing on IRC the other day. I meant that no changes to the
formatting besides the spacing introduced by the let should be made;
this still requires re-indenting the rest of the package definition.

Anyway, I adjusted the commit message, fixed the formatting, and used
the latest commit of tilix. I checked that this built locally as well.

Thanks for your contribution!

John

Toggle quote (58 lines)
> gnu/packages/terminals.scm | 26 +++++++++++++++-----------
> 1 file changed, 15 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
> index 5fc72d7937..fd55233a5b 100644
> --- a/gnu/packages/terminals.scm
> +++ b/gnu/packages/terminals.scm
> @@ -33,6 +33,7 @@
> ;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
> ;;; Copyright © 2022 ( <paren@disroot.org>
> ;;; Copyright © 2022 jgart <jgart@dismail.de>
> +;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -1339,18 +1340,21 @@ (define-public wterm
> (deprecated-package "wterm" foot))
>
> (define-public tilix
> +(let ((commit "e2c75f417a84ad784735524f1b8bf01c516f705d")
> + (revision "0"))
> (package
> (name "tilix")
> - (version "1.9.5")
> - (source
> - (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/gnunn1/tilix")
> - (commit version)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32 "1ij3ix6yhi8hicxvglrxjyyv8bch9birrgsr8ml6jfh3hvk4pxdh"))))
> + ;; includes commits that fix glibc related build issues
> + (version (git-version "1.9.5" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/gnunn1/tilix")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1k5r99c9ab1l0v37hs1zy08rspgv8n7y3bd13ljqg607cyalbgbf"))))
> (build-system meson-build-system)
> (arguments
> `(#:glib-or-gtk? #t
> @@ -1394,7 +1398,7 @@ (define-public tilix
> terminal are replicated to the others.
> @item Supports notifications when processes are completed out of view.
> @end enumerate")
> - (license license:mpl2.0)))
> + (license license:mpl2.0))))
>
> (define-public tio
> (package
>
> base-commit: 7cad70566322262f6acdbbb965e867e34010eb55
Closed
A
A
Aaron Covrig wrote on 23 Aug 2023 03:45
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 65330@debbugs.gnu.org)
20230822214554.28cd7227@mobile-dev
Awesome, thank you John for your assistance and reviewing!

v/r,

Aaron Covrig

On Tue, 22 Aug 2023 19:08:26 +0000
John Kehayias <john.kehayias@protonmail.com> wrote:

Toggle quote (83 lines)
> Hello,
>
> On Mon, Aug 21, 2023 at 12:26 AM, Aaron Covrig wrote:
>
> > 1. Changed tilix from v1.9.5 to v1.9.5 + commits
> > ---
> > This revision changes the version to reflect that this is built
> > upon v1.9.5 with added commits, rather than being v1.9.6;
> > additionally, it corrects line spacing so that only the
> > changed parts are seen as modified by git
>
> We were discussing on IRC the other day. I meant that no changes to
> the formatting besides the spacing introduced by the let should be
> made; this still requires re-indenting the rest of the package
> definition.
>
> Anyway, I adjusted the commit message, fixed the formatting, and used
> the latest commit of tilix. I checked that this built locally as well.
>
> Thanks for your contribution!
>
> John
>
> > gnu/packages/terminals.scm | 26 +++++++++++++++-----------
> > 1 file changed, 15 insertions(+), 11 deletions(-)
> >
> > diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
> > index 5fc72d7937..fd55233a5b 100644
> > --- a/gnu/packages/terminals.scm
> > +++ b/gnu/packages/terminals.scm
> > @@ -33,6 +33,7 @@
> > ;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
> > ;;; Copyright © 2022 ( <paren@disroot.org>
> > ;;; Copyright © 2022 jgart <jgart@dismail.de>
> > +;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
> > ;;;
> > ;;; This file is part of GNU Guix.
> > ;;;
> > @@ -1339,18 +1340,21 @@ (define-public wterm
> > (deprecated-package "wterm" foot))
> >
> > (define-public tilix
> > +(let ((commit "e2c75f417a84ad784735524f1b8bf01c516f705d")
> > + (revision "0"))
> > (package
> > (name "tilix")
> > - (version "1.9.5")
> > - (source
> > - (origin
> > - (method git-fetch)
> > - (uri (git-reference
> > - (url "https://github.com/gnunn1/tilix")
> > - (commit version)))
> > - (file-name (git-file-name name version))
> > - (sha256
> > - (base32
> > "1ij3ix6yhi8hicxvglrxjyyv8bch9birrgsr8ml6jfh3hvk4pxdh"))))
> > + ;; includes commits that fix glibc related build issues
> > + (version (git-version "1.9.5" revision commit))
> > + (source (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/gnunn1/tilix")
> > + (commit commit)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> > +
> > "1k5r99c9ab1l0v37hs1zy08rspgv8n7y3bd13ljqg607cyalbgbf"))))
> > (build-system meson-build-system) (arguments
> > `(#:glib-or-gtk? #t
> > @@ -1394,7 +1398,7 @@ (define-public tilix
> > terminal are replicated to the others.
> > @item Supports notifications when processes are completed out of
> > view. @end enumerate")
> > - (license license:mpl2.0)))
> > + (license license:mpl2.0))))
> >
> > (define-public tio
> > (package
> >
> > base-commit: 7cad70566322262f6acdbbb965e867e34010eb55
>
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQSPXVwROJGaYSBOwhhfTkc5aZTD/QUCZOVk0gAKCRBfTkc5aZTD
/ROqAQCrk/Z2WE1WkBM5mbOHq19zOMrSneAaYpXLtqZAJDS/nwEAr/PbHgA21BF7
XoBdTAdsJBIWbMp/Du8QI/ev6HQvgwo=
=goFd
-----END PGP SIGNATURE-----


?