[PATCH] gnu: update emacs-orderless to 1.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Piotr Kwiecinski
Owner
unassigned
Submitted by
Piotr Kwiecinski
Severity
normal
P
P
Piotr Kwiecinski wrote on 14 Aug 2023 12:52
(address . guix-patches@gnu.org)(name . Piotr Kwiecinski)(address . piokwiecinski@gmail.com)
3fdc4c12bb7ce7ba962103f78dc00f091eae291e.1692005226.git.piokwiecinski@gmail.com
previously used commit was pointing to 0.8 instead 1.0
---
gnu/packages/emacs-xyz.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f0751e39a..e62c71752e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11290,8 +11290,7 @@ (define-public emacs-selectrum
(license license:expat)))
(define-public emacs-orderless
- (let ((commit "004cee6b8e01f8eb0cb1c683d0a637b14890600f"))
- (package
+ (package
(name "emacs-orderless")
(version "1.0")
(source
@@ -11299,9 +11298,9 @@ (define-public emacs-orderless
(method git-fetch)
(uri (git-reference
(url "https://github.com/oantolin/orderless")
- (commit commit)))
+ (commit version)))
(sha256
- (base32 "115bwqi2yc44bgvcl7lha8p2s6jgh5hksn4wa9s0kpfxhi14jwmy"))
+ (base32 "1jmwyici90v82gqjq44n0scrwhmg05pi9yplkn4bpss80c83dxp4"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(arguments
@@ -11322,7 +11321,7 @@ (define-public emacs-orderless
that match all of the components in any order. Each component can match in
any one of several ways: literally, as a regexp, as an initialism, in the flex
style, or as multiple word prefixes.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-consult
(package

base-commit: b15381460ed74e72792ff182dd2ca7a06ba59b0c
--
2.39.2
H
H
Hilton Chain wrote on 15 Aug 2023 09:27
(name . Piotr Kwiecinski)(address . piokwiecinski@gmail.com)(address . 65285@debbugs.gnu.org)
87350kojed.wl-hako@ultrarare.space
Hi Piotr,

Thank you for the patch! There're some minor changes to make.

On Mon, 14 Aug 2023 18:52:38 +0800,
Piotr Kwiecinski wrote:
Toggle quote (5 lines)
>
> previously used commit was pointing to 0.8 instead 1.0
> ---


Please write commit logs in ChangeLog format [1]. You can also check
the commit history for examples.

For this commit, the following can be used:
Toggle snippet (7 lines)
gnu: emacs-orderless: Update to 1.0.

* gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 1.0, previously used
commit was pointing to 0.8.


Toggle quote (44 lines)
> gnu/packages/emacs-xyz.scm | 9 ++++-----
> 1 file changed, 4 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 0f0751e39a..e62c71752e 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -11290,8 +11290,7 @@ (define-public emacs-selectrum
> (license license:expat)))
>
> (define-public emacs-orderless
> - (let ((commit "004cee6b8e01f8eb0cb1c683d0a637b14890600f"))
> - (package
> + (package
> (name "emacs-orderless")
> (version "1.0")
> (source
> @@ -11299,9 +11298,9 @@ (define-public emacs-orderless
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/oantolin/orderless")
> - (commit commit)))
> + (commit version)))
> (sha256
> - (base32 "115bwqi2yc44bgvcl7lha8p2s6jgh5hksn4wa9s0kpfxhi14jwmy"))
> + (base32 "1jmwyici90v82gqjq44n0scrwhmg05pi9yplkn4bpss80c83dxp4"))
> (file-name (git-file-name name version))))
> (build-system emacs-build-system)
> (arguments
> @@ -11322,7 +11321,7 @@ (define-public emacs-orderless
> that match all of the components in any order. Each component can match in
> any one of several ways: literally, as a regexp, as an initialism, in the flex
> style, or as multiple word prefixes.")
> - (license license:gpl3+))))
> + (license license:gpl3+)))
>
> (define-public emacs-consult
> (package
>
> base-commit: b15381460ed74e72792ff182dd2ca7a06ba59b0c
> --
> 2.39.2


I think it's fine to also change the indentation here, remove two
leading spaces in every line after the "(package" one, your editor may
do this for you. :)


Thanks

P
P
Piotr Kwiecinski wrote on 15 Aug 2023 11:19
[PATCH] gnu: emacs-orderless: Update to 1.0.
(address . 65285@debbugs.gnu.org)(name . Piotr Kwiecinski)(address . piokwiecinski@gmail.com)
4032a1092db3ebcc5e72c25771cabb840277a474.1692091092.git.piokwiecinski@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 1.0, previously used
commit was pointing to 0.8.
---
gnu/packages/emacs-xyz.scm | 57 +++++++++++++++++++-------------------
1 file changed, 28 insertions(+), 29 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f0751e39a..877895f011 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11290,39 +11290,38 @@ (define-public emacs-selectrum
(license license:expat)))
(define-public emacs-orderless
- (let ((commit "004cee6b8e01f8eb0cb1c683d0a637b14890600f"))
- (package
- (name "emacs-orderless")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/orderless")
- (commit commit)))
- (sha256
- (base32 "115bwqi2yc44bgvcl7lha8p2s6jgh5hksn4wa9s0kpfxhi14jwmy"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda _
- (invoke "makeinfo" "orderless.texi")
- (install-file "orderless.info"
- (string-append #$output "/share/info")))))))
- (native-inputs
- (list texinfo))
- (home-page "https://github.com/oantolin/orderless")
- (synopsis "Emacs completion style that matches multiple regexps in any order")
- (description "This package provides an orderless completion style that
+ (package
+ (name "emacs-orderless")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/orderless")
+ (commit version)))
+ (sha256
+ (base32 "1jmwyici90v82gqjq44n0scrwhmg05pi9yplkn4bpss80c83dxp4"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda _
+ (invoke "makeinfo" "orderless.texi")
+ (install-file "orderless.info"
+ (string-append #$output "/share/info")))))))
+ (native-inputs
+ (list texinfo))
+ (home-page "https://github.com/oantolin/orderless")
+ (synopsis "Emacs completion style that matches multiple regexps in any order")
+ (description "This package provides an orderless completion style that
divides the pattern into space-separated components, and matches candidates
that match all of the components in any order. Each component can match in
any one of several ways: literally, as a regexp, as an initialism, in the flex
style, or as multiple word prefixes.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-consult
(package

base-commit: 642ae73ec0c38ee4758ad9d39f16232c8945c6b6
--
2.39.2
P
P
Piotr Kwieci?ski wrote on 15 Aug 2023 11:32
Re: [bug#65285] [PATCH] gnu: update emacs-orderless to 1.0
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 65285@debbugs.gnu.org)
CAMv3DFV7F1sXkL02YQ=woY9Hhu4Vp2jrF2CiEC=D9xg1XR70_Q@mail.gmail.com
Hi Hilton,
thank you for the guidance and patience.
I hope the updated patch is correct now.

On Tue, 15 Aug 2023 at 09:29, Hilton Chain <hako@ultrarare.space> wrote:

Toggle quote (83 lines)
> Hi Piotr,
>
> Thank you for the patch! There're some minor changes to make.
>
> On Mon, 14 Aug 2023 18:52:38 +0800,
> Piotr Kwiecinski wrote:
> >
> > previously used commit was pointing to 0.8 instead 1.0
> > ---
>
>
> Please write commit logs in ChangeLog format [1]. You can also check
> the commit history for examples.
>
> For this commit, the following can be used:
> --8<---------------cut here---------------start------------->8---
> gnu: emacs-orderless: Update to 1.0.
>
> * gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 1.0, previously
> used
> commit was pointing to 0.8.
> --8<---------------cut here---------------end--------------->8---
>
>
> > gnu/packages/emacs-xyz.scm | 9 ++++-----
> > 1 file changed, 4 insertions(+), 5 deletions(-)
> >
> > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> > index 0f0751e39a..e62c71752e 100644
> > --- a/gnu/packages/emacs-xyz.scm
> > +++ b/gnu/packages/emacs-xyz.scm
> > @@ -11290,8 +11290,7 @@ (define-public emacs-selectrum
> > (license license:expat)))
> >
> > (define-public emacs-orderless
> > - (let ((commit "004cee6b8e01f8eb0cb1c683d0a637b14890600f"))
> > - (package
> > + (package
> > (name "emacs-orderless")
> > (version "1.0")
> > (source
> > @@ -11299,9 +11298,9 @@ (define-public emacs-orderless
> > (method git-fetch)
> > (uri (git-reference
> > (url "https://github.com/oantolin/orderless")
> > - (commit commit)))
> > + (commit version)))
> > (sha256
> > - (base32
> "115bwqi2yc44bgvcl7lha8p2s6jgh5hksn4wa9s0kpfxhi14jwmy"))
> > + (base32
> "1jmwyici90v82gqjq44n0scrwhmg05pi9yplkn4bpss80c83dxp4"))
> > (file-name (git-file-name name version))))
> > (build-system emacs-build-system)
> > (arguments
> > @@ -11322,7 +11321,7 @@ (define-public emacs-orderless
> > that match all of the components in any order. Each component can
> match in
> > any one of several ways: literally, as a regexp, as an initialism, in
> the flex
> > style, or as multiple word prefixes.")
> > - (license license:gpl3+))))
> > + (license license:gpl3+)))
> >
> > (define-public emacs-consult
> > (package
> >
> > base-commit: b15381460ed74e72792ff182dd2ca7a06ba59b0c
> > --
> > 2.39.2
>
>
> I think it's fine to also change the indentation here, remove two
> leading spaces in every line after the "(package" one, your editor may
> do this for you. :)
>
>
> Thanks
>
> [1]: <https://www.gnu.org/prep/standards/standards.html#Change-Logs>
>


--
Regards
Piotr Kwiecinski
Attachment: file
H
H
Hilton Chain wrote on 27 Aug 2023 05:54
Re: [bug#65285] [PATCH] gnu: emacs-orderless: Update to 1.0.
(name . Piotr Kwiecinski)(address . piokwiecinski@gmail.com)(address . 65285-done@debbugs.gnu.org)
8735055edz.wl-hako@ultrarare.space
Hi Piotr,

On Tue, 15 Aug 2023 17:19:03 +0800,
Piotr Kwiecinski wrote:
Toggle quote (5 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 1.0, previously used
> commit was pointing to 0.8.
> ---

Applied as e9bea73e2da021cfccfb5356d378f2feb668742c, thank you for the
contribution!
Closed
?