[PATCH] gnu: ardour: Build locales.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Denys Nykula
Owner
unassigned
Submitted by
Denys Nykula
Severity
normal
D
D
Denys Nykula wrote on 13 Aug 2023 16:38
(address . guix-patches@gnu.org)(name . Denys Nykula)(address . vegan@libre.net.ua)
20230813143802.15927-1-vegan@libre.net.ua
The TRANSLATORS file in the Ardour source says the i18n waf phase
is optional between the build and install phases.

* gnu/packages/audio.scm (ardour)[#:phases] Add build-i18n.
---
Tested the resulting build by running 'LANG=de_DE.UTF-8 ardour7'.

gnu/packages/audio.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8c15189b2b..006d21bbff 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -776,6 +776,9 @@ (define-public ardour
libdir "/panners" ":"
libdir "/surfaces" ":"
libdir "/vamp" "\"]"))))))
+ (add-after 'build 'build-i18n
+ (lambda _
+ (invoke "python" "waf" "i18n")))
(add-after 'install 'install-freedesktop-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.40.1
M
M
Maxim Cournoyer wrote on 6 Sep 2023 02:37
(name . Denys Nykula)(address . vegan@libre.net.ua)(address . 65271-done@debbugs.gnu.org)
87o7igf864.fsf@gmail.com
Hi!

Denys Nykula <vegan@libre.net.ua> writes:

Toggle quote (22 lines)
> The TRANSLATORS file in the Ardour source says the i18n waf phase
> is optional between the build and install phases.
>
> * gnu/packages/audio.scm (ardour)[#:phases] Add build-i18n.
> ---
> Tested the resulting build by running 'LANG=de_DE.UTF-8 ardour7'.
>
> gnu/packages/audio.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 8c15189b2b..006d21bbff 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -776,6 +776,9 @@ (define-public ardour
> libdir "/panners" ":"
> libdir "/surfaces" ":"
> libdir "/vamp" "\"]"))))))
> + (add-after 'build 'build-i18n
> + (lambda _
> + (invoke "python" "waf" "i18n")))

Installed, thanks for your contribution.

--
Thanks,
Maxim
Closed
?