add offpunk

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • ShinyZero0
Owner
unassigned
Submitted by
ShinyZero0
Severity
normal
S
S
ShinyZero0 wrote on 10 Aug 2023 10:06
(address . guix-patches@gnu.org)
CUOPJROOM6ZF.35KPDF9MJI7RB@Void
From 55885770d70ec38e190783c64322144d00495075 Mon Sep 17 00:00:00 2001
From: "zero@void" <shinyzero0@gmail.com>
Date: Thu, 10 Aug 2023 11:03:09 +0300
Subject: [PATCH] add offpunk

---
gnu/packages/web-browsers.scm | 49 +++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (84 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index c7143e3..e1b8fdd 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -43,6 +43,7 @@ (define-module (gnu packages web-browsers)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -61,6 +62,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fonts)
+ #:use-module (gnu packages file)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
@@ -71,7 +73,9 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages image-viewers)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages less)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -547,6 +551,51 @@ (define-public qutebrowser
GUI. It is based on PyQt5 and QtWebEngine.")
(license license:gpl3+)))
+(define-public offpunk
+ (package
+ (name "offpunk")
+ (version "1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~lioploum/offpunk")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0r8j01s3hdn3iq4ld6pj3v0h4hpakvkc4h55jzz7jr6az4y8lcgs"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'check)
+ (add-before 'wrap 'wrap-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append #$output
+ "/bin/offpunk")
+ `("PATH" ":" prefix
+ (,(string-append #$(this-package-input "less")
+ "/bin") ,(string-append #$(this-package-input
+ "file")
+ "/bin")
+ ,(string-append #$(this-package-input
+ "xdg-utils") "/bin")))))))))
+ (inputs (list python-cryptography
+ python-requests
+ python-feedparser
+ python-beautifulsoup4
+ python-readability-lxml
+ python-flit
+ xdg-utils
+ file
+ less))
+ (synopsis
+ "Command-line browser/feed reader for Gemini, Gopher, Spartan and Web")
+ (description
+ "The goal of Offpunk is to be able to synchronise your content once
+ (a day, a week, a month) and then browse/organise it while staying
+ disconnected")
+ (home-page "https://git.sr.ht/~lioploum/offpunk")
+ (license license:bsd-2)))
+
(define-public vimb
(package
(name "vimb")
--
2.41.0
S
S
ShinyZero0 wrote on 10 Aug 2023 12:47
[PATCH] fix formatting issues, remove unnecessary module import
(address . 65197@debbugs.gnu.org)
CUOSPCOA5POJ.CGNUST81C2DM@Void
From 392732b00eace467aa2fc894fbdcb56985513de9 Mon Sep 17 00:00:00 2001
From: "zero@void" <shinyzero0@gmail.com>
Date: Thu, 10 Aug 2023 13:32:47 +0300
Subject: [PATCH] fix formatting issues, remove unnecessary module

---
gnu/packages/web-browsers.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index e1b8fdd..d9f0e9c 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -73,7 +73,6 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
- #:use-module (gnu packages image-viewers)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages less)
#:use-module (gnu packages libevent)
@@ -572,12 +571,15 @@ (define-public offpunk
(wrap-program (string-append #$output
"/bin/offpunk")
`("PATH" ":" prefix
- (,(string-append #$(this-package-input "less")
- "/bin") ,(string-append #$(this-package-input
- "file")
- "/bin")
- ,(string-append #$(this-package-input
- "xdg-utils") "/bin")))))))))
+ (,(string-append
+ #$(this-package-input "less")
+ "/bin")
+ ,(string-append
+ #$(this-package-input "file")
+ "/bin")
+ ,(string-append
+ #$(this-package-input "xdg-utils")
+ "/bin")))))))))
(inputs (list python-cryptography
python-requests
python-feedparser
--
2.41.0
S
S
ShinyZero0 wrote on 13 Aug 2023 00:21
[PATCH] install manpage
(address . 65197@debbugs.gnu.org)
CUQWYVUB8PCW.1A4ZSHI3LF3WF@Void
From fcde8e265cbd7012b2983b6b5f9dbe58ba42a739 Mon Sep 17 00:00:00 2001
From: "zero@void" <shinyzero0@gmail.com>
Date: Sun, 13 Aug 2023 01:14:45 +0300
Subject: [PATCH] offpunk: install manpage

---
gnu/packages/web-browsers.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d9f0e9c..915fbb0 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -579,7 +579,12 @@ (define-public offpunk
"/bin")
,(string-append
#$(this-package-input "xdg-utils")
- "/bin")))))))))
+ "/bin"))))))
+ (add-after 'install 'install-manpages
+ (lambda _
+ (let*
+ ((mandir (string-append #$output "/share/man/man1")))
+ (install-file "man/offpunk.1" mandir)))))))
(inputs (list python-cryptography
python-requests
python-feedparser
--
2.41.0
S
S
ShinyZero0 wrote on 16 Aug 2023 00:44
[PATCH] gnu: Add offpunk
(address . 65197@debbugs.gnu.org)
CUTDC97XKRJQ.3J04N714GO0D8@Void
From 60d578dfedaa237fbf1a7dec4902736ca882f75d Mon Sep 17 00:00:00 2001
Message-ID: <60d578dfedaa237fbf1a7dec4902736ca882f75d.1692130093.git.shinyzero0@gmail.com>
From: "zero@void" <shinyzero0@gmail.com>
Date: Tue, 15 Aug 2023 23:06:12 +0300
Subject: [PATCH] gnu: Add offpunk

---
gnu/packages/web-browsers.scm | 63 +++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)

Toggle diff (106 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 4b0e33c..f352c43 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -43,6 +43,7 @@ (define-module (gnu packages web-browsers)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -61,6 +62,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fonts)
+ #:use-module (gnu packages file)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
@@ -72,6 +74,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages less)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -97,6 +100,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg))
(define-public midori
@@ -547,6 +551,65 @@ (define-public qutebrowser
GUI. It is based on PyQt5 and QtWebEngine.")
(license license:gpl3+)))
+(define-public offpunk
+ (package
+ (name "offpunk")
+ (version "1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~lioploum/offpunk")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0r8j01s3hdn3iq4ld6pj3v0h4hpakvkc4h55jzz7jr6az4y8lcgs"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f ; no tests
+ #:phases #~(modify-phases
+ %standard-phases
+ (add-before
+ 'wrap 'wrap-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program
+ (string-append #$output
+ "/bin/offpunk")
+ `("PATH" ":" prefix
+ (,(string-append
+ #$(this-package-input "less")
+ "/bin")
+ ,(string-append
+ #$(this-package-input "file")
+ "/bin")
+ ,(string-append
+ #$(this-package-input "xdg-utils")
+ "/bin"))))))
+ (add-after
+ 'install 'install-manpages
+ (lambda _
+ (let
+ ((mandir
+ (string-append
+ #$output "/share/man/man1")))
+ (install-file "man/offpunk.1" mandir)))))))
+ (inputs (list python-cryptography
+ python-requests
+ python-feedparser
+ python-beautifulsoup4
+ python-readability-lxml
+ python-flit
+ xdg-utils
+ file
+ less))
+ (synopsis
+ "Command-line browser/feed reader for Gemini, Gopher, Spartan and Web")
+ (description
+ "The goal of Offpunk is to be able to synchronise your content once
+ (a day, a week, a month) and then browse/organise it while staying
+ disconnected")
+ (home-page "https://git.sr.ht/~lioploum/offpunk")
+ (license license:bsd-2)))
+
(define-public vimb
(package
(name "vimb")

base-commit: f2943958a224beda05a3d040876df2a7285cd7a2
--
2.41.0
M
M
Maxim Cournoyer wrote on 6 Sep 2023 07:00
Re: bug#65197: add offpunk
(name . ShinyZero0)(address . shinyzero0@tilde.club)(address . 65197@debbugs.gnu.org)
8734zr99qr.fsf@gmail.com
Hi,

This series look good for the most part. It's just missing GNU
ChangeLog style commits message. You can check other commits or read
'info (standards) ChangeLog' from the 'standards' package to get
familiar with it.

Could you send a v2 with the changelog added?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 6 Sep 2023 07:00
control message for bug #65197
(address . control@debbugs.gnu.org)
871qfb99qo.fsf@gmail.com
tags 65197 + moreinfo
quit
S
S
ShinyZero0 wrote on 18 Sep 2023 18:18
Re: bug#65197: add offpunk
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65197@debbugs.gnu.org)
CVM6GC42RINR.3JOBTUQRJT0YT@localhost
Hi, do you mean it should have the capital "A"? I can't see any more
differences to another commit messages. Or maybe i'm looking at the
wrong place?
First time using email for patches :sweat:
S
S
ShinyZero0 wrote on 18 Sep 2023 18:38
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65197@debbugs.gnu.org)
CVM6VW8YO112.1WPRRWX7EVK8@localhost
From 60d578dfedaa237fbf1a7dec4902736ca882f75d Mon Sep 17 00:00:00 2001
Message-ID: <60d578dfedaa237fbf1a7dec4902736ca882f75d.1692130093.git.shinyzero0@gmail.com>
From: "zero@void" <shinyzero0@gmail.com>
Date: Tue, 15 Aug 2023 23:06:12 +0300
Subject: [PATCH] gnu: Add offpunk
* gnu/packages/web-browsers.scm (offpunk): New variable
---
gnu/packages/web-browsers.scm | 63 +++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)

Toggle diff (106 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 4b0e33c..f352c43 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -43,6 +43,7 @@ (define-module (gnu packages web-browsers)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -61,6 +62,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fonts)
+ #:use-module (gnu packages file)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
@@ -72,6 +74,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages less)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -97,6 +100,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg))
(define-public midori
@@ -547,6 +551,65 @@ (define-public qutebrowser
GUI. It is based on PyQt5 and QtWebEngine.")
(license license:gpl3+)))
+(define-public offpunk
+ (package
+ (name "offpunk")
+ (version "1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~lioploum/offpunk")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0r8j01s3hdn3iq4ld6pj3v0h4hpakvkc4h55jzz7jr6az4y8lcgs"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f ; no tests
+ #:phases #~(modify-phases
+ %standard-phases
+ (add-before
+ 'wrap 'wrap-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program
+ (string-append #$output
+ "/bin/offpunk")
+ `("PATH" ":" prefix
+ (,(string-append
+ #$(this-package-input "less")
+ "/bin")
+ ,(string-append
+ #$(this-package-input "file")
+ "/bin")
+ ,(string-append
+ #$(this-package-input "xdg-utils")
+ "/bin"))))))
+ (add-after
+ 'install 'install-manpages
+ (lambda _
+ (let
+ ((mandir
+ (string-append
+ #$output "/share/man/man1")))
+ (install-file "man/offpunk.1" mandir)))))))
+ (inputs (list python-cryptography
+ python-requests
+ python-feedparser
+ python-beautifulsoup4
+ python-readability-lxml
+ python-flit
+ xdg-utils
+ file
+ less))
+ (synopsis
+ "Command-line browser/feed reader for Gemini, Gopher, Spartan and Web")
+ (description
+ "The goal of Offpunk is to be able to synchronise your content once
+ (a day, a week, a month) and then browse/organise it while staying
+ disconnected")
+ (home-page "https://git.sr.ht/~lioploum/offpunk")
+ (license license:bsd-2)))
+
(define-public vimb
(package
(name "vimb")

base-commit: f2943958a224beda05a3d040876df2a7285cd7a2
--
2.41.0
?