[PATCH] gnu: add python-altgraph.

  • Done
  • quality assurance status badge
Details
4 participants
  • Michael Ford
  • Hilton Chain
  • jgart
  • Munyoki Kilyungi
Owner
unassigned
Submitted by
Michael Ford
Severity
normal
M
M
Michael Ford wrote on 10 Aug 2023 10:41
(address . guix-patches@gnu.org)
CAFyhPjXqtAg7_HQft9_M4wUAPovvEdC7ELUOueBrY8ksU86kGQ@mail.gmail.com
From c3a2be87c3f2fc4e39e765444e4e08047998bf8a Mon Sep 17 00:00:00 2001
From: fanquake <fanquake@gmail.com>
Date: Thu, 10 Aug 2023 10:35:02 +0200
Subject: [PATCH] gnu: add python-altgraph.

* gnu/packages/python-xyz.scm (python-altgraph): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b8e8097c7b..8403386277 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11369,6 +11369,28 @@ (define-public python-toposort
algorithm.")
(license license:asl2.0)))

+(define-public python-altgraph
+ (package
+ (name "python-altgraph")
+ (version "0.17.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ronaldoussoren/altgraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n9qw0xxss4sbpys5hh1gbzy0bfjkaf4h8fd27vprnbix6q6zlvp"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ronaldoussoren/altgraph")
+ (synopsis "Python graph (network) package")
+ (description
+ "altgraph is a fork of graphlib: a graph (network) package for
+constructing graphs, BFS and DFS traversals, topological sort, shortest
paths,
+etc. with graphviz output.")
+ (license license:expat)))
+
(define-public python-three-merge
(package
(name "python-three-merge")
--
2.41.0
Attachment: file
H
H
Hilton Chain wrote on 29 Sep 2023 09:30
[PATCH v2] gnu: Add python-altgraph.
(address . 65194@debbugs.gnu.org)
d979250903d2de5f0ce0e2e701db4e7cb09375b7.1695972259.git.hako@ultrarare.space
From: fanquake <fanquake@gmail.com>

* gnu/packages/python-xyz.scm (python-altgraph): New variable.
---

V1 -> V2:
- 0.17.3->0.17.4.
- Adjust description.
- Rebase.

gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3d91480ac..a03bbbd4de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11493,6 +11493,28 @@ (define-public python-toposort
algorithm.")
(license license:asl2.0)))
+(define-public python-altgraph
+ (package
+ (name "python-altgraph")
+ (version "0.17.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ronaldoussoren/altgraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03cingygy7k8cg1l7ffxyrsva1a87y0is14wp04y7zazjab12w87"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ronaldoussoren/altgraph")
+ (synopsis "Python graph (network) package")
+ (description
+ "@code{altgraph} is a graph (network) package for constructing graphs, BFS
+and DFS traversals, topological sort, shortest paths, etc. with graphviz output.
+")
+ (license license:expat)))
+
(define-public python-three-merge
(package
(name "python-three-merge")

base-commit: 1b0ec97bce2db93ec4159a13fb0a184f012df4fe
--
2.41.0
H
H
Hilton Chain wrote on 29 Sep 2023 13:33
[PATCH v3] gnu: Add python-altgraph.
(address . 65194@debbugs.gnu.org)
f4085bd91daf39f762d068f130d7cf8f472a2995.1695987035.git.hako@ultrarare.space
From: fanquake <fanquake@gmail.com>

* gnu/packages/python-xyz.scm (python-altgraph): New variable.
---

V2 -> V3:
- Correct license to expat-0.

V1 -> V2:
- 0.17.3->0.17.4.
- Adjust description.
- Rebase.

gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3d91480ac..ec0283838e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11493,6 +11493,28 @@ (define-public python-toposort
algorithm.")
(license license:asl2.0)))
+(define-public python-altgraph
+ (package
+ (name "python-altgraph")
+ (version "0.17.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ronaldoussoren/altgraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03cingygy7k8cg1l7ffxyrsva1a87y0is14wp04y7zazjab12w87"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ronaldoussoren/altgraph")
+ (synopsis "Python graph (network) package")
+ (description
+ "@code{altgraph} is a graph (network) package for constructing graphs, BFS
+and DFS traversals, topological sort, shortest paths, etc. with graphviz output.
+")
+ (license license:expat-0)))
+
(define-public python-three-merge
(package
(name "python-three-merge")

base-commit: 1b0ec97bce2db93ec4159a13fb0a184f012df4fe
--
2.41.0
J
M
M
Munyoki Kilyungi wrote on 2 Oct 2023 10:14
87sf6t4f0h.fsf@saitama.mail-host-address-is-not-set
"jgart" <jgart@dismail.de> aliandika:

Toggle quote (8 lines)
> Hi Guixers,
>
> Thanks for the patches.
>
> Can you also patch these methods to use our binarie executables in Guix?
>
> https://github.com/ronaldoussoren/altgraph/blob/master/altgraph_tests/test_dot.py#L52
>
I've done a build of python-alt-graph and it
builds just file, tests and all so ...
Toggle quote (5 lines)
> Lars or someone else,
>
> Feel free to let me know if not needed. I'm unsure of when we should and shouldn't for Python libraries sometimes.
>

I doubt we need to patch the tests ase you had
earlier indicated since the tests still pass---I
don't know why though.
Just my 2¢s.

Toggle quote (6 lines)
> Should we document our policy for that in the manual?
>
> all best,
>
> jgart

--
(Life is like a pencil that will surely run out,
but will leave the beautiful writing of life.)
(D4F09EB110177E03C28E2FE1F5BBAE1E0392253F
(hkp://keys.openpgp.org))
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmUae/4WHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlP+1XEACXjeo/vlKCRTOGenHjnxEeB2q9
rY19JxfC6QHQ8Czr1mrkzVcxG/v+WeKk6PGxnW+Trc/GH1IrWFoiDkHXVB4A1qR0
gDc457ArKfIqi4YiBH5r7oQH2wGVBOLvQ2kmHBFexMZ0c5DzzO/954gsKe+P91Jy
4yosbVL8idat5zvsB1xHUJfwqDLfWQwdJSVCC0s3x0QpYMkEptCXtZ0jOvInQHLx
nZXjtTvTKDAtEeVPlBf3fMtAUCsYSqVy4GI+BYO7p6ztPGQ545JE9/vhYH8iwqFx
/uPaB3ccchJ+JjEaHx/D67AcJMjGet3KKc1+d3kRpmi7c7k5gPsVZnhIjYk2akzd
5Kcp8ICwoJbeZMlCuKuluPdNHEiENjXme31VGn8OjMQmTogctZjg94jTCAPVAfma
JUVwLyyDiJa7G/UaqKLKF73BDgur8umtJd1bCl2HoTJ7rae8zfG/Fnz9nevl2iOx
4XbIuIQLvwml74A6UMQDXTZWfII7XJJ/KsBSk7r6bXyvhATvft8/aEqVp2QXoFR5
EePVubv9XGo1ymSNno+c7Wz5D4sni89qrn0BS7WtTKnQPpsGfqvCWZJhwcMycK8t
ipr8QrjPJVDXA7OLkWez32MKWLfL1aUl+QXJ2y501qIRUG6pO7PnfXf3c/T/V7FD
4w5IyYlnPincwwE8zQ==
=3L14
-----END PGP SIGNATURE-----

J
J
jgart wrote on 2 Oct 2023 15:59
7b2b67f04b21ac5747130e0c279d2559@dismail.de
Hi Bonface,

Thanks for reviewing and testing.

Ok,

I also think that this patch is good to go. If someone else thinks we should patch just reply to comment or we can take care of that in a future ticket so as to not block this one.

I'll try to merge this by tonight/tomorrow after I do another review and test.

all best,

jgart
J
J
jgart wrote on 3 Oct 2023 15:32
9c58e95cfd34ae3361495d25893646df@dismail.de
Hi fanquake,

Why not use the PyPi source if it includes the tests?

It is what the importer would have produced:

$ guix import pypi altgraph

Starting download of /tmp/guix-file.mH76On
…17.4.tar.gz 47KiB 835KiB/s 00:00 ???????????????????? 100.0%

Starting download of /tmp/guix-file.j6I6jB
…2.py3-none-any.whl 21KiB 1.8MiB/s 00:00 ???????????????????? 100.0%
(package
(name "python-altgraph")
(version "0.17.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "altgraph" version))
(sha256
(base32 "01j48np3g50g6insjkszsz0vifwlm6gspria5vdwlkbciywznnhv"))))
(build-system pyproject-build-system)
(home-page "https://altgraph.readthedocs.io")
(synopsis "Python graph (network) package")
(description "Python graph (network) package")

all best,

jgart
M
M
Michael Ford wrote on 3 Oct 2023 16:26
(name . jgart)(address . jgart@dismail.de)
CAFyhPjXVWmb4MhqQTHhdjbtCv-SszeK5jw45ef4CBuU4GCxefg@mail.gmail.com
Hi jgart,

I'm happy for this to be changed in whatever way is best for inclusion in
Guix.
The original patch I submitted, came from a manifest in a different
project, where
we have just been using the source, and were not running the tests. If the
PyPi souce
would be a better fit here, that is fine with me.

Thanks,

Michael

On Tue, 3 Oct 2023 at 14:32, jgart <jgart@dismail.de> wrote:

Toggle quote (39 lines)
> Hi fanquake,
>
> Why not use the PyPi source if it includes the tests?
>
> It is what the importer would have produced:
>
> $ guix import pypi altgraph
>
> Starting download of /tmp/guix-file.mH76On
> From
> https://files.pythonhosted.org/packages/de/a8/7145824cf0b9e3c28046520480f207df47e927df83aa9555fb47f8505922/altgraph-0.17.4.tar.gz.
> ..
> …17.4.tar.gz 47KiB 835KiB/s 00:00 ????????????????????
> 100.0%
>
> Starting download of /tmp/guix-file.j6I6jB
> From
> https://files.pythonhosted.org/packages/4d/3f/3bc3f1d83f6e4a7fcb834d3720544ca597590425be5ba9db032b2bf322a2/altgraph-0.17.4-py2.py3-none-any.whl.
> ..
> …2.py3-none-any.whl 21KiB 1.8MiB/s 00:00 ????????????????????
> 100.0%
> (package
> (name "python-altgraph")
> (version "0.17.4")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "altgraph" version))
> (sha256
> (base32 "01j48np3g50g6insjkszsz0vifwlm6gspria5vdwlkbciywznnhv"))))
> (build-system pyproject-build-system)
> (home-page "https://altgraph.readthedocs.io")
> (synopsis "Python graph (network) package")
> (description "Python graph (network) package")
>
> all best,
>
> jgart
>
Attachment: file
J
J
jgart wrote on 3 Oct 2023 18:49
(name . Michael Ford)(address . fanquake@gmail.com)
aab1301a73948339436bf8592977375b@dismail.de
Our usual informal protocol in the past for Python packages has been if the PyPi sources have the tests then we prefer that.

We maybe should formally document the policy to avoid these confusions like this.

Lars or another veteran Guix contributor could you confirm that this is indeed what we should do?

Michael,

Can you send a v4 patch for that?

all best,

jgart
J
J
jgart wrote on 4 Oct 2023 03:51
(name . Michael Ford)(address . fanquake@gmail.com)
4308ae63034f0924960d7ac91a8280cf@dismail.de
Hi Guixers,

I applied the patch with some small changes in 0c6198319a.

I fixed up the description and synopsis a bit and added python-pytest as a native-input since the pyproject-build-system does not include it so test wouldn't be run otherwise.

Thanks for your contributions and review to everyone involved. It is much appreciated!

all best,

jgart
Closed
M
M
Munyoki Kilyungi wrote on 4 Oct 2023 12:04
87il7mg0uk.fsf@saitama.mail-host-address-is-not-set
"jgart" <jgart@dismail.de> aliandika:

Toggle quote (6 lines)
> Hi Guixers,
>
> I applied the patch with some small changes in 0c6198319a.
>
> I fixed up the description and synopsis a bit and added python-pytest as a native-input since the pyproject-build-system does not include it so test wouldn't be run otherwise.
>
Nice! Thanks for the effort +1


--
(Life is like a pencil that will surely run out,
but will leave the beautiful writing of life.)
(D4F09EB110177E03C28E2FE1F5BBAE1E0392253F
(hkp://keys.openpgp.org))
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmUdOLMWHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlPzK3EACg3W00rR2YI9Oo2kCAimMm17We
NSjCi8khT/FVrQ/RaGxNJxDsMOpQRJeipIAkySrAQ0RTChhmOojmfpllKKmL01qr
+370dB8rRpnW633T7P78rcLYutTbQp30B3z/eBdWpkcX+H5ZsoetrYz0QIjSdG+o
fawSB45AXPSZUwHcwRCUx9yO+cJ4Ml3gGzTAM5T4H4jvdXJ4woQuECfN49YlQc3g
G07JxQGrOvZvWr8Mssa0u5nlcbTr8iApaNKiyryFEX7h3BEQYO57t21KQz13dH81
jP7Emu84Xrv02cpl28+39G96906Zm9FLgPENPTLMQSGSBEDjmio9kJHUcJNVbXcE
anrneu8lSL/6hLknCh3X2+IG2byLE5Z+nQyG9pmHwbMMZIRP4ajhCkPg8gNu5heG
UpS5fz+uxfuSbqRdIn6SorawuMYo661l3z9PtHSEXs7gLA+GAbOyU61fuyaferPx
144WrJBjAOGFwE5vSJEbpzPNLFWJ1gr2YaVDLeqLogA76CpdX8wQHOYTfRbJhKaE
g1ceKs/2G2gPFLgRjcVPJ6nvxAtympVIAuNKwoTfDelNzseomdBrqtfx0YMdZGO2
t7LQWMUb1cYCDT6SfoS6tFfOcPmOhy9F8xOyChczfVxU/E3ACgEXhDxD13iAia3o
WqtFqXt1AWLtyyYUmA==
=eq/H
-----END PGP SIGNATURE-----

Closed
?