[PATCH] gnu: uwufetch: Add and use missing inputs.

  • Done
  • quality assurance status badge
Details
One participant
  • Juliana Sims
Owner
unassigned
Submitted by
Juliana Sims
Severity
normal
J
J
Juliana Sims wrote on 10 Aug 2023 03:20
(address . guix-patches@gnu.org)
1b44a2db770f4f2a956c2235ea9cba3f0d1383a9.1691630423.git.juli@incana.org
Hi Ludovic,

Putting the fully-qualified paths of binaries into the source like this had not
occurred to me before, but it seems so obviously correct now. Thanks for
suggesting it! This patch uses that technique; I'll be adding it to my bag of
packaging tricks for the future as well :)

Thanks,
Juli

* gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
[phases]: Use the fully-qualified paths of the input gawk and grep.
---
gnu/packages/admin.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 33f9b703a7..6b6b05c4a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4025,6 +4025,11 @@ (define-public uwufetch
(delete 'configure)
(add-before 'build 'patch-source-paths
(lambda _
+ (substitute* "fetch.c"
+ (("grep")
+ #$(file-append grep "/bin/grep"))
+ (("awk")
+ #$(file-append gawk "/bin/awk")))
(substitute* "uwufetch.c"
(("(/usr(/local)?)(.*;)" all _ _ rest)
(string-append #$output rest)))))
@@ -4033,6 +4038,8 @@ (define-public uwufetch
(lambda _
(mkdir-p (string-append #$output "/include")))))))
(inputs (list lshw
+ gawk
+ grep
;; viu XXX not yet packaged in Guix
xwininfo))
(home-page "https://github.com/TheDarkBug/uwufetch")

base-commit: 90e34d25d5e7c14b7f3293a78f3cdad676c0d035
--
2.41.0
J
J
Juliana Sims wrote on 10 Aug 2023 04:34
oops, emailed this wrong
(address . 65189-done@debbugs.gnu.org)
RTL5ZR.VZ59TV4GLEDW1@incana.org
i done did a bad and sent the email wrong :(
Closed
?