[PATCH] gnu: Add dnstracer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 9 Aug 2023 02:50
058ba2de1899a9e1bc45a022725675aa3dee91e0.1691542243.git.maxim.cournoyer@gmail.com
* gnu/packages/networking.scm (dnstracer): New variable.
---
gnu/packages/networking.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 542e93891c..2088f9108f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4617,6 +4617,42 @@ (define-public vnstat
of system resources regardless of network traffic rate.")
(license license:gpl2+)))
+(define-public dnstracer
+ (package
+ (name "dnstracer")
+ (version "1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mavetju.org/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "089bmrjnmsga2n0r4xgw4bwbf41xdqsnmabjxhw8lngg2pns1kb4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\{PREFIX}/man")
+ "${PREFIX}/share/man")
+ (("^install:.*" all)
+ (string-append
+ all
+ "\tinstall -d ${BINPREFIX}\n"
+ "\tinstall -d ${MANPREFIX}\n")))))
+ (delete 'configure))))
+ (native-inputs (list perl)) ;for pod2man
+ (home-page "http://www.mavetju.org/unix/dnstracer.php")
+ (synopsis "Trace a chain of DNS servers to the source")
+ (description "@command{dnstracer} determines where a given Domain Name
+Server (DNS) gets its information from, and follows the chain of DNS servers
+back to the servers which know the data.")
+ (license license:bsd-2)))
+
(define-public dropwatch
(package
(name "dropwatch")

base-commit: 782ef67a59f4b564f16101cf23c30a3777b3f734
--
2.41.0
L
L
Ludovic Courtès wrote on 12 Aug 2023 23:04
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65163@debbugs.gnu.org)
87pm3sc6qa.fsf@gnu.org
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/networking.scm (dnstracer): New variable.

Hi, LGTM!

Ludo’.
M
M
Maxim Cournoyer wrote on 15 Aug 2023 15:52
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 65163-done@debbugs.gnu.org)
87sf8kjtu4.fsf@gmail.com
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> * gnu/packages/networking.scm (dnstracer): New variable.
>
> Hi, LGTM!
>
> Ludo’.

Installed, thank you!

--
Thanks,
Maxim
Closed
?