[PATCH] gnu: exiv2: Get rid of reference to GCC.

  • Done
  • quality assurance status badge
Details
3 participants
  • iyzsong
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 7 Aug 2023 16:03
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
3eba9a4c0ca80fa57106cd50ba827915b9bd91a0.1691416969.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>


* gnu/packages/image.scm (exiv2)[arguments]: Add phase to
remove _GLIBCXX_ASSERTIONS from compiler flags.
---
gnu/packages/image.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3336e38852..1dbf3cbdd6 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1511,6 +1511,12 @@ (define-public exiv2
"-DEXIV2_ENABLE_BMFF=ON")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-gcc-reference
+ (lambda _
+ ;; _GLIBCXX_ASSERTIONS brings reference to GCC.
+ (substitute* "cmake/compilerFlags.cmake"
+ (("add_compile_options[(]-Wp,-D_GLIBCXX_ASSERTIONS[)]")
+ ""))))
(add-after 'install 'delete-static-libraries
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))

base-commit: 56667ee55cd7f3368cbff169352fe440f4f93da5
--
2.41.0
L
L
Ludovic Courtès wrote on 16 Aug 2023 20:07
(address . iyzsong@envs.net)
875y5e6etl.fsf@gnu.org
Hi!

iyzsong@envs.net skribis:

Toggle quote (4 lines)
> From: ??? <iyzsong@member.fsf.org>
>
> This fixes <https://issues.guix.gnu.org/57677>.

s/This fixes/Fixes/, for consistency.

Toggle quote (7 lines)
> + (add-after 'unpack 'patch-gcc-reference
> + (lambda _
> + ;; _GLIBCXX_ASSERTIONS brings reference to GCC.
> + (substitute* "cmake/compilerFlags.cmake"
> + (("add_compile_options[(]-Wp,-D_GLIBCXX_ASSERTIONS[)]")
> + ""))))

Well done! According to
‘_GLIBCXX_ASSERTIONS’ enables various run-time checks; I guess disabling
it is acceptable.

So… LGTM!

Thanks,
Ludo’.
L
?
(name . Ludovic Courtès)(address . ludo@gnu.org)
87jztqcfcf.fsf_-_@envs.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (2 lines)
> Well, wait for https://qa.guix.gnu.org/issue/65126 to be done.

Hello, I think CI is stucking here.

Builds for new patch series suspended as master branch substitute
availability is low for: i686-linux
In this case should I first fix broken builds for i686-linux?

Also will CI able to automatically rebase the patch upon latest master?
If the patch was built with old base, it won't have substitutes after
merge even it's green.
C
C
Christopher Baines wrote on 20 Aug 2023 20:27
(name . ???)(address . iyzsong@envs.net)
87v8d9wo91.fsf@cbaines.net
??? <iyzsong@envs.net> writes:

Toggle quote (6 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done.
>
> Hello, I think CI is stucking here.

I'm going to answer replacing CI with qa.guix.gnu.org, as I think that
makes the questions make more sense.

Toggle quote (5 lines)
> Builds for new patch series suspended as master branch substitute
> availability is low for: i686-linux
> In this case should I first fix broken builds for i686-linux?

I think substitute availability is below 80% for i686-linux because the
bordeaux build farm is still catching up. There's a shepherd issue on
milano-guix-1, so that's reduced the resources available for
x86_64-linux and i686-linux builds.

QA waits until substitute availability is good before submitting builds
as that avoids submitting builds when they probably won't happen for a
while, given the bordeaux build farm will be busy with the master branch
builds instead.

Ideally more changes would be processed by QA and built fully before
being merged, so that substitutes are available when they're merged.

Toggle quote (4 lines)
> Also will CI able to automatically rebase the patch upon latest master?
> If the patch was built with old base, it won't have substitutes after
> merge even it's green.

The qa-frontpage does automatically rebase patches, although there's
probably a lot of room for improvement to better detect when a patch
series could do with rebasing.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTiXjpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdlbBAAr7Qqcq+qpO+fIWlX7+qkhcJgZsg8zfq7
gPWwl36KpQYr1pon3DqSEqwp+GQPHL8AyEp9uycOunf4pmlHq9xm3QkwikTkb5FQ
QU0badhRAVvf2syHPD5/kL5jb1wBzwbX16q0DrLVhdaYj2sp/kblC5SjrGuNlSHG
vy0QvqoE1+5B76UH14igVE1N+4m/tgIQQkgU/Ms1GNiD6pM3ObiWWzGcavwDJDN+
mBDnGKbHQUwMrGMZTfldJ/jC32e68JZdQvA04rO6B5Bz50Cf8OHuTPOIgOPZvDfH
KG9YEv61AbMrTXDl6CSJkoFRhmDh4ic89V0+Sit0/CSNB2m03WLDFF7U3utWcHOL
yXoNuM/U/7Lkuzd3tZsBaie2pN2xnRbeT+n+743/0OKyMg5YuS+C3fPtaW73Inua
L/vxgM3mZFftan+Job1yf0sqakgyDr+OHXAaD2pWo1embd5ATqvHaYZXm/dUsPMQ
uBOILr5J2YFBq2iLwNA9CN1mwdVtCOl98gA9GnYBmOtDFT5LfZ7Kp+XHuorR+p4k
nLn2WbEyxsz8NQSJL5gfZCHkZhid+FaBOC0Qw9Zlvc5do7GQYXN1fJwQcM7q+GqC
ARu8M96ZcOFfy6UAYhmadWUBGu/sUS/0pD+neYn23g8v+ZSc/dp0EKaFfunaLkkE
DJEQDHESBlY=
=LclU
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 19 Oct 2023 21:58
Re: [bug#65126] [PATCH] gnu: exiv2: Get rid of reference to GCC.
(address . iyzsong@envs.net)
87o7guz8nx.fsf@gnu.org
Hi ???,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (6 lines)
> Ludovic Courtès <ludo@gnu.org> skribis:
>
>> So… LGTM!
>
> Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done.

Looks like it’s all green now, go ahead! :-)

Ludo’.
?
(name . Ludovic Courtès)(address . ludo@gnu.org)
87y1fx8vik.fsf@envs.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Hi ???,
>
> Ludovic Courtès <ludo@gnu.org> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> skribis:
>>
>>> So… LGTM!
>>
>> Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done.
>
> Looks like it’s all green now, go ahead! :-)

Pushed now, thanks!
Closed
?