[PATCH] services: syncthing: Use the new command line syntax.

  • Done
  • quality assurance status badge
Details
2 participants
  • Justin Veilleux
  • Ludovic Courtès
Owner
unassigned
Submitted by
Justin Veilleux
Severity
normal
J
J
Justin Veilleux wrote on 6 Aug 2023 01:22
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
YQBPR0101MB515126FA0A061DDEDFFC811C820EA@YQBPR0101MB5151.CANPRD01.PROD.OUTLOOK.COM
Syncthing updated its command line interface to use --flag instead of -flag.
Attachment: file
From 07f90bb908b173f726309d8256f061a6fdad4710 Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Thu, 13 Jul 2023 16:16:51 -0400
Subject: [PATCH] services: syncthing: Use the new command line syntax.

* gnu/services/syncthing.scm (syncthing-shepherd-service): Use the new command line syntax.
---
gnu/services/syncthing.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/services/syncthing.scm b/gnu/services/syncthing.scm
index 7c3d5b027d..c1a0cdd81f 100644
--- a/gnu/services/syncthing.scm
+++ b/gnu/services/syncthing.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2023 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,9 +61,9 @@ (define syncthing-shepherd-service
(requirement '(loopback))
(start #~(make-forkexec-constructor
(append (list (string-append #$syncthing "/bin/syncthing")
- "-no-browser"
- "-no-restart"
- (string-append "-logflags=" (number->string #$logflags)))
+ "--no-browser"
+ "--no-restart"
+ (string-append "--logflags=" (number->string #$logflags)))
'#$arguments)
#:user #$user
#:group #$group
--
2.39.2
J
J
Justin Veilleux wrote on 8 Aug 2023 16:42
(name . 65109@debbugs.gnu.org)(address . 65109@debbugs.gnu.org)
YQBPR0101MB51512AB5FE2E40D7201032E2820DA@YQBPR0101MB5151.CANPRD01.PROD.OUTLOOK.COM
Please note that syncthing-service-type is currently broken because of this.
Attachment: file
L
L
Ludovic Courtès wrote on 11 Aug 2023 00:50
(name . Justin Veilleux)(address . justin.veilleux@umontreal.ca)(address . 65109-done@debbugs.gnu.org)
874jl6ikb0.fsf@gnu.org
Hi,

Justin Veilleux <justin.veilleux@umontreal.ca> skribis:

Toggle quote (7 lines)
> From 07f90bb908b173f726309d8256f061a6fdad4710 Mon Sep 17 00:00:00 2001
> From: terramorpha <terramorpha@cock.li>
> Date: Thu, 13 Jul 2023 16:16:51 -0400
> Subject: [PATCH] services: syncthing: Use the new command line syntax.
>
> * gnu/services/syncthing.scm (syncthing-shepherd-service): Use the new command line syntax.

Applied, thanks!

Ludo’.
Closed
?