[PATCH] gnu: emacs-helpful: Update to 0.21.

  • Done
  • quality assurance status badge
Details
2 participants
  • Cayetano Santos
  • Hilton Chain
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 5 Aug 2023 12:40
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
ca7eedd4d35ff5e18e38f4fba090c704d5c167f0.1691232008.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
---
gnu/packages/emacs-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3d89d51f..c01192b7b3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24360,11 +24360,11 @@ (define-public emacs-download-region
(license license:gpl3+))))
(define-public emacs-helpful
- (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
- (revision "1"))
+ (let ((commit "ced07fe0d48ce1111d7a8376fdbfef34d927c967")
+ (revision "0"))
(package
(name "emacs-helpful")
- (version (git-version "0.19" revision commit))
+ (version (git-version "0.21" revision commit))
(source
(origin
(method git-fetch)
@@ -24373,7 +24373,7 @@ (define-public emacs-helpful
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
+ (base32 "03afgdbs5nmhw833svrqky7fmfs1zlvqzcj7j5g29sakivs60xqc"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-dash emacs-elisp-refs emacs-f emacs-s))

base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
--
2.41.0
H
H
Hilton Chain wrote on 5 Aug 2023 13:22
(name . Cayetano Santos)(address . csantosb@inventati.org)(address . 65088@debbugs.gnu.org)
87fs4xivio.wl-hako@ultrarare.space
Hi Cayetano,

On Sat, 05 Aug 2023 18:40:08 +0800,
Cayetano Santos via Guix-patches via wrote:
Toggle quote (28 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
> ---
> gnu/packages/emacs-xyz.scm | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index ed3d89d51f..c01192b7b3 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -24360,11 +24360,11 @@ (define-public emacs-download-region
> (license license:gpl3+))))
>
> (define-public emacs-helpful
> - (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
> - (revision "1"))
> + (let ((commit "ced07fe0d48ce1111d7a8376fdbfef34d927c967")
> + (revision "0"))
> (package
> (name "emacs-helpful")
> - (version (git-version "0.19" revision commit))
> + (version (git-version "0.21" revision commit))
> (source
> (origin
> (method git-fetch)
> @@ -24373,7 +24373,7 @@ (define-public emacs-helpful
> (commit commit)))

Since it's a tagged release, we can remove the `let' form, use only
"0.21" for version, and `version' for commit.

Thanks
C
C
Cayetano Santos wrote on 5 Aug 2023 19:25
[PATCH v1] gnu: emacs-helpful: Update to 0.21.
(address . 65088@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
d5d20ad0b3e3a453cd206944ec4d03f7cb6c3555.1691256357.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
---
gnu/packages/emacs-xyz.scm | 48 ++++++++++++++++++--------------------
1 file changed, 23 insertions(+), 25 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3d89d51f..9ecc58d7d6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24360,31 +24360,29 @@ (define-public emacs-download-region
(license license:gpl3+))))
(define-public emacs-helpful
- (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
- (revision "1"))
- (package
- (name "emacs-helpful")
- (version (git-version "0.19" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Wilfred/helpful")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
- (home-page "https://github.com/Wilfred/helpful")
- (synopsis "More contextual information in Emacs help")
- (description "@code{helpful} is an alternative to the built-in Emacs help
+ (package
+ (name "emacs-helpful")
+ (version "0.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/helpful")
+ (commit "0.21")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03afgdbs5nmhw833svrqky7fmfs1zlvqzcj7j5g29sakivs60xqc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")))
+ (home-page "https://github.com/Wilfred/helpful")
+ (synopsis "More contextual information in Emacs help")
+ (description "@code{helpful} is an alternative to the built-in Emacs help
that provides much more contextual information.
@itemize

base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
--
2.41.0
H
H
Hilton Chain wrote on 7 Aug 2023 13:42
(name . Cayetano Santos)(address . csantosb@inventati.org)(address . 65088@debbugs.gnu.org)
877cq7f59f.wl-hako@ultrarare.space
Hi Cayetano,

On Sun, 06 Aug 2023 01:25:57 +0800,
Cayetano Santos via Guix-patches via wrote:
Toggle quote (50 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
> ---
> gnu/packages/emacs-xyz.scm | 48 ++++++++++++++++++--------------------
> 1 file changed, 23 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index ed3d89d51f..9ecc58d7d6 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -24360,31 +24360,29 @@ (define-public emacs-download-region
> (license license:gpl3+))))
>
> (define-public emacs-helpful
> - (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
> - (revision "1"))
> - (package
> - (name "emacs-helpful")
> - (version (git-version "0.19" revision commit))
> - (source
> - (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/Wilfred/helpful")
> - (commit commit)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
> - (build-system emacs-build-system)
> - (propagated-inputs
> - (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
> - (native-inputs
> - (list emacs-ert-runner emacs-undercover))
> - (arguments
> - `(#:tests? #t
> - #:test-command '("ert-runner")))
> - (home-page "https://github.com/Wilfred/helpful")
> - (synopsis "More contextual information in Emacs help")
> - (description "@code{helpful} is an alternative to the built-in Emacs help
> + (package
> + (name "emacs-helpful")
> + (version "0.21")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/Wilfred/helpful")
> + (commit "0.21")))


The version specified in the `version' field is available as a
variable, so `(commit version)' can be used instead.


Toggle quote (23 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "03afgdbs5nmhw833svrqky7fmfs1zlvqzcj7j5g29sakivs60xqc"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
> + (native-inputs
> + (list emacs-ert-runner emacs-undercover))
> + (arguments
> + `(#:tests? #t
> + #:test-command '("ert-runner")))
> + (home-page "https://github.com/Wilfred/helpful")
> + (synopsis "More contextual information in Emacs help")
> + (description "@code{helpful} is an alternative to the built-in Emacs help
> that provides much more contextual information.
>
> @itemize
>
> base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
> --
> 2.41.0


There's an extra parenthesis to remove ;)
Toggle snippet (4 lines)
- (license license:gpl3+))))
+ (license license:gpl3+)))

Thanks
C
C
Cayetano Santos wrote on 7 Aug 2023 14:11
[PATCH v2] gnu: emacs-helpful: Update to 0.21.
(address . 65088@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
656bcc189b3a9279d6906e1e29ccc7ef3e52739a.1691410263.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
---
gnu/packages/emacs-xyz.scm | 50 ++++++++++++++++++--------------------
1 file changed, 24 insertions(+), 26 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3d89d51f..d03a9a91f4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24360,31 +24360,29 @@ (define-public emacs-download-region
(license license:gpl3+))))
(define-public emacs-helpful
- (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
- (revision "1"))
- (package
- (name "emacs-helpful")
- (version (git-version "0.19" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Wilfred/helpful")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
- (home-page "https://github.com/Wilfred/helpful")
- (synopsis "More contextual information in Emacs help")
- (description "@code{helpful} is an alternative to the built-in Emacs help
+ (package
+ (name "emacs-helpful")
+ (version "0.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/helpful")
+ (commit "0.21")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03afgdbs5nmhw833svrqky7fmfs1zlvqzcj7j5g29sakivs60xqc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")))
+ (home-page "https://github.com/Wilfred/helpful")
+ (synopsis "More contextual information in Emacs help")
+ (description "@code{helpful} is an alternative to the built-in Emacs help
that provides much more contextual information.
@itemize
@@ -24403,7 +24401,7 @@ (define-public emacs-helpful
@item Trace, disassemble functions from inside Helpful. This is discoverable
and doesn't require memorisation of commands.
@end itemize\n")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-logview
(package

base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
--
2.41.0
H
H
Hilton Chain wrote on 27 Aug 2023 05:51
Re: [bug#65088] [PATCH] gnu: emacs-helpful: Update to 0.21.
(name . Cayetano Santos)(address . csantosb@inventati.org)(address . 65088-done@debbugs.gnu.org)
875y515eio.wl-hako@ultrarare.space
Hi Cayetano,

On Sat, 05 Aug 2023 18:40:08 +0800,
Cayetano Santos via Guix-patches via wrote:
Toggle quote (4 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
> ---

I have applied v2 as 5476f79e41c843a7ee43f6fcf64039f527b9f21e, with
(commit "0.21") changed to (commit version). Thanks!
Closed
?