[PATCH] gnu: emacs-mastodon: Update to 1.0.0-1.20dec88.

  • Done
  • quality assurance status badge
Details
3 participants
  • Cayetano Santos
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 30 Jul 2023 19:51
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
f1088c0e21260d70fecd0a1d1afc7bfcebc895bf.1690739463.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.
---
gnu/packages/emacs-xyz.scm | 60 ++++++++++++++++++++------------------
1 file changed, 31 insertions(+), 29 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e8d1ac6034..0bd4ff93bc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32420,35 +32420,37 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- (package
- (name "emacs-mastodon")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13swcbvwhjl8ksrgzvmfafkgd3iz8znk49bs1n48w3g9qvh097w7"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
+ (revision "1"))
+ (package
+ (name "emacs-mastodon")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (propagated-inputs
+ (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
(license license:gpl3+)))

base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
--
2.41.0
L
L
Ludovic Courtès wrote on 20 Aug 2023 23:20
(name . Cayetano Santos)(address . csantosb@inventati.org)(address . 64961@debbugs.gnu.org)
87lee5pg0b.fsf@gnu.org
Hi Cayetano,

Cayetano Santos <csantosb@inventati.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.

[...]

Toggle quote (6 lines)
> + (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
> + (revision "1"))
> + (package
> + (name "emacs-mastodon")
> + (version (git-version "1.0.0" revision commit))

Normally we only package releases, unless there’s a good reason to grab
a snapshot, in which case there should be a comment explaining it.

What’s the situation here?

Toggle quote (5 lines)
> + (synopsis "Emacs client for Mastodon")
> + (description "@code{mastodon.el} is an Emacs client for Mastodon, the
> federated microblogging social network.")
> (license license:gpl3+)))

There’s a missing paren here, which made qa.guix unhappy:


:-)

Thanks,
Ludo’.
C
C
Cayetano Santos wrote on 21 Aug 2023 09:46
[PATCH v1] gnu: emacs-mastodon: Update to 1.0.0-1.20dec88.
(address . 64961@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
755f5aa4c50601e6f94c3c6f0156228bdd82b3fe.1692603994.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.
---
gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++++------------------
1 file changed, 32 insertions(+), 30 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e8d1ac6034..192f697efb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32420,37 +32420,39 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- (package
- (name "emacs-mastodon")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13swcbvwhjl8ksrgzvmfafkgd3iz8znk49bs1n48w3g9qvh097w7"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
+ (revision "1"))
+ (package
+ (name "emacs-mastodon")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (propagated-inputs
+ (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-ebdb
(package

base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
--
2.41.0
C
C
Cayetano Santos wrote on 21 Aug 2023 10:01
Re: bug#64961: [PATCH] gnu: emacs-mastodon: Update to 1.0.0-1.20dec88.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64961@debbugs.gnu.org)
874jks7r4m.fsf@inventati.org
Toggle quote (21 lines)
>dim. 20 août 2023 at 23:20, Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Cayetano,
>
> Cayetano Santos <csantosb@inventati.org> skribis:
>
>> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.
>
> [...]
>
>> + (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
>> + (revision "1"))
>> + (package
>> + (name "emacs-mastodon")
>> + (version (git-version "1.0.0" revision commit))
>
> Normally we only package releases, unless there’s a good reason to grab
> a snapshot, in which case there should be a comment explaining it.
>
> What’s the situation here?

Nothing special here, other than the fact that latest stable is from
more than one year ago.

In my opinion, we should debate this question once for ever in a broader
discussion about emacs packages (guix-devel?): what do we package ?
only stables (obsolete packages, see emacs-org-ref) ? always master (we
run after latest commit) ? something in between (current situation) ?

As for now, it is stated that we privilege releases ... except that
emacs-xyz is full of snapshots, and for a good reason (case of magit,
etc.), probably due to releases being too old (author just forgets
releasing).

(By the way. Similar debate comes to using melpa or melpa-stable)

What do you think ?

Cayetano
C
C
Christopher Baines wrote on 27 Aug 2023 20:07
tag 64961 moreinfo
(address . control@debbugs.gnu.org)
87o7iss6io.fsf@cbaines.net
tags 64961 + moreinfo
quit
L
L
Ludovic Courtès wrote on 11 Sep 2023 23:54
Re: bug#64961: [PATCH] gnu: emacs-mastodon: Update to 1.0.0-1.20dec88.
(name . Cayetano Santos)(address . csantosb@inventati.org)(address . 64961@debbugs.gnu.org)
87msxspe9t.fsf_-_@gnu.org
Hi Cayetano,

Cayetano Santos <csantosb@inventati.org> skribis:

Toggle quote (24 lines)
>>dim. 20 août 2023 at 23:20, Ludovic Courtès <ludo@gnu.org> wrote:
>
>> Hi Cayetano,
>>
>> Cayetano Santos <csantosb@inventati.org> skribis:
>>
>>> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.
>>
>> [...]
>>
>>> + (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
>>> + (revision "1"))
>>> + (package
>>> + (name "emacs-mastodon")
>>> + (version (git-version "1.0.0" revision commit))
>>
>> Normally we only package releases, unless there’s a good reason to grab
>> a snapshot, in which case there should be a comment explaining it.
>>
>> What’s the situation here?
>
> Nothing special here, other than the fact that latest stable is from
> more than one year ago.

OK. I went ahead and applied the patch (there’s not a lot at stake in
this case anyway).

Toggle quote (5 lines)
> In my opinion, we should debate this question once for ever in a broader
> discussion about emacs packages (guix-devel?): what do we package ?
> only stables (obsolete packages, see emacs-org-ref) ? always master (we
> run after latest commit) ? something in between (current situation) ?

The question’s not really up for debate in that the policy is to choose
releases, unless there’s a good reason not to do so. But…

Toggle quote (5 lines)
> As for now, it is stated that we privilege releases ... except that
> emacs-xyz is full of snapshots, and for a good reason (case of magit,
> etc.), probably due to releases being too old (author just forgets
> releasing).

… you’re right of course. The situation of Emacs packages is a bit
special I guess, and it would be worth clarifying that somehow. Please
feel free to launch the discussion on guix-devel!

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 11 Sep 2023 23:54
control message for bug #64961
(address . control@debbugs.gnu.org)
87ledcpe9m.fsf@gnu.org
close 64961
quit
?