[PATCH] gnu: Add font-powerline.

  • Open
  • quality assurance status badge
Details
One participant
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Sergio Pastor Pérez
Severity
normal
S
S
Sergio Pastor Pérez wrote on 30 Jul 2023 16:58
(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB2132C6A488A0933C3780E70BF304A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/fonts.scm (font-powerline): New variable.
---
gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 25659ab8d6..6dadfc853d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3457,3 +3457,26 @@ (define-public font-open-fonts
(description
"This package provides open source fonts with a variety of styles which include Sans Serif, Serif and Monospeced fonts.")
(license license:expat)))
+
+(define-public font-powerline
+ (package
+ (name "font-powerline")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/powerline/fonts")
+ (commit "e80e3eba9091dac0655a0a77472e10f53e754bb0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n8yhc8y1vpiyza58d4fj5lyf03ncymrxc81a31crlbzlqvwwrqq"))))
+ (build-system font-build-system)
+ (home-page
+ "https://powerline.readthedocs.io/en/latest/installation/linux.html#fonts-installation")
+ (synopsis "Powerline fonts")
+ (description
+ "This package provides a collection of patched fonts for Powerline users.")
+ (license (list license:silofl1.1 license:asl2.0 license:expat
+ license:bsd-3
+ (license:x11-style "http://dejavu-fonts.org/")))))

base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
prerequisite-patch-id: 92a3fab6e4174a4d4877fc5b426752df81e4df39
--
2.39.2
?