[PATCH] gnu: Add dexy-color-sddm-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Sergio Pastor Pérez
Severity
normal
S
S
Sergio Pastor Pérez wrote on 29 Jul 2023 15:02
(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB2132603FFB6D8546B11120E0F307A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.
---
gnu/packages/display-managers.scm | 35 +++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index f6c9283a29..dcfa3bcf3f 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -142,6 +142,41 @@ (define-public sddm
;; QML files are MIT licensed and images are CC BY 3.0.
(license (list license:gpl2+ license:expat license:cc-by3.0))))
+(define-public dexy-color-sddm-theme
+ (let ((commit "7929384dbb9305e6da53a8942bca3d75593fd99f")
+ (revision "0"))
+ (package
+ (name "dexy-color-sddm-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/L4ki/Dexy-Plasma-Themes")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dcp3pvs6x63740sz852yr19fjrdnh81dbrq7rssgm6ssi1rqjig"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (sddm-themes (string-append out
+ "/share/sddm/themes")))
+ (mkdir-p sddm-themes)
+ (copy-recursively (string-append (assoc-ref
+ %build-inputs
+ "source")
+ "/Dexy-Color-SDDM")
+ (string-append sddm-themes
+ "/dexy-color"))))))
+ (home-page "https://github.com/L4ki/Dexy-Plasma-Themes")
+ (synopsis "Dexy Color theme for SDDM")
+ (description "Dexy-Color-SDDM is part of KDE Themes and Extensions.")
+ (license license:gpl3+))))
+
(define-public guix-simplyblack-sddm-theme
(package
(name "guix-simplyblack-sddm-theme")

base-commit: e43cbeafd1b632f39b08b3644af5230d5350a656
--
2.39.2
L
L
Ludovic Courtès wrote on 17 Sep 2023 15:13
(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)(address . 64933@debbugs.gnu.org)
87edixx7ql.fsf@gnu.org
Hi,

And apologies for the late reply.

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

Toggle quote (2 lines)
> * gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.

[...]

Toggle quote (16 lines)
> + (build-system trivial-build-system)
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder (begin
> + (use-modules (guix build utils))
> + (let* ((out (assoc-ref %outputs "out"))
> + (sddm-themes (string-append out
> + "/share/sddm/themes")))
> + (mkdir-p sddm-themes)
> + (copy-recursively (string-append (assoc-ref
> + %build-inputs
> + "source")
> + "/Dexy-Color-SDDM")
> + (string-append sddm-themes
> + "/dexy-color"))))))

Could you consider writing it using ‘copy-build-system’? It should lead
to a more concise definition.

Toggle quote (4 lines)
> + (synopsis "Dexy Color theme for SDDM")
> + (description "Dexy-Color-SDDM is part of KDE Themes and Extensions.")

It would be great if you could add a sentence saying what the package
provides (think about someone running ‘guix search’ and not knowing
which package might provide the thing).

Could you send an updated patch?

Thanks in advance,
Ludo’.
S
S
Sergio Pastor Pérez wrote on 20 Sep 2023 23:27
[PATCH v2] gnu: Add dexy-color-sddm-theme.
(address . ludo@gnu.org)
DU2P193MB2132BC650D1C8D1BF6855463F3F9A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.
---
gnu/packages/display-managers.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 327a29aa9e..ef9826c0f7 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -142,6 +142,32 @@ (define-public sddm
;; QML files are MIT licensed and images are CC BY 3.0.
(license (list license:gpl2+ license:expat license:cc-by3.0))))
+(define-public dexy-color-sddm-theme
+ (let ((commit "7929384dbb9305e6da53a8942bca3d75593fd99f")
+ (revision "0"))
+ (package
+ (name "dexy-color-sddm-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/L4ki/Dexy-Plasma-Themes")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dcp3pvs6x63740sz852yr19fjrdnh81dbrq7rssgm6ssi1rqjig"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("Dexy-Color-SDDM"
+ "/share/sddm/themes/dexy-color-sddm"))))
+ (home-page "https://github.com/L4ki/Dexy-Plasma-Themes")
+ (synopsis "Dexy Color theme for SDDM")
+ (description
+ "This package provides a minimalistic and modern SDDM theme with blured
+background.")
+ (license license:gpl3+))))
+
(define-public guix-simplyblack-sddm-theme
(package
(name "guix-simplyblack-sddm-theme")

base-commit: 4bdb8bd2674c2b630626be43a5cd3c2b65401b52
--
2.41.0
L
L
Ludovic Courtès wrote on 14 Oct 2023 17:32
(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)(address . 64933-done@debbugs.gnu.org)
87pm1hfcd1.fsf@gnu.org
Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

Toggle quote (2 lines)
> * gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.

Applied, thanks!
Closed
?