[PATCH 0/3] gnu: docker: Update to 20.10.25.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Christopher Baines
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 28 Jul 2023 05:11
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1690513710.git.hako@ultrarare.space
Hello Guix!

This patchset updates docker & docker-cil to 20.10.25, runc to latest version,
and containerd to latest 1.6 version.

It's only a patch version update and I haven't looked into the major version
update.

Thanks

Hilton Chain (3):
gnu: runc: Update to 1.1.8.
gnu: containerd: Update to 1.6.22.
gnu: docker: Update to 20.10.25.

gnu/packages/docker.scm | 18 +++++++++---------
gnu/packages/virtualization.scm | 4 ++--
2 files changed, 11 insertions(+), 11 deletions(-)


base-commit: 35c8d631d2bd63c64e863b5509f29fdcb7f856e6
--
2.41.0
H
H
Hilton Chain wrote on 28 Jul 2023 05:13
[PATCH 1/3] gnu: runc: Update to 1.1.8.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
31696b55e49febc6b224cd604cdf916494d74910.1690513710.git.hako@ultrarare.space
* gnu/packages/virtualization.scm (runc): Update to 1.1.8.
---
gnu/packages/virtualization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index db7df83524..698d7242c9 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1999,7 +1999,7 @@ (define-public looking-glass-client
(define-public runc
(package
(name "runc")
- (version "1.1.1")
+ (version "1.1.8")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2008,7 +2008,7 @@ (define-public runc
(file-name (string-append name "-" version ".tar.xz"))
(sha256
(base32
- "0jx56x49dgkygdbrfb3pmxycy1n37arj97jra8n422dj36xz1hbm"))))
+ "1w6d2prsb0kgfrcc2m1w0vi8g6qhggr7wfgn4as6nckaymav1i7s"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/opencontainers/runc"
--
2.41.0
H
H
Hilton Chain wrote on 28 Jul 2023 05:13
[PATCH 2/3] gnu: containerd: Update to 1.6.22.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
55a46d4ab3228e69523d5f72eb0855e43a2f6857.1690513710.git.hako@ultrarare.space
* gnu/packages/docker.scm (containerd): Update to 1.6.22.
---
gnu/packages/docker.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 0b2a18d661..3fe7c6ca2c 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -177,7 +177,7 @@ (define-public python-docker-pycreds
(define-public containerd
(package
(name "containerd")
- (version "1.6.6")
+ (version "1.6.22")
(source
(origin
(method git-fetch)
@@ -186,7 +186,7 @@ (define-public containerd
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1vsl747i3wyy68j4lp4nprwxadbyga8qxlrk892afcd2990zp5mr"))
+ (base32 "1m31y00sq2m76m1jiq4znws8gxbgkh5adklvqibxiz1b96vvwjk8"))
(patches
(search-patches "containerd-create-pid-file.patch"))))
(build-system go-build-system)
--
2.41.0
H
H
Hilton Chain wrote on 28 Jul 2023 05:13
[PATCH 3/3] gnu: docker: Update to 20.10.25.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
ff5fe6fd8ca84167e48f748cc0a00d97ab129ce7.1690513710.git.hako@ultrarare.space
* gnu/packages/docker.scm (%docker-version): Update to 20.10.25.
(docker-libnetwork): Update to 20.10-2.3f00484.
(docker)[native-inputs]: Replace go with go-1.19.
---
gnu/packages/docker.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 3fe7c6ca2c..f6c417187c 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -54,7 +54,7 @@ (define-module (gnu packages docker)
;; Note - when changing Docker versions it is important to update the versions
;; of several associated packages (docker-libnetwork and go-sctp).
-(define %docker-version "20.10.17")
+(define %docker-version "20.10.25")
(define-public python-docker
(package
@@ -259,9 +259,9 @@ (define docker-libnetwork
;; the branch that Docker uses, as can be seen in the 'vendor.conf' Docker
;; source file. NOTE - It is important that this version is kept in sync
;; with the version of Docker being used.
- (let ((commit "f6ccccb1c082a432c2a5814aaedaca56af33d9ea")
+ (let ((commit "3f0048413d95802b9c6c836eba06bfc54f9dbd03")
(version (version-major+minor %docker-version))
- (revision "1"))
+ (revision "2"))
(package
(name "docker-libnetwork")
(version (git-version version revision commit))
@@ -274,7 +274,7 @@ (define docker-libnetwork
(file-name (git-file-name name version))
(sha256
(base32
- "0nxpr0h0smv4n641g41vxibr5r85ixfcvs9cp3c4fc7zvrhjc49s"))
+ "185i5ji7dwkv41zmb8s3d7i5gg72wivcj1l4bhr1lb3a1vy2hcxc"))
;; Delete bundled ("vendored") free software source code.
(modules '((guix build utils)))
(snippet '(delete-file-recursively "vendor"))))
@@ -325,7 +325,7 @@ (define-public docker
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0hn7fg717rggwk6dbicrwa7aglqp7dp0jp5rvn6p9gfcnrp2w97d"))))
+ (base32 "1q5vc6f5fzzxsvv1kwdky56fr1jiy9199m3vxqh4mz85qr067cmn"))))
(build-system gnu-build-system)
(arguments
(list
@@ -586,7 +586,7 @@ (define-public docker
xz))
(native-inputs
(list eudev ; TODO: Should be propagated by lvm2 (.pc -> .pc)
- go gotestsum pkg-config))
+ go-1.19 gotestsum pkg-config))
(synopsis "Container component library and daemon")
(description "This package provides a framework to assemble specialized
container systems. It includes components for orchestration, image
@@ -607,7 +607,7 @@ (define-public docker-cli
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ksicj4iqvgp9jabd4xmhkf3vax6dwn4f5dsr73bdqj4mf3ahav0"))))
+ (base32 "0qy35vvnl4lf9w6dr9n7yfqvzhzm7m3sl2ai275apbhygwgcsbss"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"
--
2.41.0
H
H
Hilton Chain wrote on 11 Aug 2023 10:01
Re: [PATCH 0/3] gnu: docker: Update to 20.10.25.
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
87o7jej9d4.wl-hako@ultrarare.space
tags 64910 moreinfo
thanks

Toggle quote (15 lines)
> Hilton Chain (3):
> gnu: runc: Update to 1.1.8.
> gnu: containerd: Update to 1.6.22.
> gnu: docker: Update to 20.10.25.
>
> gnu/packages/docker.scm | 18 +++++++++---------
> gnu/packages/virtualization.scm | 4 ++--
> 2 files changed, 11 insertions(+), 11 deletions(-)
>
>
> base-commit: 35c8d631d2bd63c64e863b5509f29fdcb7f856e6
> --
> 2.41.0


There's an issue that containerd fails to start, I'll address it.
H
H
Hilton Chain wrote on 11 Aug 2023 12:45
[PATCH v2 0/3] gnu: docker: Update to 20.10.25.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1691750473.git.hako@ultrarare.space
V1 -> V2:
- runc@1.1.9
- Fix containerd starting issue.

`make check-system TESTS=docker' passes.


Details on the issue:

Error message:
Toggle snippet (4 lines)
msg="failed to load plugin io.containerd.grpc.v1.cri"
error="invalid plugin config: no corresponding runtime configured in `containerd.runtimes` for `containerd` `default_runtime_name` = \"/gnu/store/...-runc-1.1.9/sbin/runc\""

The message comes from pkg/cri/config/config.go:
Toggle snippet (5 lines)
if _, ok := c.ContainerdConfig.Runtimes[c.ContainerdConfig.DefaultRuntimeName]; !ok {
return fmt.Errorf("no corresponding runtime configured in `containerd.runtimes` for `containerd` `default_runtime_name = \"%s\"", c.ContainerdConfig.DefaultRuntimeName)
}

It expects there's `ContainerdConfig.DefaultRuntimeName' within
`ContainerdConfig.Runtimes'.

And from the relevant code in pkg/cri/config/config_unix.go and the
package definion, "runc" the `DefaultRuntimeName' was substituted to a
store path, but not "runc" in `Runtimes'.

So [...].Runtimes["/gnu/store/...-runc-1.1.9/sbin/runc"] fails.
Toggle snippet (19 lines)
func DefaultConfig() PluginConfig {
[...]
return PluginConfig{
[...]
ContainerdConfig: ContainerdConfig{
[...]
DefaultRuntimeName: "runc",
Runtimes: map[string]Runtime{
"runc": {
[...]
},
},
[...]
},
[...]
}
}

There's no functional change in those two files between 1.6.6 and
1.6.22, I wonder why this wasn't an issue before...

Thanks

Hilton Chain (3):
gnu: runc: Update to 1.1.9.
gnu: containerd: Update to 1.6.22.
gnu: docker: Update to 20.10.25.

gnu/packages/docker.scm | 25 +++++++++++++++----------
gnu/packages/virtualization.scm | 4 ++--
2 files changed, 17 insertions(+), 12 deletions(-)


base-commit: ad4520b92662e42d7d0b1e648b2068300dbb95c8
--
2.41.0
H
H
Hilton Chain wrote on 11 Aug 2023 12:46
[PATCH v2 1/3] gnu: runc: Update to 1.1.9.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
c03d9ce4da33903df3078fb9b1499005086660dd.1691750473.git.hako@ultrarare.space
* gnu/packages/virtualization.scm (runc): Update to 1.1.9.
---
gnu/packages/virtualization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 9556fbc61e..9410b674a3 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2002,7 +2002,7 @@ (define-public looking-glass-client
(define-public runc
(package
(name "runc")
- (version "1.1.1")
+ (version "1.1.9")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2011,7 +2011,7 @@ (define-public runc
(file-name (string-append name "-" version ".tar.xz"))
(sha256
(base32
- "0jx56x49dgkygdbrfb3pmxycy1n37arj97jra8n422dj36xz1hbm"))))
+ "1hhxqwg0mblrgv2aim3scfd9xg13l6i22j124sdma5sf2fzgx5bn"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/opencontainers/runc"
--
2.41.0
H
H
Hilton Chain wrote on 11 Aug 2023 12:46
[PATCH v2 2/3] gnu: containerd: Update to 1.6.22.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
69b56dbf3a55f19e0ac9232eab0e3003a5c380d2.1691750473.git.hako@ultrarare.space
* gnu/packages/docker.scm (containerd): Update to 1.6.22.
[#:phases]<patch-paths>: Patch Runtime name.
---
gnu/packages/docker.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 0b2a18d661..3815824202 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -177,7 +177,7 @@ (define-public python-docker-pycreds
(define-public containerd
(package
(name "containerd")
- (version "1.6.6")
+ (version "1.6.22")
(source
(origin
(method git-fetch)
@@ -186,7 +186,7 @@ (define-public containerd
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1vsl747i3wyy68j4lp4nprwxadbyga8qxlrk892afcd2990zp5mr"))
+ (base32 "1m31y00sq2m76m1jiq4znws8gxbgkh5adklvqibxiz1b96vvwjk8"))
(patches
(search-patches "containerd-create-pid-file.patch"))))
(build-system go-build-system)
@@ -215,7 +215,12 @@ (define-public containerd
(("DefaultRuntimeName: \"runc\"")
(string-append "DefaultRuntimeName: \""
(search-input-file inputs "/sbin/runc")
- "\"")))
+ "\""))
+ ;; ContainerdConfig.Runtimes
+ (("\"runc\":")
+ (string-append "\""
+ (search-input-file inputs "/sbin/runc")
+ "\":")))
(substitute* "vendor/github.com/containerd/go-runc/runc.go"
(("DefaultCommand[ \t]*=.*")
(string-append "DefaultCommand = \""
--
2.41.0
H
H
Hilton Chain wrote on 11 Aug 2023 12:46
[PATCH v2 3/3] gnu: docker: Update to 20.10.25.
(address . 64910@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
0a5220aced12ffbec1d7b09e97e50b7df5fe2d10.1691750473.git.hako@ultrarare.space
* gnu/packages/docker.scm (%docker-version): Update to 20.10.25.
(docker-libnetwork): Update to 20.10-2.3f00484.
(docker)[native-inputs]: Replace go with go-1.19.
---
gnu/packages/docker.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 3815824202..3b809feb67 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -54,7 +54,7 @@ (define-module (gnu packages docker)
;; Note - when changing Docker versions it is important to update the versions
;; of several associated packages (docker-libnetwork and go-sctp).
-(define %docker-version "20.10.17")
+(define %docker-version "20.10.25")
(define-public python-docker
(package
@@ -264,9 +264,9 @@ (define docker-libnetwork
;; the branch that Docker uses, as can be seen in the 'vendor.conf' Docker
;; source file. NOTE - It is important that this version is kept in sync
;; with the version of Docker being used.
- (let ((commit "f6ccccb1c082a432c2a5814aaedaca56af33d9ea")
+ (let ((commit "3f0048413d95802b9c6c836eba06bfc54f9dbd03")
(version (version-major+minor %docker-version))
- (revision "1"))
+ (revision "2"))
(package
(name "docker-libnetwork")
(version (git-version version revision commit))
@@ -279,7 +279,7 @@ (define docker-libnetwork
(file-name (git-file-name name version))
(sha256
(base32
- "0nxpr0h0smv4n641g41vxibr5r85ixfcvs9cp3c4fc7zvrhjc49s"))
+ "185i5ji7dwkv41zmb8s3d7i5gg72wivcj1l4bhr1lb3a1vy2hcxc"))
;; Delete bundled ("vendored") free software source code.
(modules '((guix build utils)))
(snippet '(delete-file-recursively "vendor"))))
@@ -330,7 +330,7 @@ (define-public docker
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0hn7fg717rggwk6dbicrwa7aglqp7dp0jp5rvn6p9gfcnrp2w97d"))))
+ (base32 "1q5vc6f5fzzxsvv1kwdky56fr1jiy9199m3vxqh4mz85qr067cmn"))))
(build-system gnu-build-system)
(arguments
(list
@@ -591,7 +591,7 @@ (define-public docker
xz))
(native-inputs
(list eudev ; TODO: Should be propagated by lvm2 (.pc -> .pc)
- go gotestsum pkg-config))
+ go-1.19 gotestsum pkg-config))
(synopsis "Container component library and daemon")
(description "This package provides a framework to assemble specialized
container systems. It includes components for orchestration, image
@@ -612,7 +612,7 @@ (define-public docker-cli
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ksicj4iqvgp9jabd4xmhkf3vax6dwn4f5dsr73bdqj4mf3ahav0"))))
+ (base32 "0qy35vvnl4lf9w6dr9n7yfqvzhzm7m3sl2ai275apbhygwgcsbss"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"
--
2.41.0
C
C
Christopher Baines wrote on 27 Aug 2023 19:57
Re: [bug#64910] [PATCH v2 0/3] gnu: docker: Update to 20.10.25.
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 64910@debbugs.gnu.org)
87ledwz7oj.fsf@cbaines.net
Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (9 lines)
> Hilton Chain (3):
> gnu: runc: Update to 1.1.9.
> gnu: containerd: Update to 1.6.22.
> gnu: docker: Update to 20.10.25.
>
> gnu/packages/docker.scm | 25 +++++++++++++++----------
> gnu/packages/virtualization.scm | 4 ++--
> 2 files changed, 17 insertions(+), 12 deletions(-)

I haven't tried this out, but it seems like QA [1] is OK with the
changes. There are some red bits, but I think that's just some blocked
builds being counted as unknown.

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTrj1xfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcNZxAAjqhhLosS+qRVrW6K/BuQHx+/F0y/rkEg
wKy1yYCrpkZQkA3LTbHNcoAy1XVVAHro0NPeBuUX9JLvMAInz8f/Mn9UmpUkZf6O
QTE3UtImFeqx4Ldq2MbnuLUx4uGMT16X0jMbtD4VfpIOjkYQoGlGf66TMKf2Br9q
rJCMYUtIl/KTEtMATHjzL49Cmgu4UI4vL1u+qeHC3a2giZqLUCSXGTAltcbF4mDf
41GV5xgkuWnimY+Ck1x27qPR5K0tSVOlPCiG9MvhOYOap/nH4TBuWGpVeDzHSH+B
+RJzevbjGI67JPRkgOqlqGSzviRFIXTWFfAyoVL9+LuNjK9Zb20KKWVsjO3bD3lZ
dknb7xyh8m72I0gz0pw6/P7X3o5sQhuViIbDu0aIIhxagyodHN+yWINWH5lzTp5s
Ptd2nQkq4FJUo1ezwJbX+iTGNgsQoXGNrsi1LrY+u+thp6Dw+79hVHFigybunGEI
Sb1wVtS5tIifgnqDyTcGOlnEsE0d/3NX1OV20rM5C9Jv2er8j0eMe3fPxs3y9dyV
f/Dppjxo73rU/dJESpaJaNUmv/A4L3ucCxZATxeNWFl3nWyAs2Tf8ARRGLk+9O/7
g5OX0xfn9qSSNAVO74OQsIzFRPZeAVJQ+Fg/lJLNAjxFMoUox4Pj++wdlWBaNXT7
YMygvsef5Go=
=SJqd
-----END PGP SIGNATURE-----

H
H
Hilton Chain wrote on 29 Aug 2023 17:16
(name . Christopher Baines)(address . mail@cbaines.net)(address . 64910-done@debbugs.gnu.org)
87msy92814.wl-hako@ultrarare.space
On Mon, 28 Aug 2023 01:57:43 +0800,
Christopher Baines wrote:
Toggle quote (18 lines)
>
> [1 <text/plain (7bit)>]
>
> Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:
>
> > Hilton Chain (3):
> > gnu: runc: Update to 1.1.9.
> > gnu: containerd: Update to 1.6.22.
> > gnu: docker: Update to 20.10.25.
> >
> > gnu/packages/docker.scm | 25 +++++++++++++++----------
> > gnu/packages/virtualization.scm | 4 ++--
> > 2 files changed, 17 insertions(+), 12 deletions(-)
>
> I haven't tried this out, but it seems like QA [1] is OK with the
> changes. There are some red bits, but I think that's just some blocked
> builds being counted as unknown.

Thanks for taking a look! I have checked it again and pushed it to
master.
Closed
?