[PATCH 0/4] Adding xsv

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Christopher Baines
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 26 Jul 2023 17:49
(address . guix-patches@gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
cover.1690386417.git.w@wmeyer.eu
Hi Guix,

I'd like to add xsv, which is a csv cli toolkit, to guix packages. It
has two dependencies, rust-chan-0.1 and rust-filetime-0.1, which I've
added in this patch series as well. As this is my first time adding
something to guix packages I tried to be as close to the guix manual as
possible, please let me know if there's still something missing/if
there's something I can do to further improve the quality of my patches.

Best Regards,

Wilko Meyer

Wilko Meyer (4):
gnu: Added rust-chan-0.1.
gnu: Added rust-filetime-0.1 variant.
gnu: Added xsv.
gnu: Added copyright information.

gnu/packages/crates-io.scm | 40 ++++++++++++++++++++++++++++++++++++++
gnu/packages/rust-apps.scm | 36 ++++++++++++++++++++++++++++++++++
2 files changed, 76 insertions(+)


base-commit: e05dcecd0df49a397aba49585a626cae16a6306c
--
2.41.0
W
W
Wilko Meyer wrote on 26 Jul 2023 17:52
[PATCH 2/4] gnu: Added rust-filetime-0.1 variant.
(address . 64875@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
693b17323a68c8391a53f04bf7934b62af589e4e.1690386417.git.w@wmeyer.eu
* added rust-filetime-0.1 variant inheriting from v0.2
---
gnu/packages/crates-io.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 30afb82eb8..dae443e949 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22350,6 +22350,25 @@ (define-public rust-filetime-0.2
(license (list license:asl2.0
license:expat))))
+(define-public rust-filetime-0.1
+ (package
+ (inherit rust-filetime-0.2)
+ (name "rust-filetime")
+ (version "0.1.15")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "filetime" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03xishfxzpr4nfz4g3r218d6b6g94rxsqw9pw96m6wa8wgrm6iki"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-0.1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-redox-syscall" ,rust-redox-syscall-0.1))))))
+
(define-public rust-field-offset-0.3
(package
(name "rust-field-offset")
--
2.41.0
W
W
Wilko Meyer wrote on 26 Jul 2023 17:52
[PATCH 1/4] gnu: Added rust-chan-0.1.
(address . 64875@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
4bc26eb4d2101ada0722545b6eb5ccace59bcd9a.1690386417.git.w@wmeyer.eu
* added rust-chan-0.1 to crates-io.scm
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f9574e2797..30afb82eb8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10761,6 +10761,26 @@ (define-public rust-cfg-if-0.1
(("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))))
+(define-public rust-chan-0.1
+ (package
+ (name "rust-chan")
+ (version "0.1.23")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "chan" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1n0y992mqfk5zpxzvrv14g9qivacmd4fiv4j1nmgyrg0vaimcjfi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-rand" ,rust-rand-0.3))))
+ (home-page "https://github.com/BurntSushi/chan")
+ (synopsis "DEPRECATED. Use crossbeam-channel instead")
+ (description "DEPRECATED. Use crossbeam-channel instead.")
+ (license (list license:unlicense license:expat))))
+
(define-public rust-chacha20-0.8
(package
(name "rust-chacha20")
--
2.41.0
W
W
Wilko Meyer wrote on 26 Jul 2023 17:52
[PATCH 3/4] gnu: Added xsv.
(address . 64875@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
6489b19de7908f5bd88b4bcd41cfeba27e92fc03.1690386417.git.w@wmeyer.eu
* added xsv to rust-apps.scm
---
gnu/packages/rust-apps.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 8c29969712..2762d6186a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2362,3 +2362,38 @@ (define-public htmlq
(synopsis "Like jq, but for HTML")
(description "Extract content from HTML files using CSS selectors.")
(license license:expat)))
+
+(define-public xsv
+ (package
+ (name "xsv")
+ (version "0.13.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "xsv" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pvzr7x5phlya6m5yikvy13vgbazshw0plysckz9zmf2ly5x4jl8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-chan" ,rust-chan-0.1)
+ ("rust-csv" ,rust-csv-1)
+ ("rust-csv-index" ,rust-csv-index-0.1)
+ ("rust-docopt" ,rust-docopt-1)
+ ("rust-filetime" ,rust-filetime-0.1)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-rand" ,rust-rand-0.4)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-streaming-stats" ,rust-streaming-stats-0.2)
+ ("rust-tabwriter" ,rust-tabwriter-1)
+ ("rust-threadpool" ,rust-threadpool-1))
+ #:cargo-development-inputs (("rust-log" ,rust-log-0.4)
+ ("rust-quickcheck" ,rust-quickcheck-0.6))))
+ (home-page "https://github.com/BurntSushi/xsv")
+ (synopsis "High performance CSV command line toolkit")
+ (description
+ "This package provides a high performance CSV command line toolkit.")
+ (license (list license:unlicense license:expat))))
--
2.41.0
W
W
Wilko Meyer wrote on 26 Jul 2023 17:52
[PATCH 4/4] gnu: Added copyright information.
(address . 64875@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
4baa292ceaf2b1ec4032eef209dededae4b201c6.1690386417.git.w@wmeyer.eu
* added copyright information to rust-apps.scm
* added copyright information to crates-io.scm
---
gnu/packages/crates-io.scm | 1 +
gnu/packages/rust-apps.scm | 1 +
2 files changed, 2 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dae443e949..6a46bd5f3d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2762d6186a..bf14e1290e 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
--
2.41.0
C
C
Christopher Baines wrote on 5 Oct 2023 12:22
Re: [bug#64875] [PATCH 0/4] Adding xsv
(name . Wilko Meyer)(address . w@wmeyer.eu)
874jj5gyfc.fsf@cbaines.net
Wilko Meyer <w@wmeyer.eu> writes:

Toggle quote (24 lines)
> I'd like to add xsv, which is a csv cli toolkit, to guix packages. It
> has two dependencies, rust-chan-0.1 and rust-filetime-0.1, which I've
> added in this patch series as well. As this is my first time adding
> something to guix packages I tried to be as close to the guix manual as
> possible, please let me know if there's still something missing/if
> there's something I can do to further improve the quality of my patches.
>
> Best Regards,
>
> Wilko Meyer
>
> Wilko Meyer (4):
> gnu: Added rust-chan-0.1.
> gnu: Added rust-filetime-0.1 variant.
> gnu: Added xsv.
> gnu: Added copyright information.
>
> gnu/packages/crates-io.scm | 40 ++++++++++++++++++++++++++++++++++++++
> gnu/packages/rust-apps.scm | 36 ++++++++++++++++++++++++++++++++++
> 2 files changed, 76 insertions(+)
>
>
> base-commit: e05dcecd0df49a397aba49585a626cae16a6306c

Hi Wilko,

Thanks for sending these patches. I think there's an issue with xsv as
one of the inputs (rust-csv-index) doesn't seem to exist.

Do these new packages build for you on your system?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUejrdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeOmQ//YDcErd/FhpB0DAf2jsTwCjpJDMGyRCl+
BQ7tPbG4Hx/cUBsVXJpKSB7R3h8DKNP52b0o8HZ984X+aSSZuE6wSY2HgpfQZ/gx
6XDZuswsh48TOcGJISSHmFPdCwU2ox38AusJOfJnzamU12Jumn4CJI20KIm/xNP3
CiNXz+N8zLwkcuk3CzqDlCKnl9lWRCJdCaoHp4r6QiT7aVTIUDlO0uWZ7Cdion5M
jhT0va9PYjoVFFzROSFx4uXlyy/xwfXh+zm0HoJH6/GM15TwXtO1E61GTnMsFW96
4ZvOEhQTi6d4A5n6HQP1YwJN5MCQ0tHNe2M+ju869y3Al1Q7DQvuo0z6xlOGh9E7
V18zmPqJbNQEmZp2sGj5s/+ZTVzoyH0XZ5RPS0M7Y07lE0KuY8h8plYx9tqoJTzj
/43/vwkPhXzLHf7jVCouhccy9zXqrSduWYauAtlMnnwo6fJ20ynK3wpjo6spCtGl
iGadrSQAwiTyyz15lVtC+8oDWwAgg7dAIMEuJeywrqBCkp8gWMwvvinwh6ovFwTO
WP2Q1qHAdxYZpFKvS1hIDoP9QhIUOvdttSfPrY8zgCABuysAYWXPM8WEzDB2yPAK
c/kR0ahwMEtvclSv8UTIgJaIJ9D/IgwyCkzrKjX6RquxozAFI0X8HOFtpuDMq/QG
zMZkANmtXFo=
=U7Gv
-----END PGP SIGNATURE-----

W
W
Wilko Meyer wrote on 5 Oct 2023 15:25
(name . Christopher Baines)(address . mail@cbaines.net)
87cyxtmas4.fsf@wmeyer.eu
Hi Chris,

Thanks for reviewing my patch series!

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (3 lines)
> Thanks for sending these patches. I think there's an issue with xsv as
> one of the inputs (rust-csv-index) doesn't seem to exist.

You're right, I forgot to include rust-csv-index in this patch series,
but already had it locally, which is why I was able to build xsv without
noticing it. I'll include a patch to add rust-csv-index in a minute.

Others than that, and with rust-csv-index included, it should build (at
least it does so for me locally)/work fine:

wilko@guix230 ~/devel/guix [env]$ xsv --version
0.13.0

--
Kind regards,

Wilko Meyer
w@wmeyer.eu
W
W
Wilko Meyer wrote on 5 Oct 2023 16:04
[PATCH] gnu: Add rust-csv-index.
(address . 64875@debbugs.gnu.org)
4b9470397e4c5b4929725251e6bb002ef80b6bae.1696512142.git.w@wmeyer.eu
* gnu/packages/crates-io.scm (rust-csv-index-0.1): New variable.
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 36f1e93f1d..b25a7fec46 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17124,6 +17124,26 @@ (define-public rust-cssparser-macros-0.3
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))))))
+(define-public rust-csv-index-0.1
+ (package
+ (name "rust-csv-index")
+ (version "0.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "csv-index" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01048y84y0bakqm0x4y1svjv6lzc753b9q598xp7xgcqrdgi6x7j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-csv" ,rust-csv-1))))
+ (home-page "https://github.com/BurntSushi/rust-csv")
+ (synopsis "On disk CSV indexing data structures.")
+ (description "On disk CSV indexing data structures.")
+ (license (list license:unlicense license:expat))))
+
(define-public rust-csv-1
(package
(name "rust-csv")

base-commit: ad5e4fe54a66c725dc03dedebf8e5c65723ccb74
prerequisite-patch-id: 5bde835de1e0f7e9cd752986da0585463713d745
prerequisite-patch-id: cda50d13de497f5c74c87b2def4ae6a7d5807305
prerequisite-patch-id: 7024afc52961b5947429f925c55265f29607c801
prerequisite-patch-id: 10a4f92340880065a5210c983cc878c98c075855
--
2.41.0
C
C
Christopher Baines wrote on 11 Oct 2023 12:16
Re: [bug#64875] [PATCH 0/4] Adding xsv
(name . Wilko Meyer)(address . w@wmeyer.eu)
875y3dfon2.fsf@cbaines.net
Wilko Meyer <w@wmeyer.eu> writes:

Toggle quote (11 lines)
> Thanks for reviewing my patch series!
>
> Christopher Baines <mail@cbaines.net> writes:
>
>> Thanks for sending these patches. I think there's an issue with xsv as
>> one of the inputs (rust-csv-index) doesn't seem to exist.
>
> You're right, I forgot to include rust-csv-index in this patch series,
> but already had it locally, which is why I was able to build xsv without
> noticing it. I'll include a patch to add rust-csv-index in a minute.

I see the new patch now.

The other simple thing I notice is that the commit messages should be in
the present tense (so Add rather than Added). Would you be able to fix
that and then resend the entire series? It's always useful to send all
the patches again when you make changes, as that simplifies the job for
anyone trying to get the latest patches.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUmdoFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcB5A/+PkL56aKZ+tJat1R352+Ag8s6dwlp+u85
CE4S/nVe4EbMOBJ9TwQHwc9tZqAUAZpkYs3C0gnzF2fVGBhMWt1PgpxcA1t8pDxu
yv7gbry+efQUJm+Z5HcPE0eXeF7qgeWUtQhO1x166S4/6UceavmmluuR8qBNmiqC
+55sdfvFlo4Ejx4922CLJEcnAdihc0W79d6XI8Dw/kj5gN/x7SMKPrX33ovfrMoW
75hiMAj56LVHNq5ra5jNyIZfMVmiSH30boFXTJJk7cPTMxzYMF7xRe2gti+8s5Ja
sdabLMnxifAurJb7EFAWc07EMTVRxJPD8dCYuCeX/BwGOV/2vBUT45FJIlVxpskC
BteWeUIwm8sOO8n1zKZlhIPwcFxGyTKMnAeR/aDTdMNwh9W9ZkMX8HQtOtUi+3Ul
ZaZbZdFV0UNd+HPE86sMmloOCxomckl8wQtP2QrV24tBN2SUmfuqVL83CZ481nj4
69EfE4X1lnMT94EK11azwPRjeyyZhqrMr0QtDfUfY1L3pJuKj3gDGoq2FzqG0EG1
hXq84tSny88OaLHFkEhncd6kKUKtndxi5zEYqnQCMUV6+xopiJo+r8j9OSjf6RbZ
b5/JhXaz/ZvO1wkLnJH2vrYywMr8KodsRxR0fBFhyL5AQGnoHfwdkLtNGswO2gID
+r/MG3cae8w=
=vOab
-----END PGP SIGNATURE-----

W
W
Wilko Meyer wrote on 15 Oct 2023 23:57
[PATCH v2 1/5] gnu: Add rust-filetime-0.1 variant.
(address . 64875@debbugs.gnu.org)
20231015215713.20824-1-w@wmeyer.eu
* gnu/packages/crates-io.scm (rust-filetime-0.1): New variable.
---
gnu/packages/crates-io.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80fb92ec82..7a06d877e2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24389,6 +24389,25 @@ (define-public rust-filetime-0.2
(license (list license:asl2.0
license:expat))))
+(define-public rust-filetime-0.1
+ (package
+ (inherit rust-filetime-0.2)
+ (name "rust-filetime")
+ (version "0.1.15")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "filetime" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03xishfxzpr4nfz4g3r218d6b6g94rxsqw9pw96m6wa8wgrm6iki"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-0.1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-redox-syscall" ,rust-redox-syscall-0.1))))))
+
(define-public rust-field-offset-0.3
(package
(name "rust-field-offset")
--
2.41.0
W
W
Wilko Meyer wrote on 15 Oct 2023 23:57
[PATCH v2 2/5] gnu: Add rust-chan-0.1.
(address . 64875@debbugs.gnu.org)
20231015215713.20824-2-w@wmeyer.eu
* gnu/packages/crates-io.scm (rust-chan-0.1): New variable.
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7a06d877e2..2fa2cfe695 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11424,6 +11424,26 @@ (define-public rust-cfg-if-0.1
(("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))))
+(define-public rust-chan-0.1
+ (package
+ (name "rust-chan")
+ (version "0.1.23")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "chan" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1n0y992mqfk5zpxzvrv14g9qivacmd4fiv4j1nmgyrg0vaimcjfi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-rand" ,rust-rand-0.3))))
+ (home-page "https://github.com/BurntSushi/chan")
+ (synopsis "DEPRECATED. Use crossbeam-channel instead")
+ (description "DEPRECATED. Use crossbeam-channel instead.")
+ (license (list license:unlicense license:expat))))
+
(define-public rust-chacha20-0.8
(package
(name "rust-chacha20")
--
2.41.0
W
W
Wilko Meyer wrote on 15 Oct 2023 23:57
[PATCH v2 3/5] gnu: Add xsv.
(address . 64875@debbugs.gnu.org)
20231015215713.20824-3-w@wmeyer.eu
* gnu/packages/crates-io.scm (xsv): New variable.
---
gnu/packages/rust-apps.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2f41ca4849..f7d346d3de 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2537,3 +2537,38 @@ (define-public htmlq
(synopsis "Like jq, but for HTML")
(description "Extract content from HTML files using CSS selectors.")
(license license:expat)))
+
+(define-public xsv
+ (package
+ (name "xsv")
+ (version "0.13.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "xsv" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pvzr7x5phlya6m5yikvy13vgbazshw0plysckz9zmf2ly5x4jl8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-chan" ,rust-chan-0.1)
+ ("rust-csv" ,rust-csv-1)
+ ("rust-csv-index" ,rust-csv-index-0.1)
+ ("rust-docopt" ,rust-docopt-1)
+ ("rust-filetime" ,rust-filetime-0.1)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-rand" ,rust-rand-0.4)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-streaming-stats" ,rust-streaming-stats-0.2)
+ ("rust-tabwriter" ,rust-tabwriter-1)
+ ("rust-threadpool" ,rust-threadpool-1))
+ #:cargo-development-inputs (("rust-log" ,rust-log-0.4)
+ ("rust-quickcheck" ,rust-quickcheck-0.6))))
+ (home-page "https://github.com/BurntSushi/xsv")
+ (synopsis "High performance CSV command line toolkit")
+ (description
+ "This package provides a high performance CSV command line toolkit.")
+ (license (list license:unlicense license:expat))))
--
2.41.0
W
W
Wilko Meyer wrote on 15 Oct 2023 23:57
[PATCH v2 4/5] gnu: Add rust-csv-index.
(address . 64875@debbugs.gnu.org)
20231015215713.20824-4-w@wmeyer.eu
* gnu/packages/crates-io.scm (rust-csv-index-0.1): New variable.
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2fa2cfe695..d2d1b44e90 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17159,6 +17159,26 @@ (define-public rust-cssparser-macros-0.3
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))))))
+(define-public rust-csv-index-0.1
+ (package
+ (name "rust-csv-index")
+ (version "0.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "csv-index" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01048y84y0bakqm0x4y1svjv6lzc753b9q598xp7xgcqrdgi6x7j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-csv" ,rust-csv-1))))
+ (home-page "https://github.com/BurntSushi/rust-csv")
+ (synopsis "On disk CSV indexing data structures.")
+ (description "On disk CSV indexing data structures.")
+ (license (list license:unlicense license:expat))))
+
(define-public rust-csv-1
(package
(name "rust-csv")
--
2.41.0
W
W
Wilko Meyer wrote on 15 Oct 2023 23:57
[PATCH v2 5/5] gnu: Add copyright header.
(address . 64875@debbugs.gnu.org)
20231015215713.20824-5-w@wmeyer.eu
* gnu/packages/crates-io.scm: Add copyright header.
* gnu/packages/rust-apps.scm: Add copyright header.
---
gnu/packages/crates-io.scm | 1 +
gnu/packages/rust-apps.scm | 1 +
2 files changed, 2 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d2d1b44e90..4758a240fa 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index f7d346d3de..d5bbbd05fe 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
--
2.41.0
E
E
Efraim Flashner wrote on 16 Oct 2023 11:37
Re: [bug#64875] [PATCH v2 3/5] gnu: Add xsv.
(name . Wilko Meyer)(address . w@wmeyer.eu)
ZS0EbvdZVXtPx06H@3900XT
Thanks. Patches pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUtBG4ACgkQQarn3Mo9
g1H1og/+LvN6DsOb+rnPkgv0wUHkz0tqHTtg3iOVj3XpU3ziPKhROxHxl0VukEe6
/7oudTFi6Fs+RYwTfTCNzbITrtutdMGJNeeBO9XTPb8yEZA/zg1e008+KWif6i7k
yDzT3PUocGNyCSRD1Sjx67dAViS11c81jzUS22hEk982p1uZWH0XDFQe/ueQOcJA
sFPfEd2+dWxXFAWbP4skT3vbw8tl0kvAYlOT4rrfDwatYXVmjscDqfjiqIJV6FiO
/4xcLBYPAENQKBaQ6cz4F8xtCJszq/l7k5gWxGJvDqL3Sbq20vSpcOXXCgwbQi4C
IXDNBDvPMOP7oYfBY5b+vZnHVQKt+0yRef6lKOTnE9hgrU0Niu8PRWq6aiZZAurn
pmjq+txf3ZpQ9jafWCPYPQrAaKZGXOtDZbkDH6Ej64yEnqWKF0lBRq5+kahBBYPl
lt/gFru4raFO7up4T16GxmsC85PLK4UysON6ZQlShJ7eKPpTuCCFz8V7LmaVO2mm
bVQaEdryP9j6hHcmydRoX07er4wX1nQKofp+ByOD3XoTQoGuoFkz2ijv288MxK8v
UGxBBaFU9Lcp2T7vbyrHOIMabi7JrWqYRO2gR6V5IJKq68UV7MdjhcOUClH+IeAi
H3so2cwyTNSSL3MVKDioUC7HFFTRCnaTNuicZn46XWKCBfNhAPw=
=O/mR
-----END PGP SIGNATURE-----


Closed
?