[PATCH core-updates 1/4] gnu: imagemagick: Update to 6.9.12-91

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Saku Laesvuori
Owner
unassigned
Submitted by
Saku Laesvuori
Severity
normal
S
S
Saku Laesvuori wrote on 20 Jul 2023 20:37
(address . guix-patches@gnu.org)(name . Saku Laesvuori)(address . saku@laesvuori.fi)
20230720183731.7296-1-saku@laesvuori.fi
* gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.12-91
[patches]: Remove upstreamed patches. Add patch for fixing tests.
[arguments]: Enable tests.
* gnu/packages/patches/imagemagick-Fix-tests.patch: New file.
* gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch,
gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch,
gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch,
gnu/packages/patches/imagemagick-CVE-2020-27829.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove old patches. Add patch for
fixing imagemagick tests.
---
The comments in the code imply that this could be applied to master but
`guix refresh` claimed it to have over 3 000 dependents. Go figure.

gnu/local.mk | 5 +--
gnu/packages/imagemagick.scm | 13 ++++---
.../patches/imagemagick-CVE-2020-27829.patch | 27 --------------
.../patches/imagemagick-Fix-tests.patch | 24 +++++++++++++
.../imagemagick-ReadDCMImage-fix.patch | 26 --------------
.../imagemagick-ReadDCMPixels-fix.patch | 35 -------------------
.../imagemagick-WriteTHUMBNAILImage-fix.patch | 25 -------------
7 files changed, 31 insertions(+), 124 deletions(-)
delete mode 100644 gnu/packages/patches/imagemagick-CVE-2020-27829.patch
create mode 100644 gnu/packages/patches/imagemagick-Fix-tests.patch
delete mode 100644 gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
delete mode 100644 gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
delete mode 100644 gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch

Toggle diff (215 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index f2ef72c10a..a6a6c32a06 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1385,10 +1385,7 @@ dist_patch_DATA = \
%D%/packages/patches/idris-test-ffi008.patch \
%D%/packages/patches/igt-gpu-tools-Use-libproc2.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
- %D%/packages/patches/imagemagick-CVE-2020-27829.patch \
- %D%/packages/patches/imagemagick-ReadDCMImage-fix.patch \
- %D%/packages/patches/imagemagick-ReadDCMPixels-fix.patch \
- %D%/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch \
+ %D%/packages/patches/imagemagick-Fix-tests.patch \
%D%/packages/patches/inkscape-poppler-compat.patch \
%D%/packages/patches/instead-use-games-path.patch \
%D%/packages/patches/intel-xed-fix-nondeterminism.patch \
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 6f6fa63c64..169dc12f35 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -149,19 +149,18 @@ (define-public imagemagick
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-4")
+ (version "6.9.12-91")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1pkwij76yz7vd5grl6520pgpa912qb6kh34qamx4zfndwcx6cf6b"))
- (patches
- (search-patches "imagemagick-ReadDCMImage-fix.patch"
- "imagemagick-ReadDCMPixels-fix.patch"
- "imagemagick-WriteTHUMBNAILImage-fix.patch"
- "imagemagick-CVE-2020-27829.patch"))))))
+ "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
+ (patches (search-patches "imagemagick-Fix-tests.patch"))))
+ (arguments
+ (append (package-arguments imagemagick/stable)
+ '(#:tests? #t)))))
(define-public perl-image-magick
(package
diff --git a/gnu/packages/patches/imagemagick-CVE-2020-27829.patch b/gnu/packages/patches/imagemagick-CVE-2020-27829.patch
deleted file mode 100644
index b15c1d0879..0000000000
--- a/gnu/packages/patches/imagemagick-CVE-2020-27829.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-We omit the ChangeLog changes below, since they do not apply cleanly.
-
-
-From 6ee5059cd3ac8d82714a1ab1321399b88539abf0 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Mon, 30 Nov 2020 16:26:59 +0000
-Subject: [PATCH] possible TIFF related-heap buffer overflow (alert & POC by
- Hardik Shah)
-
----
- ChangeLog | 6 ++++++
- coders/tiff.c | 2 +-
- 2 files changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/coders/tiff.c b/coders/tiff.c
-index e98f927ab..1eecf17ae 100644
---- a/coders/tiff.c
-+++ b/coders/tiff.c
-@@ -1975,7 +1975,7 @@ static Image *ReadTIFFImage(const ImageInfo *image_info,
- extent+=image->columns*sizeof(uint32);
- #endif
- strip_pixels=(unsigned char *) AcquireQuantumMemory(extent,
-- sizeof(*strip_pixels));
-+ 2*sizeof(*strip_pixels));
- if (strip_pixels == (unsigned char *) NULL)
- ThrowTIFFException(ResourceLimitError,"MemoryAllocationFailed");
- (void) memset(strip_pixels,0,extent*sizeof(*strip_pixels));
diff --git a/gnu/packages/patches/imagemagick-Fix-tests.patch b/gnu/packages/patches/imagemagick-Fix-tests.patch
new file mode 100644
index 0000000000..cee105c61d
--- /dev/null
+++ b/gnu/packages/patches/imagemagick-Fix-tests.patch
@@ -0,0 +1,24 @@
+From 696d8735e05688d0162b769f37b0d75205ab2a97 Mon Sep 17 00:00:00 2001
+From: Saku Laesvuori <saku@laesvuori.fi>
+Date: Thu, 20 Jul 2023 19:14:43 +0300
+Subject: [PATCH] Fix tests
+
+---
+ Magick++/demo/demo.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Magick++/demo/demo.cpp b/Magick++/demo/demo.cpp
+index 14721dbcd..12cc3b10c 100644
+--- a/Magick++/demo/demo.cpp
++++ b/Magick++/demo/demo.cpp
+@@ -477,6 +477,7 @@ int main( int /*argc*/, char ** argv)
+ montageOpts.compose( OverCompositeOp );
+ montageOpts.backgroundColor( "#ffffff" );
+ montageOpts.pointSize( 18 );
++ montageOpts.font(MAGICK_FONT);
+ montageOpts.fillColor( "#600" );
+ montageOpts.strokeColor( Color() );
+ montageOpts.compose(OverCompositeOp);
+--
+2.41.0
+
diff --git a/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch b/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
deleted file mode 100644
index 42ece43682..0000000000
--- a/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 512668dfd92b20d0d08b91d62b422d8262573281 Mon Sep 17 00:00:00 2001
-From: Dirk Lemstra <dirk@lemstra.org>
-Date: Wed, 24 Mar 2021 20:37:15 +0100
-Subject: [PATCH] Throw exception when no exception was raised but status was
- false (#3432).
-
----
- coders/dcm.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/coders/dcm.c b/coders/dcm.c
-index 7a68ed6e8..ed17c9567 100644
---- a/coders/dcm.c
-+++ b/coders/dcm.c
-@@ -3989,6 +3989,8 @@ static Image *ReadDCMImage(const ImageInfo *image_info,ExceptionInfo *exception)
- if (redmap != (int *) NULL)
- redmap=(int *) RelinquishMagickMemory(redmap);
- image=DestroyImageList(image);
-+ if ((status == MagickFalse) && (exception->severity < ErrorException))
-+ ThrowReaderException(CorruptImageError,"CorruptImage");
- return(GetFirstImageInList(images));
- }
- if (info.depth != (1UL*MAGICKCORE_QUANTUM_DEPTH))
---
-2.31.0
-
diff --git a/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch b/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
deleted file mode 100644
index a91999186b..0000000000
--- a/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From c8f25953ad1dd38a8b2d92738f0f742ad7e0bce7 Mon Sep 17 00:00:00 2001
-From: Cristy <mikayla-grace@urban-warrior.org>
-Date: Sun, 21 Mar 2021 21:21:15 -0400
-Subject: [PATCH] https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32322
-
----
- coders/dcm.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/coders/dcm.c b/coders/dcm.c
-index 29eed9618..7a68ed6e8 100644
---- a/coders/dcm.c
-+++ b/coders/dcm.c
-@@ -2984,12 +2984,12 @@ static MagickBooleanType ReadDCMPixels(Image *image,DCMInfo *info,
- }
- else
- {
-- SetPixelRed(q,(Quantum) (((ssize_t) pixel.red) |
-- (((ssize_t) GetPixelRed(q)) << 8)));
-- SetPixelGreen(q,(Quantum) (((ssize_t) pixel.green) |
-- (((ssize_t) GetPixelGreen(q)) << 8)));
-- SetPixelBlue(q,(Quantum) (((ssize_t) pixel.blue) |
-- (((ssize_t) GetPixelBlue(q)) << 8)));
-+ SetPixelRed(q,(Quantum) (((size_t) pixel.red) |
-+ (((size_t) GetPixelRed(q)) << 8)));
-+ SetPixelGreen(q,(Quantum) (((size_t) pixel.green) |
-+ (((size_t) GetPixelGreen(q)) << 8)));
-+ SetPixelBlue(q,(Quantum) (((size_t) pixel.blue) |
-+ (((size_t) GetPixelBlue(q)) << 8)));
- }
- q++;
- }
---
-2.31.0
-
diff --git a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch b/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
deleted file mode 100644
index f38a45b800..0000000000
--- a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6a5d3575487487f2703383338bd17c8c25068f19 Mon Sep 17 00:00:00 2001
-From: Cristy <mikayla-grace@urban-warrior.org>
-Date: Thu, 25 Mar 2021 08:58:18 -0400
-Subject: [PATCH] eliminate compiler warning
-
----
- coders/thumbnail.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/coders/thumbnail.c b/coders/thumbnail.c
-index 3833341b0..1e2bfe8c2 100644
---- a/coders/thumbnail.c
-+++ b/coders/thumbnail.c
-@@ -199,7 +199,7 @@ static MagickBooleanType WriteTHUMBNAILImage(const ImageInfo *image_info,
- q++;
- }
- if ((q > (GetStringInfoDatum(profile)+GetStringInfoLength(profile))) ||
-- (length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
-+ ((ssize_t) length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
- ThrowWriterException(CoderError,"ImageDoesNotHaveAThumbnail");
- thumbnail_image=BlobToImage(image_info,q,length,&image->exception);
- if (thumbnail_image == (Image *) NULL)
---
-2.31.0
-
--
2.41.0
S
S
Saku Laesvuori wrote on 20 Jul 2023 20:40
[PATCH core-updates 2/4] gnu: imagemagick: Fix converting webp images
(address . 64751@debbugs.gnu.org)
20230720184039.12104-1-saku@laesvuori.fi

* gnu/packages/imagemagick.scm (imagemagick)[inputs]: Add libwebp.
---
The comments in the code imply that this could be applied to master, but
`guix refresh` claimed it to have over 3 000 dependents. Go figure.

gnu/packages/imagemagick.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 169dc12f35..55e100a71c 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -158,6 +158,8 @@ (define-public imagemagick
(base32
"0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
(patches (search-patches "imagemagick-Fix-tests.patch"))))
+ (inputs (cons `("libwebp" ,libwebp)
+ (package-inputs imagemagick/stable)))
(arguments
(append (package-arguments imagemagick/stable)
'(#:tests? #t)))))
--
2.41.0
S
S
Saku Laesvuori wrote on 20 Jul 2023 20:41
[PATCH core-updates 3/4] gnu: imagemagick: Update package style
(address . 64751@debbugs.gnu.org)(name . Saku Laesvuori)(address . saku@laesvuori.fi)
20230720184404.14172-1-saku@laesvuori.fi
* gnu/packages/imagemagick.scm
(imagemagick/stable)[arguments]<phases>: Use G-exps.
[inputs]: Use new style.
(imagemagick)[inputs]: Use new style.
---
gnu/packages/imagemagick.scm | 105 +++++++++++++++++------------------
1 file changed, 50 insertions(+), 55 deletions(-)

Toggle diff (135 lines)
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 55e100a71c..82ac9f5107 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -68,69 +68,65 @@ (define-public imagemagick/stable
(version "6.9.11-48")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://imagemagick/ImageMagick-"
- version ".tar.xz"))
+ (uri (string-append "mirror://imagemagick/ImageMagick-" version
+ ".tar.xz"))
(sha256
(base32
"0m8nkmywkqwyrr01q7aiakj6mi4rb2psjgzv8n0x82x3s1rpfyql"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-frozenpaths" "--without-gcc-arch"
+ (list
+ #:configure-flags ''("--with-frozenpaths" "--without-gcc-arch"
- ;; Do not embed the build date in binaries.
- "--enable-reproducible-build")
+ ;; Do not embed the build date in binaries.
+ "--enable-reproducible-build")
- ;; FIXME: The test suite succeeded before version 6.9.6-2.
- ;; Try enabling it again with newer releases.
- #:tests? #f
- #:phases (modify-phases %standard-phases
- (add-before
- 'build 'pre-build
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- ;; Clear the `LIBRARY_PATH' setting, which otherwise
- ;; interferes with our own use.
- (("^LIBRARY_PATH[[:blank:]]*=.*$")
- "")
+ ;; FIXME: The test suite succeeded before version 6.9.6-2.
+ ;; Try enabling it again with newer releases.
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda* _
+ (substitute* "Makefile"
+ ;; Clear the `LIBRARY_PATH' setting, which otherwise
+ ;; interferes with our own use.
+ (("^LIBRARY_PATH[[:blank:]]*=.*$")
+ "")
- ;; Since the Makefile overrides $docdir, modify it to
- ;; refer to what we want.
- (("^DOCUMENTATION_PATH[[:blank:]]*=.*$")
- (let ((doc (assoc-ref outputs "doc")))
- (string-append "DOCUMENTATION_PATH = "
- doc "/share/doc/"
- ,name "-"
- ,(package-version this-package) "\n"))))
- #t))
- (add-before
- 'configure 'strip-configure-xml
- (lambda _
- (substitute* "config/configure.xml.in"
- ;; Do not record 'configure' arguments in the
- ;; configure.xml file that gets installed: That would
- ;; include --docdir, and thus retain a reference to the
- ;; 'doc' output.
- (("@CONFIGURE_ARGS@")
- "not recorded"))
- #t)))))
+ ;; Since the Makefile overrides $docdir, modify it to
+ ;; refer to what we want.
+ (("^DOCUMENTATION_PATH[[:blank:]]*=.*$")
+ (string-append "DOCUMENTATION_PATH = "
+ #$output:doc
+ "/share/doc/imagemagick-"
+ #$(package-version this-package)
+ "\n")))))
+ (add-before 'configure 'strip-configure-xml
+ (lambda _
+ (substitute* "config/configure.xml.in"
+ ;; Do not record 'configure' arguments in the
+ ;; configure.xml file that gets installed: That would
+ ;; include --docdir, and thus retain a reference to the
+ ;; 'doc' output.
+ (("@CONFIGURE_ARGS@")
+ "not recorded")))))))
;; TODO: Add Jasper etc.
- (inputs `(("fftw" ,fftw)
- ("graphviz" ,graphviz)
- ("ghostscript" ,ghostscript)
- ("lcms" ,lcms)
- ("libx11" ,libx11)
- ("zlib" ,zlib)
- ("libxml2" ,libxml2)
- ("libtiff" ,libtiff)
- ("libpng" ,libpng)
- ("libjpeg" ,libjpeg-turbo)
- ("pango" ,pango)
- ("freetype" ,freetype)
- ("bzip2" ,bzip2)
- ("xz" ,xz)))
+ (inputs (list fftw
+ graphviz
+ ghostscript
+ lcms
+ libx11
+ zlib
+ libxml2
+ libtiff
+ libpng
+ libjpeg-turbo
+ pango
+ freetype
+ bzip2
+ xz))
(native-inputs (list pkg-config))
- (outputs '("out"
- "doc")) ; 26 MiB of HTML documentation
+ (outputs '("out" "doc")) ;26 MiB of HTML documentation
(home-page "https://www.imagemagick.org/")
(synopsis "Create, edit, compose, or convert bitmap images")
(description
@@ -158,8 +154,7 @@ (define-public imagemagick
(base32
"0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
(patches (search-patches "imagemagick-Fix-tests.patch"))))
- (inputs (cons `("libwebp" ,libwebp)
- (package-inputs imagemagick/stable)))
+ (inputs (cons libwebp (package-inputs imagemagick/stable)))
(arguments
(append (package-arguments imagemagick/stable)
'(#:tests? #t)))))
--
2.41.0
S
S
Saku Laesvuori wrote on 20 Jul 2023 20:41
[PATCH core-updates 4/4] gnu: imagemagick/stable: Sync with imagemagick
(address . 64751@debbugs.gnu.org)(name . Saku Laesvuori)(address . saku@laesvuori.fi)
20230720184404.14172-2-saku@laesvuori.fi
* gnu/packages/imagemagick (imagemagick/stable): Apply modifications from
imagemagick.
(imagemagick): Remove upstreamed modifications.
---
Upstreamed means "moved to the inherited package" here. I am not sure is
this obvious/good wording as upstreaming normally means sending the
modifications to another project.

gnu/packages/imagemagick.scm | 29 ++++++-----------------------
1 file changed, 6 insertions(+), 23 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 82ac9f5107..c87ea0d11d 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -65,14 +65,15 @@ (define-public imagemagick/stable
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.11-48")
+ (version "6.9.12-91")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-" version
".tar.xz"))
(sha256
(base32
- "0m8nkmywkqwyrr01q7aiakj6mi4rb2psjgzv8n0x82x3s1rpfyql"))))
+ "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
+ (patches (search-patches "imagemagick-Fix-tests.patch"))))
(build-system gnu-build-system)
(arguments
(list
@@ -80,10 +81,7 @@ (define-public imagemagick/stable
;; Do not embed the build date in binaries.
"--enable-reproducible-build")
-
- ;; FIXME: The test suite succeeded before version 6.9.6-2.
- ;; Try enabling it again with newer releases.
- #:tests? #f
+ #:tests? #t
#:phases #~(modify-phases %standard-phases
(add-before 'build 'pre-build
(lambda* _
@@ -121,6 +119,7 @@ (define-public imagemagick/stable
libtiff
libpng
libjpeg-turbo
+ libwebp
pango
freetype
bzip2
@@ -141,23 +140,7 @@ (define-public imagemagick/stable
(define-public imagemagick
(package
(inherit imagemagick/stable)
- (properties (alist-delete 'hidden? (package-properties imagemagick/stable)))
- ;; The 7 release series has an incompatible API, while the 6 series is still
- ;; maintained. Don't update to 7 until we've made sure that the ImageMagick
- ;; users are ready for the 7-series API.
- (version "6.9.12-91")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://imagemagick/ImageMagick-"
- version ".tar.xz"))
- (sha256
- (base32
- "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
- (patches (search-patches "imagemagick-Fix-tests.patch"))))
- (inputs (cons libwebp (package-inputs imagemagick/stable)))
- (arguments
- (append (package-arguments imagemagick/stable)
- '(#:tests? #t)))))
+ (properties (alist-delete 'hidden? (package-properties imagemagick/stable)))))
(define-public perl-image-magick
(package
--
2.41.0
M
M
Maxim Cournoyer wrote on 22 Jan 00:05 +0100
Re: [bug#64751] [PATCH core-updates 1/4] gnu: imagemagick: Update to 6.9.12-91
(name . Saku Laesvuori)(address . saku@laesvuori.fi)(address . 64751-done@debbugs.gnu.org)
87plxu70e0.fsf@gmail.com
Hi,

Saku Laesvuori <saku@laesvuori.fi> writes:

Toggle quote (11 lines)
> * gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.12-91
> [patches]: Remove upstreamed patches. Add patch for fixing tests.
> [arguments]: Enable tests.
> * gnu/packages/patches/imagemagick-Fix-tests.patch: New file.
> * gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch,
> gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch,
> gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch,
> gnu/packages/patches/imagemagick-CVE-2020-27829.patch: Delete files.
> * gnu/local.mk (dist_patch_DATA): Remove old patches. Add patch for
> fixing imagemagick tests.

Applied with commit ac658511ae. We'll want to update to 6.9.13.X
though, as 6.9.12-91 is still plagued with a CVE or two.

--
Thanks,
Maxim
Closed
?