[PATCH] gnu: Add python-pynetbox.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 20 Jul 2023 19:13
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
70f18c6352132594189e45021e5b0f31bc0d86cf.1689873228.git.timotej.lazar@araneo.si
* gnu/packages/python-web.scm (python-pynetbox): New variable.
---
gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6f855a503b..bce7fbd0e8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8686,3 +8686,28 @@ (define-public python-enoslib
scientific testbeds. It lets you deploy networks of machines on actual
hardware on Grid'5000 or via OpenStack, to Vagrant, Chameleon, and more.")
(license license:gpl3+)))
+
+(define-public python-pynetbox
+ (package
+ (name "python-pynetbox")
+ (version "7.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynetbox" version))
+ (sha256
+ (base32
+ "16ps9zgcjzyzn95lry277741i8php4ci3plsyd2vqxd57havba7b"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; Integration tests depend on docker.
+ (delete-file-recursively "tests/integration"))))))
+ (propagated-inputs (list python-requests))
+ (native-inputs (list python-pytest python-pyyaml python-setuptools-scm))
+ (home-page "https://github.com/netbox-community/pynetbox")
+ (synopsis "NetBox API client library")
+ (description "Python module to query and edit data stored in a
+@url{https://netbox.dev,NetBox} instance.")
+ (license license:asl2.0)))

base-commit: 21b718f4d6c3ded8ef50d12f6e9ae6474f74620f
--
2.41.0
M
M
Mathieu Othacehe wrote on 5 Oct 2023 17:27
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
87fs2pum2c.fsf@gnu.org
Hey,

Sorry for the laaate review.

Toggle quote (2 lines)
> + (version "7.0.1")

The patch looks OK, but the 7.2.0 is up there, would you mind updating
please?

Thanks,

Mathieu
M
M
Mathieu Othacehe wrote on 5 Oct 2023 18:32
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
87cyxtuj25.fsf_-_@gnu.org
Toggle quote (3 lines)
> The patch looks OK, but the 7.2.0 is up there, would you mind updating
> please?

I did that myself with 29243a9f39744f6275ba0a9e0a182f257a2a46eb.

Thanks,

Mathieu
Closed
?