[PATCH] gnu: Add stdman.

  • Open
  • quality assurance status badge
Details
One participant
  • Luis Henrique Gomes Higino
Owner
unassigned
Submitted by
Luis Henrique Gomes Higino
Severity
normal
L
L
Luis Henrique Gomes Higino wrote on 17 Jul 2023 00:03
(address . guix-patches@gnu.org)(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
f3715907ce80d9592c104196cb9547af118ec4f8.1689544991.git.luishenriquegh2701@gmail.com
* gnu/packages/cpp.scm (stdman): New variable.
---
Hi Guix,

this commit adds a package for the stdman [0] generated man pages. As they already provide the man pages generated with the latest version on the repository, this package basically clones their repo and moves the pages to the package's output. If you think it's better to build the program and generate the man pages instead, let me know!

Regards,
Luis Higino

gnu/packages/cpp.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ec1f4cd325..d737c4aa76 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2730,3 +2730,34 @@ (define-public tl-optional
the std::optional for C++11/14/17, with support for monadic operations added in
C++23.")
(license license:cc0)))
+
+(define-public stdman
+ (package
+ (name "stdman")
+ (version "2022.07.30")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeaye/stdman")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zbb55v149c76rfrvdxpxv2wrfx7mlfvh1jza7q9vshjak2j06h0"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags #~(list (string-append "--prefix="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'check)
+ (delete 'build))))
+ (home-page "https://github.com/jeaye/stdman")
+ (synopsis "Formatted C++20 stdlib man pages (cppreference)")
+ (description
+ "stdman is a tool that parses archived HTML files from
+cppreference and generates groff-formatted manual pages for Unix-based
+systems. The goal is to provide excellent formatting for easy
+readability.
+
+This package includes the generated man pages.")
+ (license license:expat)))

base-commit: 796c823a0d1d0aec9f4af908eca462e58e5675b5
--
2.41.0
L
L
Luis Henrique Gomes Higino wrote on 17 Jul 2023 00:11
Forgot link
(address . 64672@debbugs.gnu.org)
87edl71p33.fsf@gmail.com
Hi Guix,

forgot to add the link in previous email, it follows below. Also,
I added a link to the cppreference website [1] as I also mentioned
it on the message.


Regards,
--
Luis H. Higino
?