[PATCH] gnu: pantalaimon: Fix media downloads.

  • Open
  • quality assurance status badge
Details
One participant
  • Wojtek Kosior
Owner
unassigned
Submitted by
Wojtek Kosior
Severity
normal
W
W
Wojtek Kosior wrote on 15 Jul 2023 16:22
(address . guix-patches@gnu.org)(name . Wojtek Kosior)(address . koszko@koszko.org)
be243101e647de1de29a6c892f75aecf83180155.1689430948.git.koszko@koszko.org
* gnu/packages/matrix.scm (pantalaimon)[arguments]: Patch incorrect function
invokation that made downloads of attachments impossible
---
gnu/packages/matrix.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 6107dfc979..60c5543e5f 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -259,6 +259,14 @@ (define-public pantalaimon
;; Upgrading python-appdirs requires rebuilting 3000+ packages,
;; when 1.4.4 is a simple maintenance fix from 1.4.3.
(("appdirs >= 1.4.4") "appdirs >= 1.4.3"))))
+ (add-after 'downgrade-appdirs-requirement 'bugfixes
+ (lambda _
+ (substitute* "pantalaimon/daemon.py"
+ ;; FIXME: Remove this once a pantalaimon version with this fix
+ ;; is officially released.
+ ;; https://github.com/matrix-org/pantalaimon/pull/152/commits/d71770ca94981afde8c9be6aaaca951f0685b64e
+ (("client.download\\(server_name, media_id, file_name\\)")
+ "client.download(server_name=server_name, media_id=media_id, filename=file_name)"))))
(add-after 'install 'install-doc
(lambda _
(with-directory-excursion "docs/man"

base-commit: 00ed2901f5171e4f9435641a91678217cae38030
--
2.41.0
W
W
Wojtek Kosior wrote on 22 Dec 2023 16:13
(address . 64651@debbugs.gnu.org)
20231222161328.4c71bee0.koszko@koszko.org
Hello,

a gentle ping here :) It's been over 6 months since I sent this patch.
Does it need any improvements?

Wojtek


-- (sig_start)
fingerprint: E972 7060 E3C5 637C 8A4F 4B42 4BC5 221C 5A79 FD1A

♥ R29kIGlzIHRoZXJlIGFuZCBsb3ZlcyBtZQ== | ÷ c2luIHNlcGFyYXRlZCBtZSBmcm9tIEhpbQ==
? YnV0IEplc3VzIGRpZWQgdG8gc2F2ZSBtZQ== | ? U2hhbGwgSSBiZWNvbWUgSGlzIGZyaWVuZD8=
-- (sig_end)
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQTpcnBg48VjfIpPS0JLxSIcWnn9GgUCZYWnmAAKCRBLxSIcWnn9
GnMHAQCgGiMPFQXCD0QWFyi238npkSXpSleRUmrI9/TvDff9nAD/W4zeeogYECqo
mFiD9SUFoj9lT16cadN7PJ8R0G43OQY=
=hZfd
-----END PGP SIGNATURE-----


?