[PATCH] gnu: Add emacs-speed-type.

  • Done
  • quality assurance status badge
Details
2 participants
  • Abhiseck Paira
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Abhiseck Paira
Severity
normal
A
A
Abhiseck Paira wrote on 15 Jul 2023 08:31
(address . guix-patches@gnu.org)
87edl9wt33.fsf@disroot.org
From 37861dd8272fae95d35573a627802fed1dca7c93 Mon Sep 17 00:00:00 2001
From: Abhiseck Paira <abhiseckpaira@disroot.org>

* gnu/packages/emacs-xyz.scm (emacs-speed-type): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index be4e7aa78e..9f3e91c39f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1920,6 +1920,28 @@ (define-public emacs-typing
you will die. The game builds the list of words from the active buffer.")
(license license:gpl2+))))
+(define-public emacs-speed-type
+ (package
+ (name "emacs-speed-type")
+ (version "20230206.1330")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/" "speed-type-"
+ version ".tar"))
+ (sha256
+ (base32
+ "07xmkjhd4s0ajb8i47rx4s0j0f0y9w4k93zy57wq0sga4xgf3bkv"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/dakra/speed-type")
+ (synopsis "Practice touch/speed typing in GNU Emacs.")
+ (description
+ "Speed-type allows you to practice your touch typing skills. You can
+test yourself by typing snippets from online books or use any piece of text or
+code you have in Emacs. Speed-type keeps track of your stats (WPM, CPM,
+accuracy) while you are typing.")
+ (license license:gpl3+)))
+
(define-public emacs-graphql
(let ((commit "b57b5ca5d2d0837e1fb4a4f30c051d5f3e643f0f")) ;version bump
(package

base-commit: f0ca6346a46c605a590bfd77b84e143a8c759a3b
--
2.41.0


--
Abhiseck Paira
E34E 825B 979E EB9F 8505 F80E E93D 353B 7740 0709
https://paira.in
N
N
Nicolas Goaziou wrote on 2 Sep 2023 23:55
(name . Abhiseck Paira via Guix-patches via)(address . guix-patches@gnu.org)
87a5u48cl5.fsf@nicolasgoaziou.fr
Hello,

Abhiseck Paira via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-speed-type): New variable.

Applied, with the changes noted below. Thank you!

Toggle quote (5 lines)
> +(define-public emacs-speed-type
> + (package
> + (name "emacs-speed-type")
> + (version "20230206.1330")

This version number is specific to MELPA, but does not correspond to
real upstream version. In this case, I changed it to "1.3".

Toggle quote (5 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://melpa.org/packages/" "speed-type-"
> + version ".tar"))

We don't use MELPA as source because the tarballs they produce are not
stable. I used GitHub repository instead.


Regards,

--
Nicolas Goaziou
?