[PATCH] gnu: Add orf-dl.

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 3 Dec 2022 11:20
(address . guix-patches@gnu.org)
f9de1f53c96b16fc7779e8027dcb99b4e43c458a.camel@gmail.com
* gnu/packages/video.scm (orf-dl): New variable.
---
gnu/packages/video.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6e0a1e313c..7a60a76f92 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -167,6 +167,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-web)
+ #:use-module (gnu packages php)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -2444,6 +2445,38 @@ (define-public libvpx-next
(base32
"1x12f2bd4jqd532rnixmwvcx8d29yxiacpcxqqh86qczc49la8gm"))))))
+(define-public orf-dl
+ (let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
+ (revision "1"))
+ (package
+ (name "orf-dl")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpoechtrager/orf_dl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w413miy01cm7rzb5c6wwfdnc2sqv87cvxwikafgrkswpimvdjsk"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan #~`(("orf_dl.php" "bin/orf-dl"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "orf_dl.php"
+ (("ffmpeg")
+ (search-input-file inputs "bin/ffmpeg"))))))))
+ (inputs (list php ffmpeg))
+ (home-page "https://github.com/tpoechtrager/orf_dl")
+ (synopsis "Download videos from tvthek.orf.at")
+ (description "This package provides a PHP-based command line application
+to download videos from Austria's national television broadcaster.")
+ (license license:gpl2+))))
+
(define-public youtube-dl
(package
(name "youtube-dl")
--
2.38.1
L
L
Liliana Marie Prikler wrote on 15 Dec 2022 16:59
(address . 59801-done@debbugs.gnu.org)
f41eddf5b759028c98e956229a0ff2581b1cb4b6.camel@gmail.com
Am Samstag, dem 03.12.2022 um 11:20 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (1 lines)
> * gnu/packages/video.scm (orf-dl): New variable.
Pushed.
Closed
?