Add west requirements.txt dependencies

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Peter Polidoro
Owner
unassigned
Submitted by
Peter Polidoro
Severity
normal
P
P
Peter Polidoro wrote on 25 May 2022 18:43
(address . guix-patches@gnu.org)
865yltftp9.fsf@polidoro.io

P
[PATCH] gnu: Add python-canopen.
(address . 55637@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
5fbd41490624bfb900d276f616be21edaadf724a.1653498609.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-canopen): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6ca759e2e2..35a2009f69 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31743,3 +31743,24 @@ (define-public python-preshed
"Simple but high performance Cython hash table mapping pre-randomized keys
to void* values.")
(license license:expat)))
+
+(define-public python-canopen
+ (package
+ (name "python-canopen")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "canopen" version))
+ (sha256
+ (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
+ (build-system python-build-system)
+ (native-inputs (list python-packaging))
+ (propagated-inputs (list python-can))
+ (home-page "")
+ (synopsis "CANopen stack implementation")
+ (description "A Python implementation of the CANopen standard. The aim of
+the project is to support the most common parts of the CiA 301 standard in a
+simple Pythonic interface. It is mainly targeted for testing and automation
+tasks rather than a standard compliant master implementation.")
+ (license license:expat)))
--
2.36.0
P
[PATCH] gnu: Add python-progress.
(address . 55637@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
a6c3edc9de69547f10d1a288ecc79c1c9916f662.1653499938.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-progress): New variable.
---
gnu/packages/python-xyz.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 35a2009f69..a9fbfcc2f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31764,3 +31764,19 @@ (define-public python-canopen
simple Pythonic interface. It is mainly targeted for testing and automation
tasks rather than a standard compliant master implementation.")
(license license:expat)))
+
+(define-public python-progress
+ (package
+ (name "python-progress")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "progress" version))
+ (sha256
+ (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
+ (build-system python-build-system)
+ (home-page "http://github.com/verigak/progress/")
+ (synopsis "Progress reporting bars for Python")
+ (description "Progress reporting bars for Python")
+ (license license:isc)))
--
2.36.0
P
[PATCH] gnu: Add python-pylink-square.
(address . 55637@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
60db9b9dbccfc6522f1e3e28ff51d0ea74457fad.1653591259.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/embedded.scm (python-pylink-square): New variable.
---
gnu/packages/embedded.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 010f5b84d2..75675c2698 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1699,3 +1699,34 @@ (define-public mbed-tools
connected by USB, checkout Mbed projects and perform builds amongst other
operations.")
(license license:asl2.0)))
+
+(define-public python-pylink-square
+ (package
+ (name "python-pylink-square")
+ (version "0.12.0")
+ (source
+ ;; The tests suite appears to be incomplete in the PyPI archive.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://www.github.com/Square/pylink")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w0pi91gvaw9k2r267kpc1ryd74v19iq5ysn4j7pf4g2069gbgxf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup
+ (lambda _
+ (substitute* "setup.py"
+ (("mock == 2.0.0") "mock")))))))
+ (native-inputs (list python-mock))
+ (propagated-inputs (list python-future
+ python-psutil
+ python-six
+ libjaylink))
+ (home-page "http://www.github.com/Square/pylink")
+ (synopsis "Python interface for SEGGER J-Link.")
+ (description "Python interface for SEGGER J-Link.")
+ (license license:asl2.0)))
--
2.36.0
C
C
Christopher Baines wrote on 27 May 2022 11:22
Re: [bug#55637] [PATCH] gnu: Add python-canopen.
(address . peter@polidoro.io)(address . 55637@debbugs.gnu.org)
878rqntjj8.fsf@cbaines.net
peter@polidoro.io writes:

Toggle quote (37 lines)
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-canopen): New variable.
> ---
> gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 6ca759e2e2..35a2009f69 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31743,3 +31743,24 @@ (define-public python-preshed
> "Simple but high performance Cython hash table mapping pre-randomized keys
> to void* values.")
> (license license:expat)))
> +
> +(define-public python-canopen
> + (package
> + (name "python-canopen")
> + (version "2.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "canopen" version))
> + (sha256
> + (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
> + (build-system python-build-system)
> + (native-inputs (list python-packaging))
> + (propagated-inputs (list python-can))
> + (home-page "")
> + (synopsis "CANopen stack implementation")
> + (description "A Python implementation of the CANopen standard. The aim of
> +the project is to support the most common parts of the CiA 301 standard in a
> +simple Pythonic interface. It is mainly targeted for testing and automation
> +tasks rather than a standard compliant master implementation.")
> + (license license:expat)))

The linter picks up a couple of issues:

gnu/packages/python-xyz.scm:31761:17: python-canopen@2.0.0: sentences in description should be followed by two spaces; possible infractions at 47, 162
gnu/packages/python-xyz.scm:31759:15: python-canopen@2.0.0: invalid home page URL: ""

Plus, I'd avoid adding packages to the end of modules. If everyone does
this, it means lots of git conflicts. Instead, try and slot the new
package definition in somewhere close to related packages, or
alphabetically, or randomly even if neither of those approaches apply.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKQmNtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf4jQ//dnww1oUrCcXgEhLVggVsyFtwgRAs/44w
56DjszKnp47w2kVhBcYXLZ366ppkxkokNylj8C6rSLJaj4fejvYIkxPXbEHt14qU
Fqhn37H4upvQwvuhiE0vyQmQ1Tf7YPZgj0YH0sGGc/972y3xkipqxc7j/lxmChEj
dmAxB+vJNFFcqqnUtWW7FLXrAjUg3lhESUTX13VGAyD1LAYynKwVUF6MJQ6tSU/Y
wgUUaqpC9Huv9l4k1c7omNm7wHfZdiZ8Khyz5ZEw+kH+KMFG5QwJO1mY9CPRwkhQ
cxPDcgdMfcWZzkxPChvQ23TMNTJoT8UvaQ7wqY6xkGOD0hyyZXfuV3FgMH5Zwmp2
brpJvGdDMtenWLnsAlIQ1LK5/zyX9Mo5GtAv0fYiVxzU7+0og/9/NYuSOMv3MqJz
o8FrY05H/9HkMgjHZxdY0Q/wpBVw/lOcHggg3ycU2QK2LP9thbdO0s7GXwb79EUp
M7qv+DUz0ZKDL4zOX4VmDkQF4LB2hOo4OjPN1jQaoffo1QSdqT5kUFCgtKzqkJgr
Pv9rl2a9mdGhdlf/yrfyHhFfYz5DmGc93B8l6pvxGpt4n/Zw6U7Q9Y1hp0ifM7r/
td7jKP6ZoYErYGaGJ0BbtgIdaFFoXkTxz8aQ8oGHPtLBApdp5BrJ7RmyJQtyKsen
1Q8dId+YuxI=
=3SvW
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 27 May 2022 11:24
Re: [bug#55637] [PATCH] gnu: Add python-progress.
(address . peter@polidoro.io)(address . 55637@debbugs.gnu.org)
874k1btjhr.fsf@cbaines.net
peter@polidoro.io writes:

Toggle quote (32 lines)
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-progress): New variable.
> ---
> gnu/packages/python-xyz.scm | 16 ++++++++++++++++
> 1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 35a2009f69..a9fbfcc2f4 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31764,3 +31764,19 @@ (define-public python-canopen
> simple Pythonic interface. It is mainly targeted for testing and automation
> tasks rather than a standard compliant master implementation.")
> (license license:expat)))
> +
> +(define-public python-progress
> + (package
> + (name "python-progress")
> + (version "1.6")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "progress" version))
> + (sha256
> + (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
> + (build-system python-build-system)
> + (home-page "http://github.com/verigak/progress/")
> + (synopsis "Progress reporting bars for Python")
> + (description "Progress reporting bars for Python")
> + (license license:isc)))

The description looks like it could be improved here, plus same comment
about not adding new package definitions to the bottom of files.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKQmRBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdAsA//SfHujGFBgbi4R+R947dSdSM0Ln06JZIh
M7vbU6/RhRb57jJG/ZcOTqXvCpPh0MYyM+bRJ/eLPH109yhxcSmIYOuY9vubLFdo
uzF1N09j/UJI8gsVAZ5BYbDYRUl+Mb9x46VROvXiWG7noT5yPIeka/bO2C5JTrYn
TI3w2068oO2nS8ZAAK+AwezI5m+Sy/JHRHm4RuYEA+1RWH+sAj4Ta/Q22WcwHV2K
zN/vP+Ae/DzG/m+ySvPqGA9JyNCFe4UOMW05CKuBEQvnJzWNKHjm7fZosEg1cnqf
2onRDIxGACNx7H5SsIjlHD0T2ErpGp2QHmWFYl/zuD3AExVnoOw0ADl+1KvKEaFO
lcxdfDfjfK3U2h9zU6Pz6GvMAY02h1ZsVL0pY+bHpl6fm7RJ+EmOz7w8LbFrrRtM
E8/Q1bfrtKjohuOQeGkGL0cW0j9KukQCTPRzEihd5TNJD6BJHZqqmkeUaAfW5jaR
PMP3Y//m9m/Zsz43qG1hIPoyRlaT60uZ6mA7Ca2CInyhEcd813B/VGtXbl20XGwc
AE61b0U01c1LwyrZ4tziTL57SYwOmdUsvofnUzR1osljlTHrCHmCJvuE9FYfzcQU
0sNR9FJIKSncwx7s2gyE1ZQw9Z9dNwlR8ONxeZMoEfjx0npSZl97AusvThH02Rfn
gRof6Up+iSc=
=QAeP
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 27 May 2022 11:26
Re: [bug#55637] [PATCH] gnu: Add python-pylink-square.
(address . peter@polidoro.io)(address . 55637@debbugs.gnu.org)
87zgj3s4sv.fsf@cbaines.net
peter@polidoro.io writes:

Toggle quote (47 lines)
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/embedded.scm (python-pylink-square): New variable.
> ---
> gnu/packages/embedded.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
> index 010f5b84d2..75675c2698 100644
> --- a/gnu/packages/embedded.scm
> +++ b/gnu/packages/embedded.scm
> @@ -1699,3 +1699,34 @@ (define-public mbed-tools
> connected by USB, checkout Mbed projects and perform builds amongst other
> operations.")
> (license license:asl2.0)))
> +
> +(define-public python-pylink-square
> + (package
> + (name "python-pylink-square")
> + (version "0.12.0")
> + (source
> + ;; The tests suite appears to be incomplete in the PyPI archive.
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "http://www.github.com/Square/pylink")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0w0pi91gvaw9k2r267kpc1ryd74v19iq5ysn4j7pf4g2069gbgxf"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:phases (modify-phases %standard-phases
> + (add-after 'unpack 'patch-setup
> + (lambda _
> + (substitute* "setup.py"
> + (("mock == 2.0.0") "mock")))))))
> + (native-inputs (list python-mock))
> + (propagated-inputs (list python-future
> + python-psutil
> + python-six
> + libjaylink))
> + (home-page "http://www.github.com/Square/pylink")
> + (synopsis "Python interface for SEGGER J-Link.")
> + (description "Python interface for SEGGER J-Link.")
> + (license license:asl2.0)))

The description here also looks like it could be improved a bit.

Are you able to send some updated patches?

Also, when sending a few related patches, it's helpful if you get git
send-email to send them as a series, so something like:

git send-email HEAD~3

To send patches for the last 3 commits.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKQmbBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdiCA//fW5hsYc8Qof6Jm7BaIMFidTmu8cxkZFb
nZw8xi3vHVDCWBHk5PlY0i65gOGOHJrSvHKrwkApQ6E6ng6/zr7MbmgxGvk0ocOH
qI3zsb2rhb1yZctoRXGvwCy6gWB6inISQy/0DimuC7FEAb6CQIQSHJaons3CU2Y0
XF4u6dPEsE4ortKlYVh8bLhzQOIgY+Uc3DCmeVO1xVcOw14eRox99skC/MuUKL/k
m8rY7rSmD95LKujNcRNWs1GJYZtjvEHAEHPR8H22PMTa9Zf3G6DjqkyZalaojkrK
sooEgvP2ualztUBFrlyJ0LLVG1U7NTakSUTGekncUf7rnoBAuGBS8n0BtmkByxCF
Va6qKdbtLTcAh9V5WPJRhrhyirfPLZhjYyuXA9LQyl55UP82aa3a5E0n/32ZODXf
yc3ZuOB9gsSpwQVnl8XnmHeZF2AUIWbM/BpUAMpkrpT8YQP/7OKHyEJCrk31rVCH
pSqWljbpVHN8aujFiBWHBMMh9dnx6IaNCEPrxVcpG8ZC/03X0t+9B9N28ZV/KNQv
roDJTm93ha/lkgbPbkF6pb/EYGKgAPM2RYnxRo7T21hvjtU+XE8mFu1fnKnHBfLr
76Tw/tF4cC7x5Cf4ocnlphnWSer6+ZhA5oQIyuzyszdgU88UP+rze14PoO8eaFbB
8YJfw/7n6NY=
=gDuL
-----END PGP SIGNATURE-----

P
P
Peter Polidoro wrote on 27 May 2022 16:50
(name . Christopher Baines)(address . mail@cbaines.net)(address . 55637@debbugs.gnu.org)
86k0a7atpt.fsf@polidoro.io
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (12 lines)
> The description here also looks like it could be improved a bit.
>
> Are you able to send some updated patches?
>
> Also, when sending a few related patches, it's helpful if you
> get git
> send-email to send them as a series, so something like:
>
> git send-email HEAD~3
>
> To send patches for the last 3 commits.

Thank you for your great suggestions, I will send updated patches
as soon as I get a chance.

I misnamed this patch series. I thought, at first, that I was
adding more dependencies to the 'west' package, but that is not
quite correct.

West is a Python tool that can help build Zephyr RTOS projects.
West is only optional for building Zephyr RTOS projects, though,
and much of its functionality could perhaps be replaced by Guix.
West provides a multiple repository management system, inspired by
Google's Repo tool and Git submodules. I think it would be much
more elegant to use Guix for managing the multiple repositories
and their dependencies instead of West. I do not yet know enough
about how the Zephyr ecosystem works, nor am I yet a good enough
Guix package writer, to figure out how to replace totally replace
West with Guix.

An intermediate step might be for me to create a simple Zephyr
package that installs the dependencies needed to build Zephyr
projects. Normally these dependencies are installed using apt
packages and Python requirements.txt files, as you can see in this
Zephyr getting started guide:


I am not yet sure how many dependencies I will need to write Guix
packages for and how long it will take. Should I just keep
emailing patches to this debbug number until I get to the final
zephyr package patch or is that annoying? Would you prefer I wait
until I have all of the packages figured out and then send them
all as one big patch series using git send-email as you suggested?

On a side note, do you happen to know how to setup git send-email
to work with pass, the standard unix password manager, instead of
the normal .git-credentials file? I would prefer not having my
password stored in a plain text file in my home directory. I tried
following this guide, but could not get it to work:


Thank you for your time!
P
[PATCH] gnu: Add python-canopen.
(address . 55637@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
18cb9db1fe8214e9dd37a70746252e8f118890c0.1653676589.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-canopen): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44eeb0d7fe..3ae14765dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2248,6 +2248,27 @@ (define-public python-can
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))
+(define-public python-canopen
+ (package
+ (name "python-canopen")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "canopen" version))
+ (sha256
+ (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
+ (build-system python-build-system)
+ (native-inputs (list python-packaging))
+ (propagated-inputs (list python-can))
+ (home-page "https://github.com/christiansandberg/canopen")
+ (synopsis "CANopen stack implementation")
+ (description "A Python implementation of the CANopen standard. The aim of
+the project is to support the most common parts of the CiA 301 standard in a
+simple Pythonic interface. It is mainly targeted for testing and automation
+tasks rather than a standard compliant master implementation.")
+ (license license:expat)))
+
(define-public python-caniusepython3
(package
(name "python-caniusepython3")
--
2.36.0
P
[PATCH] gnu: Add python-progress.
(address . 55637@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
29380d8edaa09ee05fa7525107aa95063c108793.1653677770.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-progress): New variable.
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44eeb0d7fe..d226ff94b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15226,6 +15226,25 @@ (define-public python-promise
"Promises/A+ implementation for Python")
(license license:expat)))
+(define-public python-progress
+ (package
+ (name "python-progress")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "progress" version))
+ (sha256
+ (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
+ (build-system python-build-system)
+ (home-page "http://github.com/verigak/progress/")
+ (synopsis "Progress reporting bars for Python")
+ (description "This Python package provides progress reporting for visual
+of progress of long running operations. There are multiple choices of
+progress bars and spinners, with customizable options, such as width, fill
+character, and suffix.")
+ (license license:isc)))
+
(define-public python-progressbar2
(package
(name "python-progressbar2")
--
2.36.0
L
L
Ludovic Courtès wrote on 6 Jun 2022 22:19
Re: bug#55637: Add west requirements.txt dependencies
(address . peter@polidoro.io)(address . 55637@debbugs.gnu.org)
87sfohbl44.fsf_-_@gnu.org
Hi,

peter@polidoro.io skribis:

Toggle quote (4 lines)
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-canopen): New variable.

Toggle diff (19 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 312a365fb7..56552b12c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2086,9 +2086,12 @@ (define-public python-canopen
(propagated-inputs (list python-can))
(home-page "https://github.com/christiansandberg/canopen")
(synopsis "CANopen stack implementation")
- (description "A Python implementation of the CANopen standard. The aim of
-the project is to support the most common parts of the CiA 301 standard in a
-simple Pythonic interface. It is mainly targeted for testing and automation
+ (description
+ "This package provides a Python implementation of the
+@uref{https://www.can-cia.org/canopen/,CANopen standard} for
+@acronym{CAN, controller-area networks}. The aim of the project is to
+support the most common parts of the CiA 301 standard in a simple
+Pythonic interface. It is mainly targeted for testing and automation
tasks rather than a standard compliant master implementation.")
(license license:expat)))
L
L
Ludovic Courtès wrote on 6 Jun 2022 22:21
(address . peter@polidoro.io)(address . 55637-done@debbugs.gnu.org)
87o7z5bl0k.fsf_-_@gnu.org
peter@polidoro.io skribis:

Toggle quote (4 lines)
> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-progress): New variable.

Applied, thanks!

Please open a new issue if there are followup patches.

Ludo’.
Closed
?