[PATCH] gnu: Add r-pscbs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 24 May 2022 20:08
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220524180850.3381234-1-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-pscbs): New variable.
---
gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 80cf28c954..7fed1aa18b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4560,6 +4560,48 @@ (define-public r-pcamethods
structure (pcaRes) to provide a common interface to the PCA results.")
(license license:gpl3+)))
+;; This is a CRAN package, but it depends on a Bioconductor package:
+;; r-aroma-light, r-dnacopy..
+(define-public r-pscbs
+ (package
+ (name "r-pscbs")
+ (version "0.66.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "PSCBS" version))
+ (sha256
+ (base32 "14rs2wywipbkia3dbzfhpnkmfgdvm2bf586lggsx63sywlv5d02q"))))
+ (properties `((upstream-name . "PSCBS")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'change-home-dir
+ (lambda _
+ ;; Change from /homeless-shelter to /tmp for write permission.
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list r-aroma-light
+ r-dnacopy
+ r-future
+ r-listenv
+ r-matrixstats
+ r-r-cache
+ r-r-methodss3
+ r-r-oo
+ r-r-utils))
+ (native-inputs
+ (list r-r-rsp ;used to build vignettes
+ r-r-devices))
+ (home-page "https://github.com/HenrikBengtsson/PSCBS")
+ (synopsis "Analysis of Parent-Specific DNA Copy Numbers")
+ (description
+ "Segmentation of allele-specific DNA copy number data and detection of
+regions with abnormal copy number within each parental chromosome. Both
+tumor-normal paired and tumor-only analyses are supported.")
+ (license license:gpl2+)))
+
(define-public r-protgenerics
(package
(name "r-protgenerics")

base-commit: 01793ed03e8aa0960bff7adc21fd270e1527e68e
--
2.36.0
R
R
Ricardo Wurmus wrote on 24 May 2022 23:29
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 55615-done@debbugs.gnu.org)
87wneahb5b.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-pscbs): New variable.

Applied with formatting changes. Thanks!

--
Ricardo
Closed
Z
Z
zimoun wrote on 25 May 2022 09:31
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 55615-done@debbugs.gnu.org)
CAJ3okZ2a=_hbzvZTkdMZ9PK_pXgis8NTvg1P4dXrCKS=1bth1w@mail.gmail.com
Hi,

On Tue, 24 May 2022 at 23:30, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (2 lines)
> Applied with formatting changes. Thanks!

Indeed, sorry. I reformatted the output of "guix import" but then I
forgot to reformat again the phase modification (my bad!). And I ran
"guix lint" which reported nothing. But "guix style" reformats;
which I do not use (yet).

Well, it is many manual error-prone steps. My questions are :

1. Could we adapted "guix import cran" to output something using the
format of "guix style"?
2. Could we add a checker in "guix lint" using "guix style" and warn?


Cheers,
simon
Closed
R
R
Ricardo Wurmus wrote on 27 May 2022 10:12
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 55615-done@debbugs.gnu.org)
87zgj3cs09.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (16 lines)
> Hi,
>
> On Tue, 24 May 2022 at 23:30, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> Applied with formatting changes. Thanks!
>
> Indeed, sorry. I reformatted the output of "guix import" but then I
> forgot to reformat again the phase modification (my bad!). And I ran
> "guix lint" which reported nothing. But "guix style" reformats;
> which I do not use (yet).
>
> Well, it is many manual error-prone steps. My questions are :
>
> 1. Could we adapted "guix import cran" to output something using the
> format of "guix style"?

How about this:
From a10afc4c60ce734941c3c080cf13ec6636f0be33 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Fri, 27 May 2022 10:07:26 +0200
Subject: [PATCH] scripts/import: Use pretty printer from (guix scripts style).

* guix/scripts/import.scm (guix-import): Use pretty-print-with-comments.
(newline-rewriting-port): Remove procedure.
---
guix/scripts/import.scm | 39 +++------------------------------------
1 file changed, 3 insertions(+), 36 deletions(-)

Toggle diff (76 lines)
diff --git a/guix/scripts/import.scm b/guix/scripts/import.scm
index fa79f3211e..62aa7bdbc5 100644
--- a/guix/scripts/import.scm
+++ b/guix/scripts/import.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 David Thompson <davet@gnu.org>
;;; Copyright © 2018 Kyle Meyer <kyle@kyleam.com>
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -25,6 +25,7 @@
(define-module (guix scripts import)
#:use-module (guix ui)
#:use-module (guix scripts)
+ #:use-module (guix scripts style)
#:use-module (guix utils)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-11)
@@ -32,41 +33,9 @@ (define-module (guix scripts import)
#:use-module (srfi srfi-37)
#:use-module (ice-9 format)
#:use-module (ice-9 match)
- #:use-module (ice-9 pretty-print)
#:export (%standard-import-options
guix-import))
-
-;;;
-;;; Helper.
-;;;
-
-(define (newline-rewriting-port output)
- "Return an output port that rewrites strings containing the \\n escape
-to an actual newline. This works around the behavior of `pretty-print'
-and `write', which output these as \\n instead of actual newlines,
-whereas we want the `description' field to contain actual newlines
-rather than \\n."
- (define (write-string str)
- (let loop ((chars (string->list str)))
- (match chars
- (()
- #t)
- ((#\\ #\n rest ...)
- (newline output)
- (loop rest))
- ((chr rest ...)
- (write-char chr output)
- (loop rest)))))
-
- (make-soft-port (vector (cut write-char <>)
- write-string
- (lambda _ #t) ; flush
- #f
- (lambda _ #t) ; close
- #f)
- "w"))
-
;;;
;;; Command line options.
@@ -119,9 +88,7 @@ (define-command (guix-import . args)
((importer args ...)
(if (member importer importers)
(let ((print (lambda (expr)
- (pretty-print expr (newline-rewriting-port
- (current-output-port))
- #:max-expr-width 80))))
+ (pretty-print-with-comments (current-output-port) expr))))
(match (apply (resolve-importer importer) args)
((and expr (or ('package _ ...)
('let _ ...)
--
2.36.1
--
Ricardo
Closed
Z
Z
zimoun wrote on 1 Jun 2022 11:02
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 55615-done@debbugs.gnu.org)
CAJ3okZ3Y17i=5=nguFRg0=W50JK3J-QaSiQy3qyXKYPuZC=z7w@mail.gmail.com
Hi Ricardo,

On Fri, 27 May 2022 at 10:13, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (2 lines)
> How about this:

I am late and you already applied it. Cool! :-)

Thanks,
simon
Closed
?