[PATCH] tests: Fix wrong target triplets.

  • Done
  • quality assurance status badge
Details
2 participants
  • Josselin Poiret
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Josselin Poiret
Severity
normal
J
J
Josselin Poiret wrote on 24 May 2022 17:55
(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
20220524155522.16154-1-dev@jpoiret.xyz
* tests/gexp.scm (ungexp + ungexp-native,
input list + ungexp-native,
input list splicing + ungexp-native-splicing,
gexp list splicinng + ungexp-splicing,
gexp->derivation, cross-compilation,
gexp->derivation, ungexp-native,
gexp->derivation, ungexp + ungexp-native,
gexp->derivation, ungexp-native + composed gexps): Change
mips64el-linux to mips64el-linux-gnu.
* tests/guix-pack.sh: Change arm-unknown-linux-gnueabihf to
arm-linux-gnueabihf.
---
tests/gexp.scm | 12 ++++++------
tests/guix-pack.sh | 2 +-
2 files changed, 7 insertions(+), 7 deletions(-)

Toggle diff (73 lines)
diff --git a/tests/gexp.scm b/tests/gexp.scm
index 35bd99e6d4..07e940ffdc 100644
--- a/tests/gexp.scm
+++ b/tests/gexp.scm
@@ -502,7 +502,7 @@ (define (match-input thing)
(ungexp coreutils)
(ungexp-native glibc)
(ungexp binutils))))
- (target "mips64el-linux")
+ (target "mips64el-linux-gnu")
(guile (derivation->output-path
(package-derivation %store %bootstrap-guile)))
(cu (derivation->output-path
@@ -547,7 +547,7 @@ (define (match-input thing)
(gexp->sexp* exp)))))
(test-assert "input list + ungexp-native"
- (let* ((target "mips64el-linux")
+ (let* ((target "mips64el-linux-gnu")
(exp (gexp (display
(cons '(ungexp-native (list %bootstrap-guile coreutils))
'(ungexp (list glibc binutils))))))
@@ -764,7 +764,7 @@ (define guile ,guile)
intd)))))
(test-assertm "gexp->derivation, cross-compilation"
- (mlet* %store-monad ((target -> "mips64el-linux")
+ (mlet* %store-monad ((target -> "mips64el-linux-gnu")
(exp -> (gexp (list (ungexp coreutils)
(ungexp output))))
(xdrv (gexp->derivation "foo" exp
@@ -778,7 +778,7 @@ (define guile ,guile)
(not (member (derivation-file-name cu) refs))))))
(test-assertm "gexp->derivation, ungexp-native"
- (mlet* %store-monad ((target -> "mips64el-linux")
+ (mlet* %store-monad ((target -> "mips64el-linux-gnu")
(exp -> (gexp (list (ungexp-native coreutils)
(ungexp output))))
(xdrv (gexp->derivation "foo" exp
@@ -788,7 +788,7 @@ (define guile ,guile)
(derivation-file-name xdrv)))))
(test-assertm "gexp->derivation, ungexp + ungexp-native"
- (mlet* %store-monad ((target -> "mips64el-linux")
+ (mlet* %store-monad ((target -> "mips64el-linux-gnu")
(exp -> (gexp (list (ungexp-native coreutils)
(ungexp glibc)
(ungexp output))))
@@ -802,7 +802,7 @@ (define guile ,guile)
(member (derivation-file-name xglibc) refs)))))
(test-assertm "gexp->derivation, ungexp-native + composed gexps"
- (mlet* %store-monad ((target -> "mips64el-linux")
+ (mlet* %store-monad ((target -> "mips64el-linux-gnu")
(exp0 -> (gexp (list 1 2
(ungexp coreutils))))
(exp -> (gexp (list 0 (ungexp-native exp0))))
diff --git a/tests/guix-pack.sh b/tests/guix-pack.sh
index 1356a74083..f19a0f754e 100644
--- a/tests/guix-pack.sh
+++ b/tests/guix-pack.sh
@@ -107,7 +107,7 @@ guix pack --dry-run --bootstrap -f docker -S /opt/gnu=/ guile-bootstrap
# Build a tarball pack of cross-compiled software. Use coreutils because
# guile-bootstrap is not intended to be cross-compiled.
-guix pack --dry-run --bootstrap --target=arm-unknown-linux-gnueabihf coreutils
+guix pack --dry-run --bootstrap --target=arm-linux-gnueabihf coreutils
# Likewise, 'guix pack -R' requires a full-blown toolchain (because
# 'glibc-bootstrap' lacks 'libc.a'), hence '--dry-run'.
--
2.36.0
M
M
Mathieu Othacehe wrote on 25 May 2022 09:29
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 55614-done@debbugs.gnu.org)
87a6b6xe6x.fsf@gnu.org
Hey Josselin,

Toggle quote (6 lines)
> gexp->derivation, ungexp + ungexp-native,
> gexp->derivation, ungexp-native + composed gexps): Change
> mips64el-linux to mips64el-linux-gnu.
> * tests/guix-pack.sh: Change arm-unknown-linux-gnueabihf to
> arm-linux-gnueabihf.

Pushed, thanks for fixing it :)

Mathieu
Closed
?