[PATCH 1/1] gnu: Add python-spherical-geometry

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 24 May 2022 00:52
(address . guix-patches@gnu.org)
CAO+9K5qMhpw=FqMgVQX-sytaEFT+bxXNxtWC94WxsEgbx8Ot2w@mail.gmail.com
Hi Guix team,
This patch ads astronomical Python libary spherical_geometry
Sharlatan Hellseher (1):
gnu: Add python-spherical-geometry
gnu/packages/astronomy.scm | 50 ++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)
base-commit: 00be2fcb0b79641790a793df7640344e96283a2a
Pending astronomical patches:
- https://issues.guix.gnu.org/48454(assay - custom test suit for soem
packed astronomical packages with tests disbled)
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 2c838787dd751a5695ea31accd2738eafc96ceb8 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 23 May 2022 23:44:58 +0100
Subject: [PATCH 1/1] gnu: Add python-spherical-geometry

* gnu/packages/astronomy.scm (python-spherical-geometry): New variable.
---
gnu/packages/astronomy.scm | 50 ++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c209b1538f..fc09a55f7a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -48,6 +48,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages multiprecision)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -68,6 +69,7 @@ (define-module (gnu packages astronomy)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix gexp)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -925,6 +927,54 @@ (define-public python-astral
elevation, solar azimuth, rahukaalam, and the phases of the moon.")
(license license:asl2.0)))
+(define-public python-spherical-geometry
+ (package
+ (name "python-spherical-geometry")
+ (version "1.2.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spacetelescope/spherical_geometry")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kzcncqir4v7nhk9lxj9gxr32p3krkaqa58y2i4kksgxxy24qw4z"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ ;; NOTE: (Sharlatan-20220523T231348+0100): Tests depends on old Python2
+ ;; libarry `sphere'
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'preparations
+ (lambda _
+ ;; Fixing: setuptools-scm was unable to detect version for ...
+ (substitute* "setup.py"
+ (("use_scm_version=True")
+ (format #f "version=~s" #$version))
+ (("setup_requires=\\['setuptools_scm'\\],.*")
+ ""))
+ ;; Use our own libraries in place of bundles.
+ (setenv "USE_SYSTEM_QD" "1"))))))
+ (native-inputs
+ (list python-pytest
+ python-setuptools-scm))
+ (inputs
+ (list qd))
+ (propagated-inputs
+ (list python-astropy
+ python-numpy))
+ (home-page "https://github.com/spacetelescope/tweakwcs")
+ (synopsis "Python astronimical package for handling spherical polygons")
+ (description
+ "The @code{spherical_geometry} library is a Python package for handling
+spherical polygons that represent arbitrary regions of the sky.")
+ ;; LICENSE.rst Association of Universities for Research in Astronomy (AURA)
+ ;; QD_LIBRARY_LICENSE.rst for bandeled QD source
+ (license license:bsd-3)))
+
(define-public libnova
(package
(name "libnova")
--
2.36.0
S
S
Sharlatan Hellseher wrote on 14 Aug 2022 18:35
(address . 55604@debbugs.gnu.org)
CAO+9K5qr-Z6emMTEomSAvhTC8YTYMHTsnCspfjrMTejo+YYx1A@mail.gmail.com
Hi Guix team!
A gentle ping for reviewing of this package :)
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
L
L
Ludovic Courtès wrote on 24 Feb 2023 23:55
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 55604-done@debbugs.gnu.org)
87bkli1xmu.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> From 2c838787dd751a5695ea31accd2738eafc96ceb8 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Mon, 23 May 2022 23:44:58 +0100
> Subject: [PATCH 1/1] gnu: Add python-spherical-geometry
>
> * gnu/packages/astronomy.scm (python-spherical-geometry): New variable.

Finally applied, thanks!

Ludo’.
Closed
?